summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/audio-entropyd/ChangeLog8
-rw-r--r--media-sound/audio-entropyd/audio-entropyd-2.0.3.ebuild35
-rw-r--r--media-sound/audio-entropyd/files/audio-entropyd-1.0.5-ldflags.patch11
-rw-r--r--media-sound/audio-entropyd/files/audio-entropyd-1.0.5-uclibc.patch27
-rw-r--r--media-sound/audio-entropyd/files/audio-entropyd.conf-116
-rw-r--r--media-sound/audio-entropyd/files/audio-entropyd.init-127
6 files changed, 42 insertions, 82 deletions
diff --git a/media-sound/audio-entropyd/ChangeLog b/media-sound/audio-entropyd/ChangeLog
index 95c0d3ec02da..3d2df24b8543 100644
--- a/media-sound/audio-entropyd/ChangeLog
+++ b/media-sound/audio-entropyd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audio-entropyd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.38 2011/03/02 19:54:41 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.39 2011/04/18 15:08:28 angelos Exp $
+
+*audio-entropyd-2.0.3 (18 Apr 2011)
+
+ 18 Apr 2011; Christoph Mende <angelos@gentoo.org>
+ +audio-entropyd-2.0.3.ebuild:
+ Version bump
02 Mar 2011; <angelos@gentoo.org> -audio-entropyd-1.0.5.ebuild:
Removed old
diff --git a/media-sound/audio-entropyd/audio-entropyd-2.0.3.ebuild b/media-sound/audio-entropyd/audio-entropyd-2.0.3.ebuild
new file mode 100644
index 000000000000..9010b45b49e8
--- /dev/null
+++ b/media-sound/audio-entropyd/audio-entropyd-2.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/audio-entropyd-2.0.3.ebuild,v 1.1 2011/04/18 15:08:28 angelos Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Audio-entropyd generates entropy-data for the /dev/random device."
+HOMEPAGE="http://www.vanheusden.com/aed/"
+SRC_URI="http://www.vanheusden.com/aed/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-audio-entropyd )
+ media-sound/alsa-utils"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.1-uclibc.patch" \
+ "${FILESDIR}/${PN}-2.0.1-ldflags.patch"
+ sed -i -e "s:^OPT_FLAGS=.*:OPT_FLAGS=${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin audio-entropyd
+ dodoc README TODO
+ newinitd "${FILESDIR}/${PN}.init-2" ${PN}
+ newconfd "${FILESDIR}/${PN}.conf-2" ${PN}
+}
diff --git a/media-sound/audio-entropyd/files/audio-entropyd-1.0.5-ldflags.patch b/media-sound/audio-entropyd/files/audio-entropyd-1.0.5-ldflags.patch
deleted file mode 100644
index b0446b1919e1..000000000000
--- a/media-sound/audio-entropyd/files/audio-entropyd-1.0.5-ldflags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2009-02-09 18:01:37.884656874 +0100
-+++ Makefile 2009-02-09 18:01:44.412654720 +0100
-@@ -12,7 +12,7 @@
- all: $(TARGETS)
-
- audio-entropyd: snd_dev.o audio-entropyd.o error.o proc.o val.o RNGTEST.o error.o
-- $(CC) -o $@ $^ $(LFLAGS)
-+ $(CC) $(LDFLAGS) -o $@ $^ $(LFLAGS)
-
- install: audio-entropyd
- cp audio-entropyd /usr/local/sbin/
diff --git a/media-sound/audio-entropyd/files/audio-entropyd-1.0.5-uclibc.patch b/media-sound/audio-entropyd/files/audio-entropyd-1.0.5-uclibc.patch
deleted file mode 100644
index bdf5adeff825..000000000000
--- a/media-sound/audio-entropyd/files/audio-entropyd-1.0.5-uclibc.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- audio-entropyd-1.0.1.orig/error.c 2008-01-22 09:50:28 +0000
-+++ audio-entropyd-1.0.1/error.c 2008-01-22 09:53:51 +0000
-@@ -9,13 +9,13 @@
- #include <signal.h>
- #include <syslog.h>
- #include <regex.h>
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) && !defined(__UCLIBC__)
- #include <execinfo.h>
- #endif
-
- void print_trace(void)
- {
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) && !defined(__UCLIBC__)
- void *array[MAX_BACKTRACE_LENGTH];
- size_t size;
-
-@@ -39,7 +39,7 @@
- printf("\n\n\nDebug information:\n");
- if (errno) fprintf(stderr, "errno: %d=%s (if applicable)\n", errno, strerror(errno));
-
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) && !defined(__UCLIBC__)
- print_trace();
- #endif
-
diff --git a/media-sound/audio-entropyd/files/audio-entropyd.conf-1 b/media-sound/audio-entropyd/files/audio-entropyd.conf-1
deleted file mode 100644
index 75bdbcbe4756..000000000000
--- a/media-sound/audio-entropyd/files/audio-entropyd.conf-1
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/files/audio-entropyd.conf-1,v 1.1 2009/11/12 09:54:21 angelos Exp $
-
-# /etc/conf.d/audio-entropyd
-
-# The acceptable values are DEVICE, READSIZE and SAMPLERATE
-# These defaults give the optimum entropy
-
-#DEVICE="/dev/dsp"
-
-#READSIZE *must* be a power of 2
-READSIZE="65536"
-
-#SAMPLERATE must be a valid sampling rate of your audio source
-SAMPLERATE="44050"
diff --git a/media-sound/audio-entropyd/files/audio-entropyd.init-1 b/media-sound/audio-entropyd/files/audio-entropyd.init-1
deleted file mode 100644
index 9f58d3474269..000000000000
--- a/media-sound/audio-entropyd/files/audio-entropyd.init-1
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/files/audio-entropyd.init-1,v 1.1 2009/11/12 09:54:21 angelos Exp $
-
-depend() {
- need modules
- use alsa
-}
-
-start() {
- local params=""
- [ -n "$DEVICE" ] && params="$params -d $DEVICE"
- [ -n "$READSIZE" ] && params="$params -r $READSIZE"
- [ -n "$SAMPLERATE" ] && params="$params -N $SAMPLERATE"
-
- ebegin "Starting audio entropy gathering daemon"
- start-stop-daemon --start --quiet --pidfile /var/run/audio-entropyd.pid \
- --exec /usr/sbin/audio-entropyd -- ${params}
- eend ${?}
-}
-
-stop() {
- ebegin "Stopping audio entropy gathering daemon"
- start-stop-daemon --stop --quiet --pidfile /var/run/audio-entropyd.pid
- eend ${?}
-}