summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/cavezofphear/ChangeLog11
-rw-r--r--games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild36
-rw-r--r--games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch36
3 files changed, 80 insertions, 3 deletions
diff --git a/games-arcade/cavezofphear/ChangeLog b/games-arcade/cavezofphear/ChangeLog
index 16d9b7ab1b7f..abbcee4ca3e9 100644
--- a/games-arcade/cavezofphear/ChangeLog
+++ b/games-arcade/cavezofphear/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/cavezofphear
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/cavezofphear/ChangeLog,v 1.11 2009/09/05 15:04:05 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cavezofphear/ChangeLog,v 1.12 2013/01/18 07:41:02 mr_bones_ Exp $
+
+*cavezofphear-0.5.1 (18 Jan 2013)
+
+ 18 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +cavezofphear-0.5.1.ebuild, +files/cavezofphear-0.5.1-gentoo.patch:
+ version bump (bug #452314)
05 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org>
cavezofphear-0.5.ebuild, files/cavezofphear-0.5-gentoo.patch:
@@ -39,4 +45,3 @@
08 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org>
cavezofphear-0.1.ebuild:
initial commit (bug 32507)
-
diff --git a/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild b/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild
new file mode 100644
index 000000000000..29a6c7f81e83
--- /dev/null
+++ b/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cavezofphear/cavezofphear-0.5.1.ebuild,v 1.1 2013/01/18 07:41:02 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A boulder dash / digger-like game for console using ncurses"
+HOMEPAGE="http://www.x86.no/cavezofphear/"
+SRC_URI="http://www.x86.no/${PN}/${P/cavezof}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/cavezof/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:get_data_dir(.):\"${GAMES_DATADIR}/${PN}/\":" \
+ src/{chk.c,main.c,gplot.c} \
+ || die
+}
+
+src_install() {
+ dogamesbin src/phear
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ dodoc ChangeLog README* TODO
+ prepgamesdirs
+}
diff --git a/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch
new file mode 100644
index 000000000000..ab8bd41d3f35
--- /dev/null
+++ b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch
@@ -0,0 +1,36 @@
+diff -ru phear-0.5.1.orig/Makefile phear-0.5.1/Makefile
+--- phear-0.5.1.orig/Makefile 2007-02-27 06:21:55.000000000 -0500
++++ phear-0.5.1/Makefile 2013-01-18 02:09:56.403224104 -0500
+@@ -2,7 +2,7 @@
+ DESTDIR_DATA = /usr/local/share
+
+ make:
+- cd src && make
++ $(MAKE) -C src phear
+ clean:
+ rm -f phear editor
+ install:
+diff -ru phear-0.5.1.orig/src/Makefile phear-0.5.1/src/Makefile
+--- phear-0.5.1.orig/src/Makefile 2011-12-12 07:26:03.000000000 -0500
++++ phear-0.5.1/src/Makefile 2013-01-18 02:10:48.218423433 -0500
+@@ -2,10 +2,8 @@
+
+ DESTDIR = ..
+
+-CC = gcc
+ INSTALL = install
+-CFLAGS ?= -s -Wall -O2
+-LDFLAGS += -lncurses
++LDLIBS = -lncurses
+
+ all: phear install clean
+
+@@ -13,7 +11,7 @@
+ $(CC) $(CFLAGS) -c $^ -o $@
+
+ phear: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^ ${LDFLAGS}
++ $(CC) $(CFLAGS) -o $@ $^ ${LDFLAGS} $(LDLIBS)
+
+ install: install-game
+