summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/pidgin-opensteamworks/ChangeLog8
-rw-r--r--x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.3-Makefile33
-rw-r--r--x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.3.ebuild46
3 files changed, 86 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-opensteamworks/ChangeLog b/x11-plugins/pidgin-opensteamworks/ChangeLog
index b47c3c73a09d..2d388adbac6b 100644
--- a/x11-plugins/pidgin-opensteamworks/ChangeLog
+++ b/x11-plugins/pidgin-opensteamworks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-opensteamworks
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.19 2013/08/18 23:01:36 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.20 2013/09/05 10:10:00 hasufell Exp $
+
+*pidgin-opensteamworks-1.3 (05 Sep 2013)
+
+ 05 Sep 2013; Julian Ospald <hasufell@gentoo.org>
+ +files/pidgin-opensteamworks-1.3-Makefile, +pidgin-opensteamworks-1.3.ebuild:
+ version bump wrt #483664
*pidgin-opensteamworks-1.0_p68 (18 Aug 2013)
diff --git a/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.3-Makefile b/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.3-Makefile
new file mode 100644
index 000000000000..a71ece054234
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.3-Makefile
@@ -0,0 +1,33 @@
+CC ?= gcc
+PKG_CONFIG ?= pkg-config
+INSTALL = install
+INSTALL_PROGRAM = $(INSTALL) -Dm755
+
+PLUGINDIR ?= $(shell $(PKG_CONFIG) --variable=plugindir purple)
+
+CFLAGS ?= -O2 -pipe
+CFLAGS += -Wall -fPIC
+LDFLAGS += -shared
+CPPFLAGS += $(shell $(PKG_CONFIG) --cflags glib-2.0 json-glib-1.0 purple nss gnome-keyring-1)
+LIBS += $(shell $(PKG_CONFIG) --libs glib-2.0 json-glib-1.0 purple nss)
+
+TARGET = libsteam.so
+
+OBJS = libsteam.o steam_connection.o
+
+%.o: %.c %.h
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $*.c
+
+$(TARGET): $(OBJS)
+ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS) $(LIBS)
+
+install: $(TARGET)
+ $(INSTALL_PROGRAM) $(TARGET) "$(DESTDIR)$(PLUGINDIR)/$(TARGET)"
+
+uninstall:
+ rm -f "$(DESTDIR)$(PLUGINDIR)/$(TARGET)"
+
+clean:
+ rm -f $(OBJS) $(TARGET)
+
+.PHONY: uninstall clean
diff --git a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.3.ebuild b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.3.ebuild
new file mode 100644
index 000000000000..0d63cd63b8ae
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.3.ebuild,v 1.1 2013/09/05 10:10:00 hasufell Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Steam protocol plugin for pidgin"
+HOMEPAGE="http://code.google.com/p/pidgin-opensteamworks/"
+SRC_URI="http://pidgin-opensteamworks.googlecode.com/files/steam-mobile-${PV}.tar.bz2
+ http://pidgin-opensteamworks.googlecode.com/files/icons.zip
+ -> ${PN}-icons.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/nss
+ gnome-base/libgnome-keyring
+ net-im/pidgin"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CC PKG_CONFIG
+ fi
+}
+
+src_prepare() {
+ # see http://code.google.com/p/pidgin-opensteamworks/issues/detail?id=31
+ cp "${FILESDIR}"/${P}-Makefile "${S}"/Makefile || die
+}
+
+src_install() {
+ default
+ insinto /usr/share/pixmaps/pidgin/protocols
+ doins -r "${WORKDIR}"/{16,48}
+}