summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--current-packages8
-rw-r--r--net-misc/dhcp/dhcp-3.0_beta0207.ebuild73
-rw-r--r--net-nds/openldap/files/digest-openldap-2.0.71
-rw-r--r--net-nds/openldap/openldap-2.0.7.ebuild50
-rw-r--r--net-nds/ypbind/files/digest-ypbind-1.71
-rw-r--r--net-nds/ypbind/ypbind-1.7.ebuild37
-rw-r--r--net-print/LPRng/LPRng-3.6.26.ebuild45
-rw-r--r--net-print/LPRng/files/digest-LPRng-3.6.261
-rw-r--r--net-www/cocoon/cocoon-1.8.ebuild51
-rw-r--r--net-www/cocoon/files/digest-cocoon-1.81
-rw-r--r--x11-wm/enlightenment/enlightenment-0.16.5.ebuild39
-rw-r--r--x11-wm/enlightenment/files/digest-enlightenment-0.16.51
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-0.33.11
-rw-r--r--x11-wm/sawfish/sawfish-0.33.1.ebuild41
14 files changed, 349 insertions, 1 deletions
diff --git a/current-packages b/current-packages
index 225d0d5925ca..27b40f30f51e 100644
--- a/current-packages
+++ b/current-packages
@@ -331,6 +331,7 @@
#./net-misc/bind/bind-8.2.2.5-r1.ebuild
./net-misc/bind/bind-9.0.1.ebuild
./net-misc/dhcp/dhcp-3.0_beta0206.ebuild
+#!./net-misc/dhcp/dhcp-3.0_beta0207.ebuild
./net-misc/hylafax/hylafax-cvs-000614-r1.ebuild
./net-misc/ipchains-firewall/ipchains-firewall-1.7.0-r1.ebuild
./net-misc/netkit-bootpd/netkit-bootpd-0.17-r1.ebuild
@@ -351,17 +352,20 @@
./net-misc/wget/wget-1.5.3-r1.ebuild
./net-misc/whois/whois-4.5.1.ebuild
./net-nds/openldap/openldap-1.2.11-r1.ebuild
-#./net-nds/openldap/openldap-2.0.1.ebuild
+#./net-nds/openldap/openldap-2.0.7.ebuild
./net-nds/portmap/portmap-5b-r1.ebuild
./net-nds/yp-tools/yp-tools-2.4-r1.ebuild
./net-nds/ypbind/ypbind-1.6-r1.ebuild
+#!./net-nds/ypbind/ypbind-1.7.ebuild
./net-nds/ypserv/ypserv-1.3.9-r1.ebuild
#!./net-print/gtklp/gtklp-0.6d.ebuidl
./net-print/LPRng/LPRng-3.6.24.ebuild
+#!./net-print/LPRng/LPRng-3.6.26.ebuild
./net-print/cups/cups-1.1.4.ebuild
#!./net-www/amaya/amaya-4.1.ebuild
./net-www/apache-ssl/apache-ssl-1.3.14.2.7.1.ebuild
./net-www/cocoon/cocoon-1.7.4.ebuild
+#!./net-www/cocoon/cocoon-1.8.ebuild
./net-www/cvsweb/cvsweb-1.93.ebuild
./net-www/htdig/htdig-3.1.5.ebuild
./net-www/jakarta/jakarta-3.1-r1.ebuild
@@ -483,8 +487,10 @@
./x11-terms/rxvt/rxvt-2.6.3.ebuild
./x11-wm/WindowMaker/WindowMaker-0.62.1-r1.ebuild
./x11-wm/enlightenment/enlightenment-0.16.4-r1.ebuild
+#!./x11-wm/enlightenment/enlightenment-0.16.5.ebuild
./x11-wm/openmotif/openmotif-MLI-2.1.30.ebuild
./x11-wm/sawfish/sawfish-0.32.ebuild
+#!./x11-wm/sawfish/sawfish-0.33.1.ebuild
diff --git a/net-misc/dhcp/dhcp-3.0_beta0207.ebuild b/net-misc/dhcp/dhcp-3.0_beta0207.ebuild
new file mode 100644
index 000000000000..0e5a396369c6
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0_beta0207.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_beta0207.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+P=dhcp-3.0b2pl7
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/DHCP/"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+
+ cd ${S}
+ echo "CC = gcc ${CFLAGS}" > site.conf
+ echo "ETC = /etc/dhcp" >> site.conf
+ try ./configure
+ try make
+}
+
+src_install () {
+
+ cd ${S}/work.linux-2.2/client
+ into /usr
+ dosbin dhclient
+ doman *.5 *.8
+
+ cd ../common
+ doman *.5
+
+ cd ../dhcpctl
+ dolib libdhcpctl.a
+ insinto /usr/include
+ doins dhcpctl.h
+
+ cd ../omapip
+ dolib libomapi.a
+ doman *.3
+
+ cd ../relay
+ dosbin dhcrelay
+ doman *.8
+
+ cd ../server
+ dosbin dhcpd
+ doman *.5 *.8
+
+ cd ${S}/client
+ insinto /etc/dhcp
+ doins dhclient.conf
+ donewins scripts/linux dhclient-script
+
+ cd ${S}/server
+ doins dhcpd.conf
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip
+ doins alloc.h buffer.h omapip.h
+ cd ${S}/includes/isc
+ insinto /usr/include/isc
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ docinto doc
+ dodoc doc/*
+}
+
+
+
diff --git a/net-nds/openldap/files/digest-openldap-2.0.7 b/net-nds/openldap/files/digest-openldap-2.0.7
new file mode 100644
index 000000000000..48982066fa3d
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.7
@@ -0,0 +1 @@
+MD5 e772449b0fcc64dc4e7bf20c2853dd10 openldap-2.0.7.tgz
diff --git a/net-nds/openldap/openldap-2.0.7.ebuild b/net-nds/openldap/openldap-2.0.7.ebuild
new file mode 100644
index 000000000000..883b6d0c0078
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.7.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/"${A}
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --enable-wrappers --enable-passwd \
+ --enable-shell --enable-shared --enable-static \
+ --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ try make depend
+ try make
+ cd tests
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/state install
+ prepman
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc
+ dodoc doc/rfc/*.txt
+ docinto devel
+ dodoc doc/devel/*
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/slapd ${D}/etc/rc.d/init.d
+ cp ${O}/files/slurpd ${D}/etc/rc.d/init.d
+
+ cd ${D}/etc/openldap
+
+ for i in *
+ do
+ dosed $i
+ done
+}
+
+
+
+
+
+
diff --git a/net-nds/ypbind/files/digest-ypbind-1.7 b/net-nds/ypbind/files/digest-ypbind-1.7
new file mode 100644
index 000000000000..f94aa2fa644f
--- /dev/null
+++ b/net-nds/ypbind/files/digest-ypbind-1.7
@@ -0,0 +1 @@
+MD5 d6f98266a18f25337cd6afdb8282af4f ypbind-mt-1.7.tar.gz
diff --git a/net-nds/ypbind/ypbind-1.7.ebuild b/net-nds/ypbind/ypbind-1.7.ebuild
new file mode 100644
index 000000000000..19bd56bce105
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.7.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+A=ypbind-mt-${PV}.tar.gz
+S=${WORKDIR}/ypbind-mt-${PV}
+DESCRIPTION="Multithreaded NIS bind service"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/"${A}
+HOMEPAGE="http://www.suse.de/~kukuk/nis/ypbind-mt/index.html"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/yp --with-catgets
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ insinto /etc/rc.d/init.d
+ doins ${O}/files/ypbind
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+ insinto /etc/yp
+ doins etc/yp.conf
+ prepman
+}
+
+
+
+
diff --git a/net-print/LPRng/LPRng-3.6.26.ebuild b/net-print/LPRng/LPRng-3.6.26.ebuild
new file mode 100644
index 000000000000..33215e6f4aba
--- /dev/null
+++ b/net-print/LPRng/LPRng-3.6.26.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-print/LPRng/LPRng-3.6.26.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extended implementation of the Berkley LPR print spooler"
+SRC_URI="ftp://ftp.astart.com/pub/LPRng/LPRng/${A}"
+HOMEPAGE="http://www.astart.com/LPRng/LPRng.html"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/po
+ rm Makefile.in.in
+ cp /usr/share/gettext/po/Makefile.in.in .
+ rm -rf ${S}/intl
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/lprng \
+ --enable-nls --with-included-gettext
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make INSTALL_PREFIX=${D} datadir=${D}/usr/share gnulocaledir=${D}/usr/share/locale install
+
+# rm -rf ${D}/usr/share/locale
+# MOPREFIX=LPRng
+# domo po/fr.po
+ cp ${O}/files/lprng ${D}/etc/rc.d/init.d/lprng
+ cd ${S}
+ dodoc ABOUT-NLS.LPRng CHANGES CONTRIBUTORS COPYRIGHT LICENSE LINK README* UPDATE VERSION
+ dodoc HOWTO/*.txt HOWTO/*.ppt
+ docinto html
+ dodoc HOWTO/*.html HOWTO/*.gif
+}
+
+
+
diff --git a/net-print/LPRng/files/digest-LPRng-3.6.26 b/net-print/LPRng/files/digest-LPRng-3.6.26
new file mode 100644
index 000000000000..2b5230af5392
--- /dev/null
+++ b/net-print/LPRng/files/digest-LPRng-3.6.26
@@ -0,0 +1 @@
+MD5 8d3dc76549191ae6681f6b61ed9fc660 LPRng-3.6.26.tgz
diff --git a/net-www/cocoon/cocoon-1.8.ebuild b/net-www/cocoon/cocoon-1.8.ebuild
new file mode 100644
index 000000000000..64ec1be9b389
--- /dev/null
+++ b/net-www/cocoon/cocoon-1.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/cocoon/cocoon-1.8.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+A=Cocoon-${PV}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Web Publishing Framework for Apache"
+SRC_URI="http://xml.apache.org/cocoon/dist/"${A}
+HOMEPAGE="http://xml.apache.org/cocoon/"
+
+DEPEND=">=dev-lang/jdk-1.2.2
+ >=dev-java/fesi-1
+ >=dev-java/xt-1
+ >=dev-java/jndi-1.2.1"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ CLASSPATH=/opt/java/src.jar:/opt/java/lib/tools.jar
+ CLASSPATH=${CLASSPATH}:/usr/lib/java/jndi.jar
+ CLASSPATH=${CLASSPATH}:/usr/lib/java/xt.jar:/usr/lib/java/sax.jar
+ CLASSPATH=${CLASSPATH}:/usr/lib/java/fesi.jar
+ export CLASSPATH
+ export JAVA_HOME=/opt/java
+ cd ${S}
+ sh build.sh
+}
+
+src_install() {
+ cd ${S}
+ insinto /usr/lib/java
+ for i in xerces_1_2 xalan_1_2_D02 fop_0_13_0 \
+ servlet_2_2 stylebook-1.0-b2 turbine-pool
+ do
+ doins lib/$i.jar
+ done
+ doins build/cocoon.jar
+ insinto /opt/tomcat/webapps/ROOT
+ doins ${O}/files/cocoon.properties
+ dodoc README LICENSE
+ dodir /usr/doc/${PF}/html
+ cp -a docs/* ${D}/usr/doc/${PF}/html
+ find ${D}/usr/doc/${PF}/html -type f -exec gzip -9 {} \;
+}
+
+
+
+
diff --git a/net-www/cocoon/files/digest-cocoon-1.8 b/net-www/cocoon/files/digest-cocoon-1.8
new file mode 100644
index 000000000000..389ffda60431
--- /dev/null
+++ b/net-www/cocoon/files/digest-cocoon-1.8
@@ -0,0 +1 @@
+MD5 7fa79afbb60ab210752f34636c124dd1 Cocoon-1.8.tar.gz
diff --git a/x11-wm/enlightenment/enlightenment-0.16.5.ebuild b/x11-wm/enlightenment/enlightenment-0.16.5.ebuild
new file mode 100644
index 000000000000..f7c048e408e8
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.16.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.16.5.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Enlightenment Window Manager"
+SRC_URI="ftp://ftp.enlightenment.org/pub/enlightenment/enlightenment/"${A}
+HOMEPAGE="http://www.enlightenment.org/"
+
+DEPEND=">=media-libs/fnlib-0.5
+ >=media-sound/esound-0.2.19
+ >=media-libs/freetype-1.3.1
+ >=gnome-base/libghttp-1.0.7"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try CFLAGS="\"${CFLAGS} -I/opt/gnome/include\"" LDFLAGS="-L/opt/gnome/lib" \
+ ./configure --host=${CHOST} --prefix=/usr/X11R6 --with-catgets
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr/X11R6 localedir=${D}/usr/X11R6/enlightenment/locale \
+ gnulocaledir=${D}/usr/X11R6/enlightenment/locale install
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README
+ docinto sample-scripts
+ dodoc sample-scripts/*
+}
+
+
+
diff --git a/x11-wm/enlightenment/files/digest-enlightenment-0.16.5 b/x11-wm/enlightenment/files/digest-enlightenment-0.16.5
new file mode 100644
index 000000000000..96494ff73e9c
--- /dev/null
+++ b/x11-wm/enlightenment/files/digest-enlightenment-0.16.5
@@ -0,0 +1 @@
+MD5 3902b7c9cfaa8f70ca8079b348de0ed5 enlightenment-0.16.5.tar.gz
diff --git a/x11-wm/sawfish/files/digest-sawfish-0.33.1 b/x11-wm/sawfish/files/digest-sawfish-0.33.1
new file mode 100644
index 000000000000..b05b76e17c9a
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-0.33.1
@@ -0,0 +1 @@
+MD5 a2b99f3f9deae419c43504dba16554f0 sawfish-0.33.1.tar.gz
diff --git a/x11-wm/sawfish/sawfish-0.33.1.ebuild b/x11-wm/sawfish/sawfish-0.33.1.ebuild
new file mode 100644
index 000000000000..3518887611e2
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-0.33.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-0.33.1.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://sawmill.sourceforge.net/pub/sawmill/"${A}
+HOMEPAGE="http://sawmill.sourceforge.net/"
+DEPEND=">=dev-libs/rep-gtk-0.14
+ >=media-sound/esound-0.2.19
+ >=media-libs/imlib-0.9.8.1
+ gnome? ( >=gnome-base/gnome-core-1.2.2.1
+ >=gnome-base/libglade-0.14 )"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 --with-audiofile --with-esd \
+ --with-gnome-prefix=/opt/gnome
+ else
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 --with-audiofile --with-esd
+ fi
+ #pmake doesn't work, stick with make
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+}
+
+
+