summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/turbotail/ChangeLog8
-rw-r--r--sys-apps/turbotail/metadata.xml2
-rw-r--r--sys-apps/turbotail/turbotail-0.3-r1.ebuild39
3 files changed, 47 insertions, 2 deletions
diff --git a/sys-apps/turbotail/ChangeLog b/sys-apps/turbotail/ChangeLog
index e0fcf9086b41..b80f2785862c 100644
--- a/sys-apps/turbotail/ChangeLog
+++ b/sys-apps/turbotail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/turbotail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/ChangeLog,v 1.14 2011/01/07 18:13:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/ChangeLog,v 1.15 2011/10/08 13:03:36 jlec Exp $
+
+*turbotail-0.3-r1 (08 Oct 2011)
+
+ 08 Oct 2011; Justin Lecher <jlec@gentoo.org> +turbotail-0.3-r1.ebuild,
+ metadata.xml:
+ Respect FLAGS*, #334753
07 Jan 2011; Jeroen Roovers <jer@gentoo.org> turbotail-0.3.ebuild:
Use the virtual. Set RDEPEND.
diff --git a/sys-apps/turbotail/metadata.xml b/sys-apps/turbotail/metadata.xml
index 96a2d586367d..659da0ca93c2 100644
--- a/sys-apps/turbotail/metadata.xml
+++ b/sys-apps/turbotail/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>base-system</herd>
+ <herd>base-system</herd>
</pkgmetadata>
diff --git a/sys-apps/turbotail/turbotail-0.3-r1.ebuild b/sys-apps/turbotail/turbotail-0.3-r1.ebuild
new file mode 100644
index 000000000000..47748cfb436c
--- /dev/null
+++ b/sys-apps/turbotail/turbotail-0.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/turbotail-0.3-r1.ebuild,v 1.1 2011/10/08 13:03:36 jlec Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Drop-in replacement for 'tail' which uses the kernel DNOTIFY-api"
+HOMEPAGE="http://www.vanheusden.com/turbotail/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="fam"
+
+DEPEND="fam? ( virtual/fam )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf mylibs
+ if use fam; then
+ myconf="-DUSE_FAM"
+ mylibs="-lfam"
+ else
+ myconf="-DUSE_DNOTIFY"
+ fi
+
+ echo "$(tc-getCC) ${CFLAGS} ${myconf} -DVERSION=\"${PV}\" -c ${PN}.c"
+ $(tc-getCC) ${CFLAGS} ${myconf} -DVERSION=\"${PV}\" -c ${PN}.c || die
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.o ${mylibs}"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.o ${mylibs} || die
+}
+
+src_install() {
+ dobin turbotail
+ dodoc readme.txt
+}