summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tex/chktex/chktex-1.5-r2.ebuild14
-rw-r--r--dev-util/gtk-doc/gtk-doc-0.9-r2.ebuild14
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.0.ebuild19
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.1.ebuild7
4 files changed, 26 insertions, 28 deletions
diff --git a/dev-tex/chktex/chktex-1.5-r2.ebuild b/dev-tex/chktex/chktex-1.5-r2.ebuild
index 602dce92b97e..2a862435c447 100644
--- a/dev-tex/chktex/chktex-1.5-r2.ebuild
+++ b/dev-tex/chktex/chktex-1.5-r2.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/chktex-1.5-r2.ebuild,v 1.1 2003/06/09 13:11:26 satai Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/chktex/chktex-1.5-r2.ebuild,v 1.2 2003/08/03 02:30:34 vapier Exp $
-SRC_URI="http://www.ibiblio.org/pub/linux/distributions/gentoo/${P}.tar.gz"
-HOMEPAGE="http://www.nongnu.org/chktex/"
DESCRIPTION="Checks latex source for common mistakes"
+HOMEPAGE="http://www.nongnu.org/chktex/"
+SRC_URI="http://www.ibiblio.org/pub/linux/distributions/gentoo/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
+IUSE="debug"
DEPEND="app-text/tetex
dev-lang/perl
@@ -16,12 +17,11 @@ DEPEND="app-text/tetex
dev-tex/latex2html"
src_compile() {
- [ -n "$DEBUG" ] && myconf="--enable-debug-info" || myconf="$myconf --disable-debug-info"
- econf ${myconf}
+ econf `use_enable debug debug-info` || die
emake || die
}
src_install() {
- einstall
+ einstall || die
dodoc COPYING SCOPTIONS
}
diff --git a/dev-util/gtk-doc/gtk-doc-0.9-r2.ebuild b/dev-util/gtk-doc/gtk-doc-0.9-r2.ebuild
index a568f2bfbce4..3251ddfc9cfe 100644
--- a/dev-util/gtk-doc/gtk-doc-0.9-r2.ebuild
+++ b/dev-util/gtk-doc/gtk-doc-0.9-r2.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-0.9-r2.ebuild,v 1.15 2003/04/10 01:43:45 satai Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-0.9-r2.ebuild,v 1.16 2003/08/03 02:32:24 vapier Exp $
inherit gnome.org
-S=${WORKDIR}/${P}
DESCRIPTION="GTK+ Documentation Generator"
HOMEPAGE="http://www.gtk.org/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
DEPEND=">=dev-util/pkgconfig-0.12.0
@@ -19,9 +18,14 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
>=app-text/docbook-sgml-1.0
>=dev-lang/perl-5.0.0
!app-text/xhtml1"
-
+
src_compile() {
- econf --enable-debug=yes || die
+ local myconf=""
+ use debug \
+ && myconf="--enable-debug=yes" \
+ || myconf="--enable-debug=no"
+
+ econf ${myconf} || die
emake || die
}
diff --git a/dev-util/gtk-doc/gtk-doc-1.0.ebuild b/dev-util/gtk-doc/gtk-doc-1.0.ebuild
index 6670136c003c..fed384676645 100644
--- a/dev-util/gtk-doc/gtk-doc-1.0.ebuild
+++ b/dev-util/gtk-doc/gtk-doc-1.0.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.0.ebuild,v 1.11 2003/07/15 13:20:34 todd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.0.ebuild,v 1.12 2003/08/03 02:32:24 vapier Exp $
inherit gnome.org
-S=${WORKDIR}/${P}
DESCRIPTION="GTK+ Documentation Generator"
HOMEPAGE="http://www.gtk.org/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc ~alpha hppa"
DEPEND=">=dev-util/pkgconfig-0.12.0
@@ -23,20 +22,16 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
src_compile() {
local myconf
+ use debug \
+ && myconf="--enable-debug=yes" \
+ || myconf="--enable-debug=no"
- if [ "${DEBUGBUILD}" ]
- then
- myconf="--enable-debug=yes"
- else
- myconf="--enable-debug=no"
- fi
-
- econf ${myconf}
+ econf ${myconf} || die
emake || die
}
src_install() {
- einstall
+ einstall || die
dodoc AUTHORS ChangeLog COPYING INSTALL README* NEWS
docinto doc
diff --git a/dev-util/gtk-doc/gtk-doc-1.1.ebuild b/dev-util/gtk-doc/gtk-doc-1.1.ebuild
index d4d2693bc483..220a32721007 100644
--- a/dev-util/gtk-doc/gtk-doc-1.1.ebuild
+++ b/dev-util/gtk-doc/gtk-doc-1.1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.1.ebuild,v 1.3 2003/06/29 19:35:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.1.ebuild,v 1.4 2003/08/03 02:32:24 vapier Exp $
inherit gnome.org
DESCRIPTION="GTK+ Documentation Generator"
HOMEPAGE="http://www.gtk.org/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ~x86 ~ppc ~sparc alpha ~hppa"
DEPEND=">=dev-util/pkgconfig-0.12.0
@@ -22,7 +22,6 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
src_compile() {
local myconf
-
use debug \
&& myconf="--enable-debug=yes" \
|| myconf="--enable-debug=no"
@@ -32,7 +31,7 @@ src_compile() {
}
src_install() {
- einstall
+ einstall || die
dodoc AUTHORS ChangeLog COPYING INSTALL README* NEWS
docinto doc