summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/apgdiff/ChangeLog7
-rw-r--r--dev-db/apgdiff/apgdiff-2.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-db/apgdiff/ChangeLog b/dev-db/apgdiff/ChangeLog
index 475ee64ce269..def9ee90d90b 100644
--- a/dev-db/apgdiff/ChangeLog
+++ b/dev-db/apgdiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/apgdiff
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/apgdiff/ChangeLog,v 1.12 2010/10/09 00:41:47 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/apgdiff/ChangeLog,v 1.13 2010/10/22 18:27:24 fordfrog Exp $
+
+*apgdiff-2.3 (22 Oct 2010)
+
+ 22 Oct 2010; Miroslav Šulc <fordfrog@gentoo.org> +apgdiff-2.3.ebuild:
+ Version bump
*apgdiff-2.2.2 (09 Oct 2010)
diff --git a/dev-db/apgdiff/apgdiff-2.3.ebuild b/dev-db/apgdiff/apgdiff-2.3.ebuild
new file mode 100644
index 000000000000..e7db1a73e310
--- /dev/null
+++ b/dev-db/apgdiff/apgdiff-2.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/apgdiff/apgdiff-2.3.ebuild,v 1.1 2010/10/22 18:27:24 fordfrog Exp $
+
+EAPI="1"
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Another PostgreSQL Diff Tool is a simple PostgreSQL diff tool that is useful for schema upgrades."
+HOMEPAGE="http://apgdiff.startnet.biz/"
+SRC_URI="http://apgdiff.startnet.biz/download/${P}-src.zip"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.6
+ >=dev-java/ant-core-1.7.0:0
+ >=dev-java/ant-junit-1.7.0:0
+ app-arch/zip:0
+ test? (
+ dev-java/hamcrest-core:0
+ >=dev-java/junit-4.4:4
+ )"
+
+RDEPEND=">=virtual/jre-1.6"
+
+src_unpack() {
+ unpack ${A}
+
+ mkdir "${S}"/lib
+ cd "${S}"/lib
+ if use test ; then
+ java-pkg_jar-from --build-only hamcrest-core
+ java-pkg_jar-from --build-only junit-4
+ fi
+}
+
+src_compile() {
+ eant -Dnoget=true jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ java-pkg_dolauncher apgdiff --jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/main/java/*
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant -Dnoget=true test
+}