summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/corosync/ChangeLog5
-rw-r--r--sys-cluster/corosync/corosync-1.3.1.ebuild14
2 files changed, 11 insertions, 8 deletions
diff --git a/sys-cluster/corosync/ChangeLog b/sys-cluster/corosync/ChangeLog
index 1f3d91026b02..1fb87eee77f0 100644
--- a/sys-cluster/corosync/ChangeLog
+++ b/sys-cluster/corosync/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/corosync
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.15 2011/04/29 09:53:24 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.16 2011/05/10 13:24:24 scarabeus Exp $
+
+ 10 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> corosync-1.3.1.ebuild:
+ Cleanup and use eapi4.
*corosync-1.3.1 (29 Apr 2011)
diff --git a/sys-cluster/corosync/corosync-1.3.1.ebuild b/sys-cluster/corosync/corosync-1.3.1.ebuild
index 311788b7c5dc..dcef3c125cea 100644
--- a/sys-cluster/corosync/corosync-1.3.1.ebuild
+++ b/sys-cluster/corosync/corosync-1.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-1.3.1.ebuild,v 1.1 2011/04/29 09:53:24 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-1.3.1.ebuild,v 1.2 2011/05/10 13:24:24 scarabeus Exp $
-EAPI=3
+EAPI=4
inherit base autotools
@@ -29,7 +29,7 @@ PATCHES=(
"${FILESDIR}/${PN}-docs.patch"
)
-DOCS=( "README.recovery" "README.devmap" "SECURITY" "TODO" "AUTHORS" )
+DOCS=( README.recovery README.devmap SECURITY TODO AUTHORS )
src_prepare() {
base_src_prepare
@@ -38,7 +38,7 @@ src_prepare() {
src_configure() {
# appends lib to localstatedir automatically
- # FIXME: install both static and shared libs
+ # FIXME: install just shared libs --disable-static does not work
econf \
--localstatedir=/var \
--docdir=/usr/share/doc/${PF} \
@@ -48,11 +48,11 @@ src_configure() {
}
src_install() {
- base_src_install
- newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotate ${PN} || die
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
keepdir /var/lib/corosync
}