summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/vacuum/ChangeLog8
-rw-r--r--net-im/vacuum/vacuum-1.1.2.ebuild12
-rw-r--r--net-im/vacuum/vacuum-9999.ebuild16
3 files changed, 21 insertions, 15 deletions
diff --git a/net-im/vacuum/ChangeLog b/net-im/vacuum/ChangeLog
index ad9e90fb1582..1170f181f318 100644
--- a/net-im/vacuum/ChangeLog
+++ b/net-im/vacuum/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/vacuum
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.5 2011/12/29 08:18:49 maksbotan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.6 2012/03/10 20:20:13 vapier Exp $
+
+ 10 Mar 2012; Mike Frysinger <vapier@gentoo.org> vacuum-1.1.2.ebuild,
+ vacuum-9999.ebuild:
+ Make sure we use zlib/minizip from the system #387837 by Diego Elio Pettenò.
*vacuum-1.1.2 (29 Dec 2011)
diff --git a/net-im/vacuum/vacuum-1.1.2.ebuild b/net-im/vacuum/vacuum-1.1.2.ebuild
index 7194f9f7f804..cee814082f11 100644
--- a/net-im/vacuum/vacuum-1.1.2.ebuild
+++ b/net-im/vacuum/vacuum-1.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-1.1.2.ebuild,v 1.1 2011/12/29 08:18:49 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-1.1.2.ebuild,v 1.2 2012/03/10 20:20:13 vapier Exp $
EAPI="4"
LANGS="de pl ru uk"
@@ -42,20 +42,22 @@ RDEPEND="
adiummessagestyle? ( >=x11-libs/qt-webkit-4.5:4 )
net-dns/libidn
x11-libs/libXScrnSaver
+ sys-libs/zlib[minizip]
"
DEPEND="${RDEPEND}"
DOCS="AUTHORS CHANGELOG README TRANSLATORS"
src_prepare() {
- default
+ # Force usage of system libraries
+ rm -rf src/thirdparty/{idn,minizip,zlib}
epatch "${FILESDIR}"/${PN}-1.1.1-zlib.patch
}
src_configure() {
# linguas
- local langs="none;"
+ local langs="none;" x
for x in ${LANGS}; do
use linguas_${x} && langs+="${x};"
done
@@ -65,7 +67,7 @@ src_configure() {
-DINSTALL_SDK=ON
-DLANGS="${langs}"
-DINSTALL_DOCS=OFF
- -DFORCE_BUNDLED_MINIZIP=ON
+ -DFORCE_BUNDLED_MINIZIP=OFF
)
for x in ${PLUGINS}; do
diff --git a/net-im/vacuum/vacuum-9999.ebuild b/net-im/vacuum/vacuum-9999.ebuild
index d6e54bf3126c..c84f4a79f71b 100644
--- a/net-im/vacuum/vacuum-9999.ebuild
+++ b/net-im/vacuum/vacuum-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-9999.ebuild,v 1.3 2011/12/04 22:09:03 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-9999.ebuild,v 1.4 2012/03/10 20:20:13 vapier Exp $
EAPI="4"
LANGS="de pl ru uk"
@@ -42,20 +42,20 @@ RDEPEND="
adiummessagestyle? ( >=x11-libs/qt-webkit-4.5:4 )
net-dns/libidn
x11-libs/libXScrnSaver
+ sys-libs/zlib[minizip]
"
DEPEND="${RDEPEND}"
DOCS="AUTHORS CHANGELOG README TRANSLATORS"
-pkg_setup() {
- if use vcs-revision; then
- ewarn "Anyone will be able to see your VCS revision of ${PN}, it is insecure."
- fi
+src_prepare() {
+ # Force usage of system libraries
+ rm -rf src/thirdparty/{idn,minizip,zlib}
}
src_configure() {
# linguas
- local langs="none;"
+ local langs="none;" x
for x in ${LANGS}; do
use linguas_${x} && langs+="${x};"
done
@@ -65,7 +65,7 @@ src_configure() {
-DINSTALL_SDK=ON
-DLANGS="${langs}"
-DINSTALL_DOCS=OFF
- -DFORCE_BUNDLED_MINIZIP=ON
+ -DFORCE_BUNDLED_MINIZIP=OFF
)
for x in ${PLUGINS}; do