summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/xqilla/ChangeLog11
-rw-r--r--dev-libs/xqilla/files/2.2.3-xerces-c-3.1.0.patch21
-rw-r--r--dev-libs/xqilla/files/xqilla-2.2.0-gcc44.patch21
-rw-r--r--dev-libs/xqilla/xqilla-2.2.0.ebuild62
-rw-r--r--dev-libs/xqilla/xqilla-2.3.0.ebuild (renamed from dev-libs/xqilla/xqilla-2.2.3.ebuild)34
5 files changed, 31 insertions, 118 deletions
diff --git a/dev-libs/xqilla/ChangeLog b/dev-libs/xqilla/ChangeLog
index 4d5bb999abc7..cbbc1e906c3d 100644
--- a/dev-libs/xqilla/ChangeLog
+++ b/dev-libs/xqilla/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/xqilla
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.12 2011/09/24 12:36:27 chainsaw Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.13 2012/05/24 20:25:19 dev-zero Exp $
+
+*xqilla-2.3.0 (24 May 2012)
+
+ 24 May 2012; Tiziano Müller <dev-zero@gentoo.org> +xqilla-2.3.0.ebuild,
+ -files/2.2.3-xerces-c-3.1.0.patch, -files/xqilla-2.2.0-gcc44.patch,
+ -xqilla-2.2.0.ebuild, -xqilla-2.2.3.ebuild:
+ Version bump, fix tidy-support, add static-libs USE flag, drop old.
24 Sep 2011; Tony Vroon <chainsaw@gentoo.org> xqilla-2.2.4.ebuild,
+files/xqilla-2.2.4-gcc46.patch:
diff --git a/dev-libs/xqilla/files/2.2.3-xerces-c-3.1.0.patch b/dev-libs/xqilla/files/2.2.3-xerces-c-3.1.0.patch
deleted file mode 100644
index cd5d73529f7b..000000000000
--- a/dev-libs/xqilla/files/2.2.3-xerces-c-3.1.0.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur XQilla-2.2.3.orig/src/schema/SchemaValidatorFilter.cpp XQilla-2.2.3/src/schema/SchemaValidatorFilter.cpp
---- XQilla-2.2.3.orig/src/schema/SchemaValidatorFilter.cpp 2010-02-26 08:11:53.899266592 +0100
-+++ XQilla-2.2.3/src/schema/SchemaValidatorFilter.cpp 2010-02-26 08:43:08.309105237 +0100
-@@ -710,7 +710,7 @@
-
- if(prefixColonPos == -1) {
- bool unknown = false;
-- return fElemStack.mapPrefixToURI(XMLUni::fgZeroLenString, (ElemStack::MapModes) mode, unknown);
-+ return fElemStack.mapPrefixToURI(XMLUni::fgZeroLenString, unknown);
- }
- else {
- prefixBuf.set(qName, prefixColonPos);
-@@ -726,7 +726,7 @@
- }
- else {
- bool unknown = false;
-- unsigned int uriId = fElemStack.mapPrefixToURI(prefixBuf.getRawBuffer(), (ElemStack::MapModes) mode, unknown);
-+ unsigned int uriId = fElemStack.mapPrefixToURI(prefixBuf.getRawBuffer(), unknown);
-
- if(unknown)
- emitError(XMLErrs::UnknownPrefix, prefixBuf.getRawBuffer());
diff --git a/dev-libs/xqilla/files/xqilla-2.2.0-gcc44.patch b/dev-libs/xqilla/files/xqilla-2.2.0-gcc44.patch
deleted file mode 100644
index f526957c20fc..000000000000
--- a/dev-libs/xqilla/files/xqilla-2.2.0-gcc44.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ur XQilla-2.2.0.orig/src/lexer/XQLexer.cpp XQilla-2.2.0/src/lexer/XQLexer.cpp
---- XQilla-2.2.0.orig/src/lexer/XQLexer.cpp 2008-08-18 03:43:07.000000000 +0300
-+++ XQilla-2.2.0/src/lexer/XQLexer.cpp 2009-08-10 15:30:13.000000000 +0300
-@@ -1,3 +1,5 @@
-+#include <cstdio>
-+
- #define yyFlexLexer xqFlexLexer
-
- #line 4 "../src/lexer/XQLexer.cpp"
-diff -ur XQilla-2.2.0.orig/src/parser/XQParser.cpp XQilla-2.2.0/src/parser/XQParser.cpp
---- XQilla-2.2.0.orig/src/parser/XQParser.cpp 2008-11-28 19:48:27.000000000 +0200
-+++ XQilla-2.2.0/src/parser/XQParser.cpp 2009-08-10 15:21:11.000000000 +0300
-@@ -43,6 +43,8 @@
- define necessary library symbols; they are noted "INFRINGES ON
- USER NAME SPACE" below. */
-
-+#include <cstdio>
-+
- /* Identify Bison output. */
- #define YYBISON 1
-
diff --git a/dev-libs/xqilla/xqilla-2.2.0.ebuild b/dev-libs/xqilla/xqilla-2.2.0.ebuild
deleted file mode 100644
index 5bead0cf55c8..000000000000
--- a/dev-libs/xqilla/xqilla-2.2.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.2.0.ebuild,v 1.3 2010/02/26 07:56:47 dev-zero Exp $
-
-EAPI="2"
-inherit eutils
-
-MY_P="XQilla-${PV}"
-
-DESCRIPTION="An XQuery and XPath 2 library and command line utility written in C++."
-HOMEPAGE="http://xqilla.sourceforge.net/HomePage"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="Apache-2.0 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc faxpp htmltidy"
-
-# XQilla bundles two libraries:
-# - mapm, heavily patched
-# - yajl, moderately patched
-# There's currently no way to unbundle those
-
-RDEPEND="=dev-libs/xerces-c-3.0*
- faxpp? ( dev-libs/faxpp )
- htmltidy? ( app-text/htmltidy )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc44.patch
- sed -i -e 's|^LDFLAGS =|LDFLAGS +=|' Makefile.in || die "sed failed"
-}
-
-src_configure() {
- econf \
- --with-xerces=/usr \
- $(use_enable debug) \
- $(use_with htmltidy tidy) \
- $(use_with faxpp faxpp /usr)
-}
-
-src_compile() {
- default
-
- if use doc; then
- emake docs || die "emake docs failed"
- emake devdocs || die "emake devdocs failed"
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake docs failed"
-
- dodoc ChangeLog TODO
-
- if use doc; then
- cd docs
- dohtml -r dev-api dom3-api simple-api
- fi
-}
diff --git a/dev-libs/xqilla/xqilla-2.2.3.ebuild b/dev-libs/xqilla/xqilla-2.3.0.ebuild
index 8eecce8533a2..481065b9c357 100644
--- a/dev-libs/xqilla/xqilla-2.2.3.ebuild
+++ b/dev-libs/xqilla/xqilla-2.3.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.2.3.ebuild,v 1.1 2010/02/26 07:56:47 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.3.0.ebuild,v 1.1 2012/05/24 20:25:19 dev-zero Exp $
-EAPI="2"
-inherit eutils
+EAPI="4"
+
+inherit autotools base
MY_P="XQilla-${PV}"
@@ -13,32 +14,37 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="Apache-2.0 BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug doc faxpp htmltidy"
+IUSE="debug doc examples faxpp htmltidy static-libs"
# XQilla bundles two libraries:
# - mapm, heavily patched
# - yajl, moderately patched
# There's currently no way to unbundle those
-RDEPEND=">=dev-libs/xerces-c-3.1.0
+RDEPEND=">=dev-libs/xerces-c-3.1.1
faxpp? ( dev-libs/faxpp )
htmltidy? ( app-text/htmltidy )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+PATCHES=(
+ "${FILESDIR}/2.2.4-respect-ldflags-no-rpath.patch"
+)
+
S="${WORKDIR}/${MY_P}"
src_prepare() {
- epatch "${FILESDIR}/${PV}-xerces-c-3.1.0.patch"
- sed -i -e 's|^LDFLAGS =|LDFLAGS +=|' Makefile.in || die "sed failed"
+ base_src_prepare
+ eautoreconf
}
src_configure() {
econf \
--with-xerces=/usr \
$(use_enable debug) \
- $(use_with htmltidy tidy) \
- $(use_with faxpp faxpp /usr)
+ $(use_with htmltidy tidy /usr) \
+ $(use_with faxpp faxpp /usr) \
+ $(use_enable static-libs static)
}
src_compile() {
@@ -51,12 +57,16 @@ src_compile() {
}
src_install () {
- emake DESTDIR="${D}" install || die "emake docs failed"
+ default
- dodoc ChangeLog TODO
+ use static-libs || rm -rf "${D}"/usr/lib*/*.la
if use doc; then
cd docs
dohtml -r dev-api dom3-api simple-api
fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${S}"/src/samples/*
+ fi
}