summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libmpeg3/ChangeLog8
-rw-r--r--media-libs/libmpeg3/files/digest-libmpeg3-1.76
-rw-r--r--media-libs/libmpeg3/libmpeg3-1.7.ebuild71
-rw-r--r--media-libs/libmpeg3/metadata.xml3
4 files changed, 86 insertions, 2 deletions
diff --git a/media-libs/libmpeg3/ChangeLog b/media-libs/libmpeg3/ChangeLog
index 548a8fcebc6d..8b7ec9aa2de6 100644
--- a/media-libs/libmpeg3/ChangeLog
+++ b/media-libs/libmpeg3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmpeg3
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.49 2006/09/04 04:49:05 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.50 2006/10/10 18:41:25 aballier Exp $
+
+*libmpeg3-1.7 (10 Oct 2006)
+
+ 10 Oct 2006; Alexis Ballier <aballier@gentoo.org> +libmpeg3-1.7.ebuild:
+ Bumping libmpeg3 to 1.7, bug #45325; masked because it breaks
+ media-video/transcode and dev-libs/DirectFB-extra
04 Sep 2006; Joshua Kinard <kumba@gentoo.org> libmpeg3-1.5.2-r3.ebuild:
Marked stable on mips.
diff --git a/media-libs/libmpeg3/files/digest-libmpeg3-1.7 b/media-libs/libmpeg3/files/digest-libmpeg3-1.7
new file mode 100644
index 000000000000..d2b4fbb5a26d
--- /dev/null
+++ b/media-libs/libmpeg3/files/digest-libmpeg3-1.7
@@ -0,0 +1,6 @@
+MD5 65c0102f520d879fa804703bc1eb9dd7 libmpeg3-1.7-gentoo.tar.bz2 5625
+RMD160 27c6e0d5afdc5a2198d6d2968913ec7748058157 libmpeg3-1.7-gentoo.tar.bz2 5625
+SHA256 6dde60e78776e7a3c761218e35afc6432a9289eb1ae18c4e4e7f85f67d63572d libmpeg3-1.7-gentoo.tar.bz2 5625
+MD5 4a3e8896164d59d7d0dff69b50b75352 libmpeg3-1.7-src.tar.bz2 320897
+RMD160 f1989c4b52d97ee29833edc79efd731b6219f126 libmpeg3-1.7-src.tar.bz2 320897
+SHA256 b9e840ab489fd57860d305cdfb43d2c25fbb01105c4db4e16f09122727ee052d libmpeg3-1.7-src.tar.bz2 320897
diff --git a/media-libs/libmpeg3/libmpeg3-1.7.ebuild b/media-libs/libmpeg3/libmpeg3-1.7.ebuild
new file mode 100644
index 000000000000..d009329e6365
--- /dev/null
+++ b/media-libs/libmpeg3/libmpeg3-1.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.7.ebuild,v 1.1 2006/10/10 18:41:25 aballier Exp $
+
+inherit eutils autotools toolchain-funcs
+
+PATCHLEVEL="1"
+DESCRIPTION="An mpeg library for linux"
+HOMEPAGE="http://heroinewarrior.com/libmpeg3.php3"
+SRC_URI="mirror://sourceforge/heroines/${P}-src.tar.bz2
+ mirror://gentoo/${P}-gentoo.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mmx"
+
+RDEPEND="sys-libs/zlib
+ media-libs/jpeg
+ media-libs/a52dec"
+DEPEND="${RDEPEND}
+ mmx? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if [[ $(gcc-version) == "3.3" ]]; then
+ eerror "You're using an old version of GCC, but this package is"
+ eerror "designed to work only with GCC 3.4 or later."
+ eerror "Please upgrade your GCC or change the selected profile"
+ eerror "and then merge this again."
+ die "Package won't build with GCC 3.3."
+ fi
+
+ epatch "${WORKDIR}/${P}-mpeg3split.patch"
+ epatch "${WORKDIR}/${P}-textrel.patch"
+ epatch "${WORKDIR}/${P}-gnustack.patch"
+ epatch "${WORKDIR}/${P}-a52.patch"
+ epatch "${WORKDIR}/${P}-all_gcc4.patch"
+ epatch "${WORKDIR}/${P}-all_pthread.patch"
+}
+
+src_compile() {
+
+ cp -rf ${WORKDIR}/${PV}/* .
+ eautoreconf
+
+ #disabling css since it's a fake one.
+ #One can find in the sources this message :
+ # Stubs for deCSS which can't be distributed in source form
+
+ econf $(use_enable mmx )\
+ --disable-css || die "Configure failed"
+
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dohtml -r docs
+ # This is a workaround, it wants to rebuild
+ # everything if the headers have changed
+ # So we patch them after install...
+ cd "${D}/${ROOT}/usr/include/libmpeg3"
+ # This patch patches the .h files that get installed into /usr/include
+ # to show the correct include syntax '<>' instead of '""' This patch
+ # was also generated using info from SF's src.rpm
+ epatch "${WORKDIR}/gentoo-p2.patch"
+}
diff --git a/media-libs/libmpeg3/metadata.xml b/media-libs/libmpeg3/metadata.xml
index edccfe5754d2..f181ad56f720 100644
--- a/media-libs/libmpeg3/metadata.xml
+++ b/media-libs/libmpeg3/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>video</herd>
<maintainer>
-<email>media-video@gentoo.org</email>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
</maintainer>
</pkgmetadata>