summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-laptop/acpi4asus/ChangeLog10
-rw-r--r--app-laptop/acpi4asus/acpi4asus-0.32-r1.ebuild62
-rw-r--r--app-laptop/acpi4asus/files/acpi4asus-0.32-2.6.20.patch13
-rw-r--r--app-laptop/acpi4asus/files/digest-acpi4asus-0.32-r13
4 files changed, 87 insertions, 1 deletions
diff --git a/app-laptop/acpi4asus/ChangeLog b/app-laptop/acpi4asus/ChangeLog
index ce3b14e95d34..8449b4a3429c 100644
--- a/app-laptop/acpi4asus/ChangeLog
+++ b/app-laptop/acpi4asus/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-laptop/acpi4asus
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/acpi4asus/ChangeLog,v 1.10 2007/02/10 10:24:12 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acpi4asus/ChangeLog,v 1.11 2007/02/13 16:47:26 phreak Exp $
+
+*acpi4asus-0.32-r1 (13 Feb 2007)
+
+ 13 Feb 2007; Christian Heim <phreak@gentoo.org>
+ +files/acpi4asus-0.32-2.6.20.patch, +acpi4asus-0.32-r1.ebuild:
+ Fixing the compilation against 2.6.20 (#166288 thanks to Cyril Romain
+ <cyrilromain at yahoo.fr>), fixing the BUILD_PARAMS to use the selected
+ kernel and *not* the running one.
*acpi4asus-0.32 (10 Feb 2007)
diff --git a/app-laptop/acpi4asus/acpi4asus-0.32-r1.ebuild b/app-laptop/acpi4asus/acpi4asus-0.32-r1.ebuild
new file mode 100644
index 000000000000..704761595d61
--- /dev/null
+++ b/app-laptop/acpi4asus/acpi4asus-0.32-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acpi4asus/acpi4asus-0.32-r1.ebuild,v 1.1 2007/02/13 16:47:26 phreak Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="Acpi daemon and kernel module to control ASUS Laptop Hotkeys"
+HOMEPAGE="http://sourceforge.net/projects/acpi4asus"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+MODULE_NAMES="asus_acpi(acpi:${S}/driver)"
+BUILD_TARGETS=" "
+RDEPEND="sys-power/acpid"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ if kernel_is ge 2 6 20 ; then
+ epatch "${FILESDIR}"/${P}-2.6.20.patch
+ fi
+}
+
+src_compile() {
+ linux-mod_src_compile
+ emake -C asus_acpid
+}
+
+
+src_install() {
+ linux-mod_src_install
+
+ dobin asus_acpid/asus_acpid
+ doman asus_acpid/asus_acpid.8
+
+ dodoc README Changelog
+
+ dodir /usr/share/${PN}/samples
+
+ dodir /usr/share/${PN}/samples/actions
+ insinto /usr/share/${PN}/samples/actions
+ doins samples/actions/*.sh
+
+ dodir /usr/share/${PN}/samples/events
+ insinto /usr/share/${PN}/samples/events
+ doins samples/events/*
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ einfo
+ einfo "Don't forget to create your ~/.asus_acpi,"
+ einfo "see /usr/share/doc/${PF}/README.gz for details"
+ einfo
+}
diff --git a/app-laptop/acpi4asus/files/acpi4asus-0.32-2.6.20.patch b/app-laptop/acpi4asus/files/acpi4asus-0.32-2.6.20.patch
new file mode 100644
index 000000000000..0fb6fef0eaeb
--- /dev/null
+++ b/app-laptop/acpi4asus/files/acpi4asus-0.32-2.6.20.patch
@@ -0,0 +1,13 @@
+Index: acpi4asus-0.32/driver/asus_acpi.c
+===================================================================
+--- acpi4asus-0.32.orig/driver/asus_acpi.c
++++ acpi4asus-0.32/driver/asus_acpi.c
+@@ -2092,7 +2092,7 @@ static int __init asus_acpi_init(void)
+ }
+
+ #ifdef CONFIG_ACPI_ASUS_NEW_BACKLIGHT
+- bd = backlight_device_register ("asus", NULL, &asusbl_data);
++ bd = backlight_device_register ("asus", NULL, NULL, &asusbl_data);
+
+ if (IS_ERR (bd)) {
+ printk(KERN_ERR "Could not register asus backlight device\n");
diff --git a/app-laptop/acpi4asus/files/digest-acpi4asus-0.32-r1 b/app-laptop/acpi4asus/files/digest-acpi4asus-0.32-r1
new file mode 100644
index 000000000000..661b37350d93
--- /dev/null
+++ b/app-laptop/acpi4asus/files/digest-acpi4asus-0.32-r1
@@ -0,0 +1,3 @@
+MD5 4a75c5bbf51ffe7deef99bd2d84007b2 acpi4asus-0.32.tar.bz2 32043
+RMD160 253564a1ecb40649100637ecf02e76fb230b39cf acpi4asus-0.32.tar.bz2 32043
+SHA256 852482d59f66d2f918a223e27b169d8835efa38a573cfad584d484ef1cffaa09 acpi4asus-0.32.tar.bz2 32043