summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/slib/slib-2.3.8.ebuild4
-rw-r--r--media-video/smpeg-xmms/smpeg-xmms-0.3.1.ebuild13
-rw-r--r--media-video/vlc/vlc-0.1.99h.ebuild25
-rw-r--r--media-video/xmps/xmps-0.1.3-r1.ebuild18
-rw-r--r--net-www/htdig/htdig-3.1.5.ebuild4
-rw-r--r--sys-devel/perl/files/digest-perl-5.6.0-r21
6 files changed, 54 insertions, 11 deletions
diff --git a/dev-libs/slib/slib-2.3.8.ebuild b/dev-libs/slib/slib-2.3.8.ebuild
index 44f2154eab13..f66774ab0e33 100644
--- a/dev-libs/slib/slib-2.3.8.ebuild
+++ b/dev-libs/slib/slib-2.3.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/slib/slib-2.3.8.ebuild,v 1.2 2000/11/02 02:17:12 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/slib/slib-2.3.8.ebuild,v 1.3 2000/11/05 12:59:09 achim Exp $
P=slib2c8
A=${P}.zip
@@ -22,9 +22,9 @@ src_install () {
}
pkg_postinst () {
-
if [ "${ROOT}" == "/" ]
then
+ echo "Installing..."
guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)" "/"
fi
}
diff --git a/media-video/smpeg-xmms/smpeg-xmms-0.3.1.ebuild b/media-video/smpeg-xmms/smpeg-xmms-0.3.1.ebuild
index a316708a6761..825a8bfd4468 100644
--- a/media-video/smpeg-xmms/smpeg-xmms-0.3.1.ebuild
+++ b/media-video/smpeg-xmms/smpeg-xmms-0.3.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/smpeg-xmms/smpeg-xmms-0.3.1.ebuild,v 1.2 2000/09/15 20:09:06 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/smpeg-xmms/smpeg-xmms-0.3.1.ebuild,v 1.3 2000/11/05 12:59:09 achim Exp $
P=smpeg-xmms-0.3.1
A=${P}.tar.gz
@@ -10,11 +10,20 @@ DESCRIPTION="A MPEG Plugin for XMMS"
SRC_URI="ftp://ftp.xmms.org/xmms/plugins/smpeg-xmms/${A}"
HOMEPAGE="http://www.xmms.org/plugins_input.html"
+DEPEND=">=media-sound/xmms-1.2.3"
+RDEPEND=">=media-sound/xmms-1.2.3"
src_compile() {
cd ${S}
- try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ myopts="--prefix=/opt/gnome"
+ else
+ myopts="--prefix=/usr/X11R6"
+ fi
+ try ./configure ${myopts} --host=${CHOST}
try make
}
diff --git a/media-video/vlc/vlc-0.1.99h.ebuild b/media-video/vlc/vlc-0.1.99h.ebuild
index 4ea642d4694b..5ade0365cf60 100644
--- a/media-video/vlc/vlc-0.1.99h.ebuild
+++ b/media-video/vlc/vlc-0.1.99h.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.1.99h.ebuild,v 1.2 2000/09/15 20:09:06 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.1.99h.ebuild,v 1.3 2000/11/05 12:59:09 achim Exp $
P=vlc-0.1.99h
A=${P}.tar.bz2
@@ -10,15 +10,26 @@ DESCRIPTION="A Player for MPEG2 Videos"
SRC_URI="http://www.videolan.org/packages/0.1.99h/${A}"
HOMEPAGE="http://www.videolan.org/"
+DEPEND=">=media-libs/libsdl-1.1.5
+ gnome? ( gnome-base/gnome-libs-1.2.4 )"
+RDEPEND=$DEPEND
src_compile() {
unset CFLAGS
unset CXXFLAGS
cd ${S}
- try ./configure --prefix=/usr --host=${CHOST} \
+
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ myopts="--enable-gnome --prefix=/opt/gnome"
+ else
+ myopts="--prefix=/usr/X11R6"
+ fi
+ try ./configure --host=${CHOST} ${myopts} \
--enable-mmx --enable-dsp --enable-esd \
- --enable-fb --enable-sdl --enable-gnome --enable-x11
+ --enable-fb --enable-sdl --enable-x11
try make
}
@@ -26,7 +37,13 @@ src_compile() {
src_install () {
cd ${S}
- try make prefix=${D}/usr install
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr/X11R6 install
+ fi
dodoc AUTHORS ChangeLog COPYING README TODO
diff --git a/media-video/xmps/xmps-0.1.3-r1.ebuild b/media-video/xmps/xmps-0.1.3-r1.ebuild
index a5f1fa81e594..9277f0036bd1 100644
--- a/media-video/xmps/xmps-0.1.3-r1.ebuild
+++ b/media-video/xmps/xmps-0.1.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/xmps/xmps-0.1.3-r1.ebuild,v 1.4 2000/10/05 20:45:06 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xmps/xmps-0.1.3-r1.ebuild,v 1.5 2000/11/05 12:59:09 achim Exp $
P=xmps-0.1.3
A=${P}.tar.gz
@@ -10,10 +10,24 @@ DESCRIPTION="X Movie Player System"
SRC_URI="http://www-eleves.enst-bretagne.fr/~chavarri/xmps/sources/${A}"
HOMEPAGE="http://www-eleves.enst-bretagne.fr/~chavarri/xmps/"
+DEPEND=">=media-libs/smpeg-0.4.1
+ >=dev-lang/nasm-0.98
+ gnome? ( >=gnome-base/gnome-libs-1.2.4 )"
+
+RDEPEND=">=media-libs/smpeg-0.4.1
+ gnome? ( >=gnome-base/gnome-libs-1.2.4 )"
+
src_compile() {
cd ${S}
- try ./configure --prefix=/usr/X11R6 --host=${CHOST} \
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ myopts="--enable-gnome --prefix=/opt/gnome"
+ else
+ myopts="--disable-gnome --prefix=/usr/X11R6"
+ fi
+ try ./configure ${myopts} --host=${CHOST} \
--with-catgets
cp Makefile Makefile.orig
sed -e "s:\$(bindir)/xmps-config:\$(DESTDIR)\$(bindir)/xmps-config:" \
diff --git a/net-www/htdig/htdig-3.1.5.ebuild b/net-www/htdig/htdig-3.1.5.ebuild
index f900fd9a5e5c..6b99cd5775ce 100644
--- a/net-www/htdig/htdig-3.1.5.ebuild
+++ b/net-www/htdig/htdig-3.1.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/htdig-3.1.5.ebuild,v 1.3 2000/11/01 04:44:23 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/htdig-3.1.5.ebuild,v 1.4 2000/11/05 12:59:09 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -37,6 +37,8 @@ src_install () {
SEARCH_DIR=${D}/usr/local/httpd/htdocs/htdig \
IMAGE_DIR=${D}/usr/local/httpd/htdocs/images/htdig \
exec_prefix=${D}/usr install
+ dosed /etc/httpd/htdig.conf /usr/bin/rundig
+ dodoc ChangeLog COPYING README
}
diff --git a/sys-devel/perl/files/digest-perl-5.6.0-r2 b/sys-devel/perl/files/digest-perl-5.6.0-r2
new file mode 100644
index 000000000000..39a333a00793
--- /dev/null
+++ b/sys-devel/perl/files/digest-perl-5.6.0-r2
@@ -0,0 +1 @@
+MD5 b2940e2cc6312bcfa52355b684e70b9d perl-5.6.0.tar.gz