summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/xpa/ChangeLog8
-rw-r--r--x11-libs/xpa/metadata.xml1
-rw-r--r--x11-libs/xpa/xpa-2.1.10.ebuild55
3 files changed, 63 insertions, 1 deletions
diff --git a/x11-libs/xpa/ChangeLog b/x11-libs/xpa/ChangeLog
index b6befddc6e40..5c5e3c956497 100644
--- a/x11-libs/xpa/ChangeLog
+++ b/x11-libs/xpa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xpa
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.4 2009/01/09 22:41:48 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.5 2009/09/09 05:44:27 bicatali Exp $
+
+*xpa-2.1.10 (09 Sep 2009)
+
+ 09 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org> +xpa-2.1.10.ebuild,
+ metadata.xml:
+ Version bump, and added no-herd
09 Jan 2009; Joseph Jezak <josejx@gentoo.org> xpa-2.1.8.ebuild:
Marked ~ppc for bug #253299.
diff --git a/x11-libs/xpa/metadata.xml b/x11-libs/xpa/metadata.xml
index 7fd414fb5f89..3c8bcf1ed926 100644
--- a/x11-libs/xpa/metadata.xml
+++ b/x11-libs/xpa/metadata.xml
@@ -6,6 +6,7 @@
<name>Sébastien Fabbro</name>
<description>Feel free to take over</description>
</maintainer>
+<herd>no-herd</herd>
<longdescription lang="en">
The XPA messaging system provides seamless communication between many
kinds of Unix programs, including X programs and Tcl/Tk programs.
diff --git a/x11-libs/xpa/xpa-2.1.10.ebuild b/x11-libs/xpa/xpa-2.1.10.ebuild
new file mode 100644
index 000000000000..9912502bee59
--- /dev/null
+++ b/x11-libs/xpa/xpa-2.1.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/xpa-2.1.10.ebuild,v 1.1 2009/09/09 05:44:27 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Messaging system providing communication between programs"
+HOMEPAGE="http://hea-www.harvard.edu/RD/xpa"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND="dev-lang/tcl
+ x11-libs/libXt
+ !<sci-astronomy/ds9-5.3"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.8-makefile.patch
+ sed -i -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" mklib
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-threaded-xpans \
+ --with-x \
+ --with-tcl \
+ --with-threads
+}
+
+src_compile() {
+ emake shlib tclxpa || die "emake failed"
+}
+
+src_install () {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dosym libtclxpa.so.1.0 /usr/$(get_libdir)/libtclxpa.so
+ insinto /usr/$(get_libdir)/tclxpa
+ doins pkgIndex.tcl
+ mv "${D}"/usr/$(get_libdir)/libtclxpa* "${D}"/usr/$(get_libdir)/tclxpa/
+
+ dodoc README
+ if use doc; then
+ cd doc
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die
+ insinto /usr/share/doc/${PF}/html
+ doins *.html || die
+ fi
+}