summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/po4a/ChangeLog9
-rw-r--r--app-text/po4a/files/po4a-fix-io-capture.patch21
-rw-r--r--app-text/po4a/po4a-0.36.4.ebuild41
3 files changed, 70 insertions, 1 deletions
diff --git a/app-text/po4a/ChangeLog b/app-text/po4a/ChangeLog
index 5af1587b69d3..886bd07a50f2 100644
--- a/app-text/po4a/ChangeLog
+++ b/app-text/po4a/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/po4a
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/ChangeLog,v 1.37 2009/05/31 23:49:27 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/ChangeLog,v 1.38 2009/09/05 07:02:35 tove Exp $
+
+*po4a-0.36.4 (05 Sep 2009)
+
+ 05 Sep 2009; Torsten Veller <tove@gentoo.org>
+ +files/po4a-fix-io-capture.patch, +po4a-0.36.4.ebuild:
+ Version bump. Workaround for the perl hangs bug (#275268). Thanks to Kent
+ Fredric
31 May 2009; Brent Baude <ranger@gentoo.org> po4a-0.36.ebuild:
Marking po4a-0.36 ~ppc64 for bug 267987
diff --git a/app-text/po4a/files/po4a-fix-io-capture.patch b/app-text/po4a/files/po4a-fix-io-capture.patch
new file mode 100644
index 000000000000..91cd9848021b
--- /dev/null
+++ b/app-text/po4a/files/po4a-fix-io-capture.patch
@@ -0,0 +1,21 @@
+http://bugs.gentoo.org/show_bug.cgi?id=269650#c7
+from Kent Fredric
+--- po4a-0.36.4/Build.PL
++++ po4a-0.36.4/Build.PL
+@@ -127,8 +127,14 @@
+ my %options;
+ $options{utf8} = 1;
+ my $parser = Pod::Man->new (%options);
+-
+- system("PERL5LIB=lib perl po4a --previous po/pod.cfg") and die;
++ { # Fix for massive slowdown/Memory consumption
++ local %ENV = %ENV;
++ $ENV{PERL5LIB}='lib';
++ open( my $fh, '-|', qw( perl po4a --previous po/pod.cfg )) or die;
++ while( defined ( my $line = <$fh> ) ){
++ print $line;
++ }
++ }
+ system("mkdir -p blib/man/man7") and die;
+ system("mkdir -p blib/man/man1") and die;
+ system("cp doc/po4a.7.pod blib/man/man7") and die;
diff --git a/app-text/po4a/po4a-0.36.4.ebuild b/app-text/po4a/po4a-0.36.4.ebuild
new file mode 100644
index 000000000000..05e5fa5e7721
--- /dev/null
+++ b/app-text/po4a/po4a-0.36.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/po4a-0.36.4.ebuild,v 1.1 2009/09/05 07:02:35 tove Exp $
+
+EAPI=2
+
+inherit perl-app
+
+DESCRIPTION="Tools for helping translation of documentation"
+HOMEPAGE="http://po4a.alioth.debian.org"
+SRC_URI="mirror://debian/pool/main/p/po4a/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+MY_P=${PN}-v${PV}
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="dev-perl/SGMLSpm
+ >=sys-devel/gettext-0.13
+ app-text/openjade
+ dev-perl/Locale-gettext
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ >=virtual/perl-Module-Build-0.34.0201
+ test? ( app-text/docbook-sgml-dtd
+ app-text/docbook-sgml-utils
+ virtual/tex-base )"
+
+PATCHES=( "${FILESDIR}/po4a-fix-io-capture.patch" )
+SRC_TEST="do"
+
+src_prepare() {
+ rm "${S}"/Makefile || die
+ sed -i '/^Makefile$/d' "${S}"/MANIFEST || die
+ perl-module_src_prepare
+}