summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/Manifest18
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.10_rc1.ebuild8
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.8.ebuild8
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild8
5 files changed, 23 insertions, 27 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index ae39ed490b18..b1f15006d5b1 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.156 2005/08/25 07:03:05 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.157 2005/08/25 22:17:04 chriswhite Exp $
+
+ 25 Aug 2005; Chris White <chriswhite@gentoo.org> alsa-driver-1.0.8.ebuild,
+ alsa-driver-1.0.9b.ebuild, alsa-driver-1.0.10_rc1.ebuild:
+ Converted to linux-info.eclass methods so as to stop warning message spam.
+ Only remove old kernel sound modules if they actually exist (prevents silly
+ directory not found warnings with find).
24 Aug 2005; Chris White <chriswhite@gentoo.org>
+files/alsa-driver-1.0.10_rc1-include.patch,
diff --git a/media-sound/alsa-driver/Manifest b/media-sound/alsa-driver/Manifest
index 7d68b5d054f2..ec5f5a0b6c36 100644
--- a/media-sound/alsa-driver/Manifest
+++ b/media-sound/alsa-driver/Manifest
@@ -1,14 +1,12 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 12cdc86294529b15e5dd5868d0bd7fdf ChangeLog 27240
-MD5 108f913d07fdaced32c9ce8ae4043cfb alsa-driver-1.0.10_rc1.ebuild 4511
+MD5 73fc84ff1b226b659db4155d8f818332 alsa-driver-1.0.10_rc1.ebuild 4565
MD5 3c0f4daec01807f3cce65c8fff87ff3f alsa-driver-1.0.3.ebuild 3366
-MD5 2937d4d89a9282b8af1ee00ddbcbfcd6 alsa-driver-1.0.8.ebuild 4629
-MD5 803d9592f962d69ad91f08488a86fccf alsa-driver-1.0.9b.ebuild 4501
+MD5 0667138e8fbb04a9d799ac7a1183e8df alsa-driver-1.0.8.ebuild 4684
+MD5 8f7e90b15fc71635bea6aeec75f1b018 alsa-driver-1.0.9b.ebuild 4556
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 5445a523e0e8aa31b9f293b1ac380b37 files/1.0.8-msi_audigyls.patch 1771
MD5 8c120f7730b91118d0a8148d2deb3a43 files/alsa-driver-0.9.8-au-fix.patch 1267
+MD5 ed352c464a295465543d8933c162f101 files/alsa-driver-1.0.10_rc1-include.patch 346
MD5 be4912a88e538a1f620b2fd422859ef6 files/alsa-driver-1.0.9b-sparc64-ioctl-detect.patch 513
MD5 021076363d07efbc932afb961f1f3cf7 files/digest-alsa-driver-1.0.10_rc1 75
MD5 938a2ee36c54416322d1acd47b249c99 files/digest-alsa-driver-1.0.3 71
@@ -16,11 +14,3 @@ MD5 14b6c8d954e36bb9d40c97cf051220f0 files/digest-alsa-driver-1.0.8 71
MD5 496627835733f8108e6b10dfc8ee9bf4 files/digest-alsa-driver-1.0.9b 72
MD5 27ccbe36406f145c1d63725a53517233 files/makefile.patch 1122
MD5 b2791ec892d9be6952fe139cc2309abf files/xbox-1.0.8.patch 1525
-MD5 ed352c464a295465543d8933c162f101 files/alsa-driver-1.0.10_rc1-include.patch 346
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDDOLQFdQwWVoAgN4RAjNjAJ0X93rEmvJ8n/egn0ISEFuOQl/GswCghZvU
-Dwb9pQuZHnGvdKg/1zY0kk8=
-=WcwM
------END PGP SIGNATURE-----
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.10_rc1.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.10_rc1.ebuild
index a19e8e967558..2364030b6582 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.10_rc1.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.10_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.10_rc1.ebuild,v 1.2 2005/08/25 07:03:05 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.10_rc1.ebuild,v 1.3 2005/08/25 22:17:04 chriswhite Exp $
inherit linux-mod flag-o-matic eutils
@@ -84,9 +84,9 @@ src_compile() {
# linux-mod_src_compile doesn't work well with alsa
# -j1 : see bug #71028
- set_arch_to_kernel
+ ARCH=$(tc-arch-kernel)
emake -j1 || die "Make Failed"
- set_arch_to_portage
+ ARCH=$(tc-arch)
if use doc;
then
@@ -151,7 +151,7 @@ pkg_postinst() {
einfo "Check out the ALSA installation guide availible at the following URL:"
einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
- if kernel_is 2 6; then
+ if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
# Cleanup if they had older alsa installed
for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild
index 3a8e2415ebe2..8719c2465cd4 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild,v 1.15 2005/06/12 17:02:33 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.8.ebuild,v 1.16 2005/08/25 22:17:04 chriswhite Exp $
IUSE="oss doc"
inherit linux-mod flag-o-matic eutils
@@ -90,9 +90,9 @@ src_compile() {
# linux-mod_src_compile doesn't work well with alsa
# -j1 : see bug #71028
- set_arch_to_kernel
+ ARCH=$(tc-arch-kernel)
emake -j1 || die "Make Failed"
- set_arch_to_portage
+ ARCH=$(tc-arch)
if use doc;
then
@@ -158,7 +158,7 @@ pkg_postinst() {
einfo "Check out the ALSA installation guide availible at the following URL:"
einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
- if kernel_is 2 6; then
+ if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
# Cleanup if they had older alsa installed
for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
index a54a31eae2af..5a9321eaeb6d 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild,v 1.8 2005/07/21 03:41:06 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.9b.ebuild,v 1.9 2005/08/25 22:17:04 chriswhite Exp $
inherit linux-mod flag-o-matic eutils
@@ -80,9 +80,9 @@ src_compile() {
# linux-mod_src_compile doesn't work well with alsa
# -j1 : see bug #71028
- set_arch_to_kernel
+ ARCH=$(tc-arch-kernel)
emake -j1 || die "Make Failed"
- set_arch_to_portage
+ ARCH=$(tc-arch)
if use doc;
then
@@ -148,7 +148,7 @@ pkg_postinst() {
einfo "Check out the ALSA installation guide availible at the following URL:"
einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
- if kernel_is 2 6; then
+ if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
# Cleanup if they had older alsa installed
for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}