summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-roguelike/nethack/files/3.4.2-QT-support.patch11
-rw-r--r--games-roguelike/nethack/nethack-3.4.2.ebuild6
2 files changed, 14 insertions, 3 deletions
diff --git a/games-roguelike/nethack/files/3.4.2-QT-support.patch b/games-roguelike/nethack/files/3.4.2-QT-support.patch
index 22cfe1a354c8..93014af91ae8 100644
--- a/games-roguelike/nethack/files/3.4.2-QT-support.patch
+++ b/games-roguelike/nethack/files/3.4.2-QT-support.patch
@@ -18,3 +18,14 @@
@@ -248 +248 @@
-WINLIB = $(WINTTYLIB) $(WINX11LIB)
+WINLIB = $(WINTTYLIB) $(WINX11LIB) $(WINQTLIB)
+diff -ur nethack-3.4.2/win/Qt/qt_win.cpp nethack-3.4.2-gentoo/win/Qt/qt_win.cpp
+--- win/Qt/qt_win.cpp.orig 2003-09-30 01:47:32.000000000 +1200
++++ win/Qt/qt_win.cpp 2003-09-30 02:16:34.000000000 +1200
+@@ -57,6 +57,7 @@
+ #include "dlb.h"
+ #include "patchlevel.h"
+ #include "tile2x11.h"
++#undef Invisible
+ #undef Warning
+ #undef red
+ #undef green
diff --git a/games-roguelike/nethack/nethack-3.4.2.ebuild b/games-roguelike/nethack/nethack-3.4.2.ebuild
index 6c2cc464e99c..359b48be79f7 100644
--- a/games-roguelike/nethack/nethack-3.4.2.ebuild
+++ b/games-roguelike/nethack/nethack-3.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.2.ebuild,v 1.2 2003/09/17 02:37:17 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.2.ebuild,v 1.3 2003/10/06 06:59:15 vapier Exp $
inherit games eutils flag-o-matic gcc
append-flags -I../include
@@ -12,9 +12,9 @@ HOMEPAGE="http://www.nethack.org/"
SRC_URI="mirror://sourceforge/nethack/${PN}-${MY_PV}.tgz"
#SRC_URI="ftp://ftp.nethack.org/pub/nethack/nh340/src/nethack-340.tgz"
-KEYWORDS="x86 ppc sparc"
-SLOT="0"
LICENSE="nethack"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
IUSE="X qt gnome"
DEPEND="virtual/glibc