summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kmail/ChangeLog7
-rw-r--r--kde-base/kmail/kmail-3.5.9.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 7cb1616b19df..dad18f3bcca2 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.127 2008/02/17 01:44:18 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.128 2008/02/20 23:06:32 philantrop Exp $
+
+*kmail-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org> +kmail-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-files/kmail-3.5.5-dimap-mail-loss.patch, -files/kmail-utf8.diff,
diff --git a/kde-base/kmail/kmail-3.5.9.ebuild b/kde-base/kmail/kmail-3.5.9.ebuild
new file mode 100644
index 000000000000..4f5080ff2a56
--- /dev/null
+++ b/kde-base/kmail/kmail-3.5.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-3.5.9.ebuild,v 1.1 2008/02/20 23:06:32 philantrop Exp $
+
+KMNAME=kdepim
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdepim-3.5-patchset-04.tar.bz2"
+
+RESTRICT="test"
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt"
+
+DEPEND=">=kde-base/libkdenetwork-${PV}:${SLOT}
+ >=kde-base/libkdepim-${PV}:${SLOT}
+ >=kde-base/libkpimidentities-${PV}:${SLOT}
+ >=kde-base/mimelib-${PV}:${SLOT}
+ >=kde-base/libksieve-${PV}:${SLOT}
+ >=kde-base/certmanager-${PV}:${SLOT}
+ >=kde-base/libkcal-${PV}:${SLOT}
+ >=kde-base/kontact-${PV}:${SLOT}
+ >=kde-base/libkpgp-${PV}:${SLOT}
+ >=kde-base/libkmime-${PV}:${SLOT}"
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )
+ >=kde-base/kdepim-kioslaves-${PV}:${SLOT}
+ >=kde-base/kmailcvt-${PV}:${SLOT}
+ >=kde-base/kdebase-kioslaves-${PV}:${SLOT}
+ >=kde-base/kcontrol-${PV}:${SLOT}" # for the "looknfeel" icon, and probably others.
+
+KMCOPYLIB="
+ libkdepim libkdepim/
+ libkpimidentities libkpimidentities/
+ libmimelib mimelib/
+ libksieve libksieve/
+ libkleopatra certmanager/lib/
+ libkcal libkcal
+ libkpinterfaces kontact/interfaces/
+ libkmime libkmime
+ libkpgp libkpgp"
+KMEXTRACTONLY="
+ libkdenetwork/
+ libkdepim/
+ libkpimidentities/
+ libksieve/
+ libkcal/
+ mimelib/
+ certmanager/
+ korganizer/korganizeriface.h
+ korganizer/kcalendariface.h
+ kontact/interfaces/
+ libkmime/
+ libkpgp
+ dcopidlng"
+KMCOMPILEONLY="libemailfunctions"
+# the kmail plugins are installed with kmail
+KMEXTRA="plugins/kmail/
+ kontact/plugins/kmail/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_install() {
+ kde-meta_src_install
+ # Install KMail icons with libkdepim to work around bug #136810.
+ #find ${D}/${KDEDIR}/share/icons/hicolor/ -name "kmail\.png" -exec rm '{}' \;
+ rm "${D}/${KDEDIR}"/share/icons/hicolor/{16x16,22x22,32x32,48x48,64x64,128x128}/apps/kmail.png || die "deleting kmail.png failed"
+}