summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-scheme/plt-scheme/ChangeLog45
-rw-r--r--dev-scheme/plt-scheme/plt-scheme-4.2.ebuild91
2 files changed, 134 insertions, 2 deletions
diff --git a/dev-scheme/plt-scheme/ChangeLog b/dev-scheme/plt-scheme/ChangeLog
index b8350398358c..f8f077988a70 100644
--- a/dev-scheme/plt-scheme/ChangeLog
+++ b/dev-scheme/plt-scheme/ChangeLog
@@ -1,6 +1,47 @@
# ChangeLog for dev-scheme/plt-scheme
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/plt-scheme/ChangeLog,v 1.7 2009/03/22 13:05:35 hkbst Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/plt-scheme/ChangeLog,v 1.8 2009/06/04 15:35:12 hkbst Exp $
+
+*plt-scheme-4.2 (04 Jun 2009)
+
+ 04 Jun 2009; Marijn Schouten <hkBst@gentoo.org> +plt-scheme-4.2.ebuild:
+ bump
+ Internally, this version includes a conversion from C++ to Scheme
+ for part of the GUI toolbox --- specifically, 25k lines of code
+ that implement the general text and pasteboard editor. This
+ conversion is a start on a larger reimplementation of the GUI
+ toolbox. Although we believe that this change will help make PLT
+ Scheme better in the long run, we must expect bugs in the short
+ term due to porting errors. Users should therefore be aware of
+ the change, even though the new implementation is meant to behave
+ the same as previous versions.
+
+ * A new statistical profiler is now available; see the "profiler"
+ manual for more information. Currently, the profiler supports
+ only textual output, but future plans include a GUI interface
+ and DrScheme integration.
+
+ * The `world' teachpack is now deprecated. Its replacement
+ `universe' has a new interface that uses strings instead of
+ symbols and characters.
+
+ * Web-server: Native continuations in the stateless servlet
+ language support capturing continuations from untransformed
+ contexts; soft state library for stateless servlets.
+
+ * DrScheme's Stepper can now jump to a selected program
+ expression.
+
+ * New in `scheme/base': `hash-has-key?', `hash-ref!',
+ `in-sequences', `in-cycle'. New in `scheme': `count',
+ `make-list' (from `scheme/list'), `const' (from
+ `scheme/function').
+
+ * Some performance improvements, including faster start-up for small
+ programs. The latter is a result of delaying module invocations at
+ higher phases (compile time, meta-compile time, etc.) until
+ compilation is demanded at the next lower phase; this on-demand
+ instantiation is per-phase, as opposed to per-module within a phase.
22 Mar 2009; Marijn Schouten <hkBst@gentoo.org>
-plt-scheme-0.372-r1.ebuild, -plt-scheme-4.0.1.ebuild,
diff --git a/dev-scheme/plt-scheme/plt-scheme-4.2.ebuild b/dev-scheme/plt-scheme/plt-scheme-4.2.ebuild
new file mode 100644
index 000000000000..ae76632a6226
--- /dev/null
+++ b/dev-scheme/plt-scheme/plt-scheme-4.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/plt-scheme/plt-scheme-4.2.ebuild,v 1.1 2009/06/04 15:35:12 hkbst Exp $
+
+inherit eutils latex-package
+
+SRC_URI="http://download.plt-scheme.org/bundles/${PV}/plt/plt-${PV}-src-unix.tgz
+ http://pre.plt-scheme.org/installers/plt-${PV}-src-unix.tgz"
+#"mirror://gentoo/plt-${PV%%_p*}-src-unix.tgz"
+
+DESCRIPTION="DrScheme programming environment. Includes mzscheme."
+HOMEPAGE="http://www.plt-scheme.org"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="backtrace cairo cgc llvm opengl profile X"
+
+RDEPEND="X? ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXaw
+ >=x11-libs/libXft-2.1.12
+ x11-libs/libXrender
+ media-libs/freetype
+ media-libs/fontconfig
+ cairo? ( x11-libs/cairo )
+ media-libs/jpeg
+ opengl? ( virtual/opengl )
+ media-libs/libpng
+ sys-libs/zlib )"
+
+DEPEND="${RDEPEND} !dev-tex/slatex"
+
+S="${WORKDIR}/plt-${PV%%_p*}/src"
+
+pkg_setup() {
+ if use cairo && use X; then
+ if ! built_with_use x11-libs/cairo X; then
+ eerror "Cairo must be built with X use flag"
+ die "Cairo must be built with X use flag"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #remove bundled libraries
+ rm -rf wxcommon/{jpeg,libpng,zlib}
+
+ sed "s,docdir=\"\${datadir}/plt/doc,docdir=\"\${datadir}/doc/${PF}," -i configure || die
+}
+
+src_compile() {
+# according to vapier, we should use the bundled libtool
+# such that we don't preclude cross-compile. Thus don't use
+# --enable-lt=/usr/bin/libtool
+ econf $(use_enable X mred) \
+ --enable-shared \
+ --disable-perl \
+ $(use_enable backtrace) \
+ $(use_enable cairo) \
+ $(use_enable llvm) \
+ $(use_enable opengl gl) \
+ $(use_enable profile gprof) \
+ --enable-xft \
+ --enable-xrender
+
+ if use cgc; then
+ emake both || die "emake both failed"
+ else
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ # deal with slatex
+ insinto /usr/share/texmf/tex/latex/slatex/
+ doins ../collects/slatex/slatex.sty
+
+ if use cgc; then
+ emake DESTDIR="${D}" install-both || die "emake install-both failed"
+ else
+ emake DESTDIR="${D}" install || die "emake install failed"
+ fi
+
+ if use X; then
+ newicon ../collects/icons/PLT-206.png drscheme.png
+ make_desktop_entry drscheme "DrScheme" drscheme "Development"
+ fi
+}