summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-proxy/bfilter/ChangeLog10
-rw-r--r--net-proxy/bfilter/bfilter-1.1.4-r1.ebuild64
-rw-r--r--net-proxy/bfilter/files/bfilter-1.1.4-external-boost.patch45
-rw-r--r--net-proxy/bfilter/files/forwarding-proxy.xml19
-rw-r--r--net-proxy/bfilter/files/forwarding.xml5
5 files changed, 133 insertions, 10 deletions
diff --git a/net-proxy/bfilter/ChangeLog b/net-proxy/bfilter/ChangeLog
index cd396506ab1a..f8471d371623 100644
--- a/net-proxy/bfilter/ChangeLog
+++ b/net-proxy/bfilter/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-proxy/bfilter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/bfilter/ChangeLog,v 1.26 2009/02/18 19:22:48 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/bfilter/ChangeLog,v 1.27 2009/10/19 22:29:22 mrness Exp $
+
+*bfilter-1.1.4-r1 (19 Oct 2009)
+
+ 19 Oct 2009; Alin Năstac <mrness@gentoo.org> +bfilter-1.1.4-r1.ebuild,
+ files/bfilter-1.1.4-external-boost.patch, +files/forwarding.xml,
+ +files/forwarding-proxy.xml:
+ Migrate to EAPI 2. Install default forwarding.xml and forwarding-proxy.xml
+ example (#288100).
18 Feb 2009; Alin Năstac <mrness@gentoo.org>
-files/bfilter-1.1.1-date-test.patch,
diff --git a/net-proxy/bfilter/bfilter-1.1.4-r1.ebuild b/net-proxy/bfilter/bfilter-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..86921835c0f3
--- /dev/null
+++ b/net-proxy/bfilter/bfilter-1.1.4-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/bfilter/bfilter-1.1.4-r1.ebuild,v 1.1 2009/10/19 22:29:22 mrness Exp $
+
+EAPI=2
+
+inherit eutils autotools
+
+DESCRIPTION="An ad-filtering web proxy featuring an effective heuristic ad-detection algorithm"
+HOMEPAGE="http://bfilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bfilter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+IUSE="X debug"
+
+RDEPEND="sys-libs/zlib
+ dev-libs/ace
+ dev-libs/libsigc++:2
+ X? ( >=dev-cpp/gtkmm-2.4 )
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ dev-util/scons
+ dev-util/pkgconfig"
+
+RESTRICT="test" # boost's test API has changed
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-external-boost.patch
+ rm -rf "${S}"/boost
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with X gui) \
+ --without-builtin-boost || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ insinto /etc/bfilter
+ doins "${FILESDIR}"/forwarding.xml
+
+ dodoc AUTHORS ChangeLog "${FILESDIR}"/forwarding-proxy.xml
+ dohtml doc/*
+
+ newinitd "${FILESDIR}/bfilter.init" bfilter
+ newconfd "${FILESDIR}/bfilter.conf" bfilter
+}
+
+pkg_preinst() {
+ enewgroup bfilter
+ enewuser bfilter -1 -1 -1 bfilter
+}
+
+pkg_postinst() {
+ elog "The documentation is available at"
+ elog " http://bfilter.sourceforge.net/documentation.php"
+ elog "For forwarding bfilter service traffic through a proxy,"
+ elog "see forwarding-proxy.xml example installed in the doc directory."
+}
diff --git a/net-proxy/bfilter/files/bfilter-1.1.4-external-boost.patch b/net-proxy/bfilter/files/bfilter-1.1.4-external-boost.patch
index 65a4000a90fc..6f185ca9f41b 100644
--- a/net-proxy/bfilter/files/bfilter-1.1.4-external-boost.patch
+++ b/net-proxy/bfilter/files/bfilter-1.1.4-external-boost.patch
@@ -1,6 +1,21 @@
-diff -ur bfilter-1.1.4.orig/main/daemon/Makefile.am bfilter-1.1.4/main/daemon/Makefile.am
---- bfilter-1.1.4.orig/main/daemon/Makefile.am 2007-01-19 19:21:02.000000000 +0000
-+++ bfilter-1.1.4/main/daemon/Makefile.am 2008-07-13 08:49:46.000000000 +0000
+diff -Nru bfilter-1.1.4.orig/configure.in bfilter-1.1.4/configure.in
+--- bfilter-1.1.4.orig/configure.in 2007-11-11 23:14:49.000000000 +0100
++++ bfilter-1.1.4/configure.in 2009-10-18 18:26:32.000000000 +0200
+@@ -260,11 +260,6 @@
+ Makefile
+ binreloc/Makefile
+ foundation/Makefile
+-boost/Makefile
+-boost/libs/Makefile
+-boost/libs/regex/Makefile
+-boost/libs/program_options/Makefile
+-boost/libs/test/Makefile
+ reactor/Makefile
+ mkskel/Makefile
+ lexgen/Makefile
+diff -Nru bfilter-1.1.4.orig/main/daemon/Makefile.am bfilter-1.1.4/main/daemon/Makefile.am
+--- bfilter-1.1.4.orig/main/daemon/Makefile.am 2007-01-19 20:21:02.000000000 +0100
++++ bfilter-1.1.4/main/daemon/Makefile.am 2009-10-18 18:25:52.000000000 +0200
@@ -6,7 +6,7 @@
$(top_builddir)/boost/libs/program_options/libprogram_options.la
else
@@ -10,9 +25,9 @@ diff -ur bfilter-1.1.4.orig/main/daemon/Makefile.am bfilter-1.1.4/main/daemon/Ma
endif
AM_CPPFLAGS = -DSYSCONFDIR=\"$(sysconfdir)\" \
-diff -ur bfilter-1.1.4.orig/main/gui/gtk/Makefile.am bfilter-1.1.4/main/gui/gtk/Makefile.am
---- bfilter-1.1.4.orig/main/gui/gtk/Makefile.am 2008-06-02 15:25:27.000000000 +0000
-+++ bfilter-1.1.4/main/gui/gtk/Makefile.am 2008-07-13 08:49:46.000000000 +0000
+diff -Nru bfilter-1.1.4.orig/main/gui/gtk/Makefile.am bfilter-1.1.4/main/gui/gtk/Makefile.am
+--- bfilter-1.1.4.orig/main/gui/gtk/Makefile.am 2008-06-02 17:25:27.000000000 +0200
++++ bfilter-1.1.4/main/gui/gtk/Makefile.am 2009-10-18 18:25:52.000000000 +0200
@@ -50,7 +50,7 @@
BOOST_LIBS = $(top_builddir)/boost/libs/regex/libregex.la
else
@@ -22,9 +37,21 @@ diff -ur bfilter-1.1.4.orig/main/gui/gtk/Makefile.am bfilter-1.1.4/main/gui/gtk/
endif
if WITH_GUI
-diff -ur bfilter-1.1.4.orig/tests/Makefile.am bfilter-1.1.4/tests/Makefile.am
---- bfilter-1.1.4.orig/tests/Makefile.am 2007-05-07 14:19:40.000000000 +0000
-+++ bfilter-1.1.4/tests/Makefile.am 2008-07-13 08:49:46.000000000 +0000
+diff -Nru bfilter-1.1.4.orig/Makefile.am bfilter-1.1.4/Makefile.am
+--- bfilter-1.1.4.orig/Makefile.am 2007-11-11 23:16:04.000000000 +0100
++++ bfilter-1.1.4/Makefile.am 2009-10-18 18:26:46.000000000 +0200
+@@ -1,7 +1,7 @@
+ EXTRA_DIST = doc cmake bootstrap m4 VERSION CMakeLists.txt types.h pstdint.h \
+ config.h.cm bfilter.desktop bfilter.png Doxyfile
+ DISTCLEANFILES = itypes.h
+-SUBDIRS = binreloc foundation boost reactor mkskel lexgen libjs main conf \
++SUBDIRS = binreloc foundation reactor mkskel lexgen libjs main conf \
+ packaging tests
+
+ dist_man_MANS = bfilter.8
+diff -Nru bfilter-1.1.4.orig/tests/Makefile.am bfilter-1.1.4/tests/Makefile.am
+--- bfilter-1.1.4.orig/tests/Makefile.am 2007-05-07 16:19:40.000000000 +0200
++++ bfilter-1.1.4/tests/Makefile.am 2009-10-18 18:25:52.000000000 +0200
@@ -6,7 +6,7 @@
$(top_builddir)/boost/libs/regex/libregex.la
else
diff --git a/net-proxy/bfilter/files/forwarding-proxy.xml b/net-proxy/bfilter/files/forwarding-proxy.xml
new file mode 100644
index 000000000000..dafcbb1ed664
--- /dev/null
+++ b/net-proxy/bfilter/files/forwarding-proxy.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<forwarding>
+ <option name="Direct">
+ </option>
+ <option name="ISP Proxy" selected="selected">
+ <bypass>
+ <simple-hostnames/>
+ <host-mask>*.isp.com</host-mask>
+ <host-mask>192.168.*</host-mask>
+ </bypass>
+ <proxy-chain>
+ <proxy>
+ <type>socks4</type><!-- available types: http, socks4, socks4a and socks5 -->
+ <host>localhost</host>
+ <port>9050</port>
+ </proxy>
+ </proxy-chain>
+ </option>
+</forwarding>
diff --git a/net-proxy/bfilter/files/forwarding.xml b/net-proxy/bfilter/files/forwarding.xml
new file mode 100644
index 000000000000..9b62c6bfc4a9
--- /dev/null
+++ b/net-proxy/bfilter/files/forwarding.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<forwarding>
+ <option name="Direct" selected="selected">
+ </option>
+</forwarding>