summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/default-1.0_rc6/packages2
-rw-r--r--sys-devel/binutils/binutils-2.11.92.0.12.3-r1.ebuild105
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.11.92.0.12.3-r12
3 files changed, 108 insertions, 1 deletions
diff --git a/profiles/default-1.0_rc6/packages b/profiles/default-1.0_rc6/packages
index 6e163925546c..472c4a07467e 100644
--- a/profiles/default-1.0_rc6/packages
+++ b/profiles/default-1.0_rc6/packages
@@ -33,7 +33,7 @@
*>=sys-apps/baselayout-1.6.7
*>=sys-apps/portage-1.6.10
-*~sys-devel/binutils-2.11.90.0.31
+*~sys-devel/binutils-2.11.92.0.12.3
*=sys-devel/gcc-2.95.3-r5
*~sys-libs/glibc-2.2.4
>=sys-apps/sysklogd-1.4.1
diff --git a/sys-devel/binutils/binutils-2.11.92.0.12.3-r1.ebuild b/sys-devel/binutils/binutils-2.11.92.0.12.3-r1.ebuild
new file mode 100644
index 000000000000..ba34cdec0fa0
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.11.92.0.12.3-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.92.0.12.3-r1.ebuild,v 1.1 2001/12/24 18:20:59 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2 http://www.ibiblio.org/${PN}-manpages-${PV}.tar.bz2"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}
+ #man pages are tarred up seperately because building them depends on perl, which isn't installed at
+ #Gentoo Linux bootstrap time.
+ mkdir man; cd man
+ tar xjf ${DISTDIR}/${PN}-manpages-${PV}.tar.bz2 || die
+}
+
+src_compile() {
+ ./configure --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ --without-included-gettext || die
+
+ if [ "`use static`" ]
+ then
+ emake -e LDFLAGS=-all-static || die
+ else
+ emake || die
+ fi
+
+ if [ -z "`use build`" ]
+ then
+ #make the info pages (makeinfo included with gcc is used)
+ make info || die
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ #c++filt is included with gcc -- what are these GNU people thinking?
+ #but not the manpage, so leave that!
+ rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
+
+ #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip
+ #we should reverse it:
+
+ rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
+ #the strip symlink gets created in the loop below
+
+ #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
+ #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
+ #and create the appropriate symlinks. Things are cleaner that way.
+ cd ${D}/usr/bin
+ local x
+ for x in * strip
+ do
+ if [ ! -e ../${CHOST}/bin/${x} ]
+ then
+ mv $x ../${CHOST}/bin/${x}
+ else
+ rm -f $x
+ fi
+ ln -s ../${CHOST}/bin/${x} ${x}
+ done
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ #install info pages
+ make infodir=${D}/usr/share/info \
+ install-info || die
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ #install pre-generated manpages
+ rm -f ${D}/usr/share/man/man1/*
+ doman ${S}/man/*.1
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
+
+
+
diff --git a/sys-devel/binutils/files/digest-binutils-2.11.92.0.12.3-r1 b/sys-devel/binutils/files/digest-binutils-2.11.92.0.12.3-r1
new file mode 100644
index 000000000000..7eaee17c0d37
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.11.92.0.12.3-r1
@@ -0,0 +1,2 @@
+MD5 14e7d6e283326662d7287d8cba47cc58 binutils-2.11.92.0.12.3.tar.bz2 8101888
+MD5 eb31a229238366e29387fe8332816ccf binutils-manpages-2.11.92.0.12.3.tar.bz2 53248