summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-misc/yakuake/ChangeLog8
-rw-r--r--kde-misc/yakuake/yakuake-2.7.5.ebuild16
2 files changed, 20 insertions, 4 deletions
diff --git a/kde-misc/yakuake/ChangeLog b/kde-misc/yakuake/ChangeLog
index 496b2f32c2ed..98e662c4e667 100644
--- a/kde-misc/yakuake/ChangeLog
+++ b/kde-misc/yakuake/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-misc/yakuake
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/yakuake/ChangeLog,v 1.12 2006/10/29 01:18:51 flameeyes Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/yakuake/ChangeLog,v 1.13 2007/01/19 18:16:13 flameeyes Exp $
+
+ 19 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> yakuake-2.7.5.ebuild:
+ Install the .desktop file in the correct xdg directory, and add the correct
+ categories. This moves it to the System menu rather than Utilities.
29 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> yakuake-2.7.5.ebuild:
Add ~x86-fbsd keyword.
diff --git a/kde-misc/yakuake/yakuake-2.7.5.ebuild b/kde-misc/yakuake/yakuake-2.7.5.ebuild
index 0f9d282ec209..7ccd64f582f3 100644
--- a/kde-misc/yakuake/yakuake-2.7.5.ebuild
+++ b/kde-misc/yakuake/yakuake-2.7.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/yakuake/yakuake-2.7.5.ebuild,v 1.8 2006/10/29 01:18:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/yakuake/yakuake-2.7.5.ebuild,v 1.9 2007/01/19 18:16:13 flameeyes Exp $
inherit kde
@@ -20,3 +20,15 @@ DEPEND="|| ( kde-base/konsole
RDEPEND="${DEPEND}"
need-kde 3.3
+
+src_install() {
+ kde_src_install
+ rm -rf "${D}/usr/share/applnk"
+
+ insinto /usr/share/applications
+ doins "${S}/yakuake/src/yakuake.desktop"
+
+ # From upstream, fix menu categorization
+ echo "Categories=Qt;KDE;System;TerminalEmulator;" \
+ >> "${D}/usr/share/applications/yakuake.desktop"
+}