summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/wine/files/digest-wine-200104182
-rw-r--r--app-emulation/wine/files/wine.env5
-rw-r--r--app-emulation/wine/wine-20010418.ebuild66
-rw-r--r--dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild89
-rw-r--r--dev-tcltk/itcl/files/digest-itcl-3.21
-rw-r--r--dev-tcltk/itcl/files/itcl-3.2-gentoo.diff33
-rw-r--r--dev-tcltk/itcl/itcl-3.2.ebuild34
-rw-r--r--profiles/package.mask2
-rw-r--r--sys-apps/baselayout/files/rc.d/config/basic2
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.4-r5.ebuild1
10 files changed, 234 insertions, 1 deletions
diff --git a/app-emulation/wine/files/digest-wine-20010418 b/app-emulation/wine/files/digest-wine-20010418
new file mode 100644
index 000000000000..d427e2ffdb4d
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20010418
@@ -0,0 +1,2 @@
+MD5 d773c35c57579ac78f8926c5a7f9a1ec Wine-20010418.tar.gz
+MD5 6fc1bce5da60f7fe8b96d8cac4845505 winesetuptk-0.5.1b.tar.gz
diff --git a/app-emulation/wine/files/wine.env b/app-emulation/wine/files/wine.env
new file mode 100644
index 000000000000..8710e8042d27
--- /dev/null
+++ b/app-emulation/wine/files/wine.env
@@ -0,0 +1,5 @@
+PATH=/opt/wine/bin
+ROOTPATH=/opt/wine/bin
+MANPATH=/opt/wine/man
+INFODIR=/opt/wine/info
+LDPATH=/opt/wine/lib
diff --git a/app-emulation/wine/wine-20010418.ebuild b/app-emulation/wine/wine-20010418.ebuild
new file mode 100644
index 000000000000..5a50ad26749e
--- /dev/null
+++ b/app-emulation/wine/wine-20010418.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20010418.ebuild,v 1.1 2001/05/29 23:04:13 pete Exp $
+
+WSV=0.5.1b
+A="Wine-${PV}.tar.gz winesetuptk-${WSV}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/${A}
+ http://twine.codeweavers.com/~mpilka/winesetuptk/winesetuptk-${WSV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/
+ http://wine.codeweavers.com/winesetuptk.shtml"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=sys-libs/ncurses-5.2
+ opengl? ( virtual/opengl )"
+
+RDEPEND="${DEPEND}
+ >=dev-lang/tcl-tk-8.4.2
+ >=dev-tcltk/itcl-3.2"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+ if [ "`use opengl`" ]
+ then
+ myconf="--enable-opengl"
+ else
+ myconf="--disable-opengl"
+ fi
+ try ./configure --prefix=/opt/wine --sysconfdir=/etc/opt/wine \
+ --host=${CHOST} ${myconf}
+
+ try make depend
+ try make
+
+ cd ${WORKDIR}/winesetuptk-${WSV}
+ ./configure --prefix=/opt/wine --with-launcher=/opt/wine/bin \
+ --with-data=/opt/wine/share/winesetuptk --with-doc=/opt/wine/share/doc/winesetuptk
+}
+
+src_install () {
+
+ try make prefix=${D}/opt/wine install
+ insinto /etc/opt/wine
+ doins ${FILESDIR}/wine.conf
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE
+ dodoc README WARRANTY
+
+ cd ${WORKDIR}/winesetuptk-${WSV}
+ make PREFIX_BIN=${D}/opt/wine/bin \
+ PREFIX_SRC=${D}/opt/wine/share/winesetuptk \
+ PREFIX_DOC=${D}/opt/wine/share/doc/winesetuptk \
+ cw-install install
+ cd doc ; docinto winesetuptk-${WSV}
+ dodoc CHANGELOG.TXT LICENSE.TXT README.TXT
+ cd development_doc ; docinto winesetuptk-${WSV}/development_doc
+ dodoc CHANGELOG.TXT global_cfg_db_members.txt
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/wine.env 90wine
+}
+
diff --git a/dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild b/dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild
new file mode 100644
index 000000000000..c3d2e10a1bcc
--- /dev/null
+++ b/dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/dev-lang/tcl-tk/tcl-tk-8.1.1-r1.ebuild,v 1.2 2001/05/01 18:29:05 achim Exp
+
+R1=tcl8.4a2
+V1=8.4
+A1=${R1}.tar.gz
+S1=${WORKDIR}/${R1}
+SRC_URI1="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${A1}"
+
+R2=tk8.4a2
+V2=8.4
+A2=${R2}.tar.gz
+S2=${WORKDIR}/${R2}
+SRC_URI2="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${A2}"
+
+A="${A1} ${A2}"
+SRC_URI="${SRC_URI1} ${SRC_URI2}"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language/Tk Widget Set"
+
+DEPEND="virtual/glibc virtual/x11"
+
+# hyper-optimizations untested...
+#
+src_unpack() {
+ unpack ${A1}
+ unpack ${A2}
+}
+
+src_compile() {
+ cd ${S1}/unix
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man --enable-threads
+ try make CFLAGS=\""${CFLAGS}"\"
+ cd ${S2}/unix
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man --with-tcl=${S1}/unix --enable-threads
+ try make CFLAGS=\""${CFLAGS}"\"
+}
+
+src_install() {
+ cd ${S1}/unix
+ try make INSTALL_ROOT=${D} install
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S1}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S1}',TCL_SRC_DIR='/usr/lib/tcl${V1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S1}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S1}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${V1}/include/unix
+ install -c -m0644 ${S1}/unix/*.h ${D}/usr/lib/tcl${V1}/include/unix
+ dodir /usr/lib/tcl${V1}/include/generic
+ install -c -m0644 ${S1}/generic/*.h ${D}/usr/lib/tcl${V1}/include/generic
+ rm -f ${D}/usr/lib/tcl${V1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${V1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${V1}/include/generic/tclPlatDecls.h
+
+ cd ${S2}/unix
+ try make INSTALL_ROOT=${D} install
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TK_BUILD_LIB_SPEC='-L${S2}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_SRC_DIR='${S2}',TCL_SRC_DIR='/usr/lib/tk${V2}/include'," \
+ -e "s,^TK_BUILD_STUB_LIB_SPEC='-L${S2}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_BUILD_STUB_LIB_PATH='${S2}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh > ${D}/usr/lib/tkConfig.sh.new
+ mv ${D}/usr/lib/tkConfig.sh.new ${D}/usr/lib/tkConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tk${V2}/include/unix
+ install -c -m0644 ${S1}/unix/*.h ${D}/usr/lib/tk${V2}/include/unix
+ dodir /usr/lib/tk${V2}/include/generic
+ install -c -m0644 ${S1}/generic/*.h ${D}/usr/lib/tk${V2}/include/generic
+ rm -f ${D}/usr/lib/tk${V2}/include/generic/tk.h
+ rm -f ${D}/usr/lib/tk${V2}/include/generic/tkDecls.h
+ rm -f ${D}/usr/lib/tk${V2}/include/generic/tkPlatDecls.h
+
+ ln -sf tclsh${V1} ${D}/usr/bin/tclsh
+ ln -sf wish${V2} ${D}/usr/bin/wish
+
+ cd ${S1}
+ dodoc README changes license.terms
+
+}
diff --git a/dev-tcltk/itcl/files/digest-itcl-3.2 b/dev-tcltk/itcl/files/digest-itcl-3.2
new file mode 100644
index 000000000000..ca001f8b04ab
--- /dev/null
+++ b/dev-tcltk/itcl/files/digest-itcl-3.2
@@ -0,0 +1 @@
+MD5 b41ed909969eaa5f0a06ab698393760f itcl3.2.tar.gz
diff --git a/dev-tcltk/itcl/files/itcl-3.2-gentoo.diff b/dev-tcltk/itcl/files/itcl-3.2-gentoo.diff
new file mode 100644
index 000000000000..1821124c95f2
--- /dev/null
+++ b/dev-tcltk/itcl/files/itcl-3.2-gentoo.diff
@@ -0,0 +1,33 @@
+diff -ur itcl3.2.orig/itcl/generic/itcl_class.c itcl3.2/itcl/generic/itcl_class.c
+--- itcl3.2.orig/itcl/generic/itcl_class.c Mon Aug 28 23:58:00 2000
++++ itcl3.2/itcl/generic/itcl_class.c Tue May 29 12:00:19 2001
+@@ -960,7 +960,7 @@
+ * it--as it is being resolved again by the compiler.
+ */
+ cmdPtr = (Command*)mfunc->accessCmd;
+- if (!cmdPtr || cmdPtr->deleted) {
++ if (!cmdPtr || (cmdPtr->flags & CMD_IS_DELETED)) {
+ mfunc->accessCmd = NULL;
+
+ if ((flags & TCL_LEAVE_ERR_MSG) != 0) {
+diff -ur itcl3.2.orig/itcl/generic/itcl_ensemble.c itcl3.2/itcl/generic/itcl_ensemble.c
+--- itcl3.2.orig/itcl/generic/itcl_ensemble.c Mon Aug 28 23:58:00 2000
++++ itcl3.2/itcl/generic/itcl_ensemble.c Tue May 29 12:05:33 2001
+@@ -819,7 +819,7 @@
+ cmdPtr->clientData = NULL;
+ cmdPtr->deleteProc = DeleteEnsemble;
+ cmdPtr->deleteData = cmdPtr->objClientData;
+- cmdPtr->deleted = 0;
++ cmdPtr->flags &= ~CMD_IS_DELETED;
+ cmdPtr->importRefPtr = NULL;
+
+ ensPart->cmdPtr = cmdPtr;
+@@ -896,7 +896,7 @@
+ cmdPtr->clientData = NULL;
+ cmdPtr->deleteProc = deleteProc;
+ cmdPtr->deleteData = (ClientData)clientData;
+- cmdPtr->deleted = 0;
++ cmdPtr->flags &= ~CMD_IS_DELETED;
+ cmdPtr->importRefPtr = NULL;
+
+ ensPart->cmdPtr = cmdPtr;
diff --git a/dev-tcltk/itcl/itcl-3.2.ebuild b/dev-tcltk/itcl/itcl-3.2.ebuild
new file mode 100644
index 000000000000..e72bd010a327
--- /dev/null
+++ b/dev-tcltk/itcl/itcl-3.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/itcl/itcl-3.2.ebuild,v 1.1 2001/05/29 23:04:13 pete Exp $
+
+#P=
+A=itcl${PV}.tar.gz
+S=${WORKDIR}/itcl${PV}
+DESCRIPTION="Object Oriented Enhancements for Tcl/Tk"
+SRC_URI="http://dev.scriptics.com/ftp/itcl/${A}"
+HOMEPAGE="http://dev.scriptics.com/ftp/itcl/"
+
+DEPEND=">=dev-lang/tcl-tk-8.4.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ try patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make CFLAGS_DEFAULT=\""${CFLAGS}"\"
+}
+
+src_install () {
+ try make prefix=${D}/usr install
+ rm ${D}/usr/lib/iwidgets
+ ln -s iwidgets3.0.1 ${D}/usr/lib/iwidgets
+ dodoc CHANGES INCOMPATIBLE README TODO
+ cd ${S}/doc ; docinto doc
+ dodoc README
+}
+
diff --git a/profiles/package.mask b/profiles/package.mask
index 1def7792fa4a..f89e560898ff 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -12,3 +12,5 @@ app-editors/gtk-xemacs
app-text/sgml2x
>=net-nds/openldap-2.0
sys-kernel/linux-sources-2.4.4-r5
+sys-kernel/linux-extras-2.4.4-r5
+sys-kernel/linux-2.4.4-r5
diff --git a/sys-apps/baselayout/files/rc.d/config/basic b/sys-apps/baselayout/files/rc.d/config/basic
index d07ae726cddf..5086bd6e4772 100644
--- a/sys-apps/baselayout/files/rc.d/config/basic
+++ b/sys-apps/baselayout/files/rc.d/config/basic
@@ -6,7 +6,7 @@
KEYMAP="us"
CONSOLEFONT="grfixed"
-#pete lives in the USE, and uses these settings
+#pete lives in the USA, and uses these settings
#KEYMAP="us"
#CONSOLEFONT="t -m straight-to-font"
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.4-r5.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.4-r5.ebuild
index 63ce2c831d69..85b2679b0eab 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.4-r5.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.4-r5.ebuild
@@ -381,6 +381,7 @@ src_compile() {
try make mrproper
fi
try ./configure --with-kernel=\"${S}\" --with-isapnp=yes --with-sequencer=yes --with-oss=yes --with-cards=all
+ mkdir -p modules
try make
fi
if [ "`use pcmcia-cs`" ]