summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-laptop/batti/ChangeLog9
-rw-r--r--app-laptop/batti/batti-0.3.4.ebuild (renamed from app-laptop/batti/batti-0.3.1.ebuild)16
2 files changed, 19 insertions, 6 deletions
diff --git a/app-laptop/batti/ChangeLog b/app-laptop/batti/ChangeLog
index eea89e6f7df2..c40e3a60ac26 100644
--- a/app-laptop/batti/ChangeLog
+++ b/app-laptop/batti/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-laptop/batti
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/batti/ChangeLog,v 1.3 2010/04/13 19:32:09 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/batti/ChangeLog,v 1.4 2010/04/16 14:12:51 idl0r Exp $
+
+*batti-0.3.4 (16 Apr 2010)
+
+ 16 Apr 2010; Christian Ruppert <idl0r@gentoo.org> -batti-0.3.1.ebuild,
+ +batti-0.3.4.ebuild:
+ Version bump. Remove dev-python/python-distutils-extra dependency, fixes
+ bug 315551. Add support for multiple python installations.
13 Apr 2010; Christian Ruppert <idl0r@gentoo.org> batti-0.3.1.ebuild:
Remove ewarn to tell the user he has to be in the messagebus group. Depend
diff --git a/app-laptop/batti/batti-0.3.1.ebuild b/app-laptop/batti/batti-0.3.4.ebuild
index e22d616c4d56..6649e3271a34 100644
--- a/app-laptop/batti/batti-0.3.1.ebuild
+++ b/app-laptop/batti/batti-0.3.4.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/batti/batti-0.3.1.ebuild,v 1.3 2010/04/13 19:32:09 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/batti/batti-0.3.4.ebuild,v 1.1 2010/04/16 14:12:51 idl0r Exp $
-EAPI=2
+EAPI=3
+PYTHON_SUPPORT_ABIS="1"
PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
-inherit distutils gnome2-utils
+inherit python distutils gnome2-utils
DESCRIPTION="A upower based battery monitor for the system tray, similar to batterymon"
HOMEPAGE="http://code.google.com/p/batti-gtk/"
@@ -21,14 +23,18 @@ RDEPEND="dev-python/pygtk
dev-python/dbus-python
|| ( sys-apps/devicekit-power sys-power/upower )
libnotify? ( x11-libs/libnotify )"
-DEPEND="${RDEPEND}
- dev-python/python-distutils-extra"
+DEPEND=""
pkg_setup() {
DOCS="AUTHORS"
python_set_active_version 2
}
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs 2 batti
+}
+
pkg_preinst() {
gnome2_icon_savelist
}