summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmnd/ChangeLog7
-rw-r--r--x11-plugins/wmnd/Manifest2
-rw-r--r--x11-plugins/wmnd/files/digest-wmnd-0.4.11-r11
-rw-r--r--x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild35
4 files changed, 44 insertions, 1 deletions
diff --git a/x11-plugins/wmnd/ChangeLog b/x11-plugins/wmnd/ChangeLog
index 5bc5c5f35a7e..e3fd4d485261 100644
--- a/x11-plugins/wmnd/ChangeLog
+++ b/x11-plugins/wmnd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmnd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnd/ChangeLog,v 1.31 2005/04/11 07:37:41 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnd/ChangeLog,v 1.32 2005/05/16 09:37:27 s4t4n Exp $
+
+*wmnd-0.4.11-r1 (16 May 2005)
+
+ 16 May 2005; Michele Noberasco <s4t4n@gentoo.org> wmnd-0.4.11-r1.ebuild:
+ Revision bump, adding "snmp" USE flag. Closes #88067.
11 Apr 2005; Michele Noberasco <s4t4n@gentoo.org> wmnd-0.4.9.ebuild:
Wiped out older version.
diff --git a/x11-plugins/wmnd/Manifest b/x11-plugins/wmnd/Manifest
index 7dbf5774c16d..09f3db78b7bc 100644
--- a/x11-plugins/wmnd/Manifest
+++ b/x11-plugins/wmnd/Manifest
@@ -1,4 +1,6 @@
MD5 77f765b16a0e8bc125c439ea28eae45e wmnd-0.4.11.ebuild 756
+MD5 debdf79e0116d7b2e0eed51f08e589c3 wmnd-0.4.11-r1.ebuild 783
MD5 ccd7e896f3f3e3775d2d9556c452e47b ChangeLog 3407
MD5 35b06c646b51979b2022449f31d7a7ee metadata.xml 448
+MD5 8a1fa932715cb4c1c287aabf20d0d276 files/digest-wmnd-0.4.11-r1 63
MD5 8a1fa932715cb4c1c287aabf20d0d276 files/digest-wmnd-0.4.11 63
diff --git a/x11-plugins/wmnd/files/digest-wmnd-0.4.11-r1 b/x11-plugins/wmnd/files/digest-wmnd-0.4.11-r1
new file mode 100644
index 000000000000..298453ba33e6
--- /dev/null
+++ b/x11-plugins/wmnd/files/digest-wmnd-0.4.11-r1
@@ -0,0 +1 @@
+MD5 f7a57fa5b610373326007b43e341a85c wmnd-0.4.11.tar.gz 258131
diff --git a/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild b/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild
new file mode 100644
index 000000000000..5022124a751c
--- /dev/null
+++ b/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild,v 1.1 2005/05/16 09:37:27 s4t4n Exp $
+
+IUSE="snmp"
+DESCRIPTION="WindowMaker Network Devices (dockapp)"
+HOMEPAGE="http://www.yuv.info/wmnd/"
+SRC_URI="ftp://ftp.yuv.info/pub/wmnd/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+DEPEND="virtual/x11
+ snmp? ( >=net-analyzer/net-snmp-5.2.1 )"
+
+src_compile()
+{
+ if use snmp; then
+ LDFLAGS="$LDFLAGS -lcrypto"
+ fi
+
+ LDFLAGS="$LDFLAGS" econf || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install()
+{
+ einstall || die "make install failed"
+
+ dodoc README AUTHORS COPYING ChangeLog INSTALL NEWS TODO
+
+ # gpl.info is no valid .info file. Causes errors with install-info.
+ rm -r ${D}/usr/share/info
+}