summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/graphviz/ChangeLog10
-rw-r--r--media-gfx/graphviz/graphviz-2.22.1.ebuild5
-rw-r--r--media-gfx/graphviz/graphviz-2.22.2-r1.ebuild213
-rw-r--r--media-gfx/graphviz/graphviz-2.22.2.ebuild5
-rw-r--r--media-gfx/graphviz/metadata.xml3
5 files changed, 231 insertions, 5 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index ab8cf355c580..817c395096c3 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/graphviz
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.188 2009/03/19 18:18:29 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.189 2009/04/05 20:00:13 maekke Exp $
+
+*graphviz-2.22.2-r1 (05 Apr 2009)
+
+ 05 Apr 2009; Markus Meier <maekke@gentoo.org> metadata.xml,
+ graphviz-2.22.1.ebuild, graphviz-2.22.2.ebuild,
+ +graphviz-2.22.2-r1.ebuild:
+ disable automagic media-libs/lasi dep, create a new revision with lasi
+ USE-flag, bug #264362
*graphviz-2.22.2 (19 Mar 2009)
diff --git a/media-gfx/graphviz/graphviz-2.22.1.ebuild b/media-gfx/graphviz/graphviz-2.22.1.ebuild
index 3c59935ace9f..c30174148626 100644
--- a/media-gfx/graphviz/graphviz-2.22.1.ebuild
+++ b/media-gfx/graphviz/graphviz-2.22.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.22.1.ebuild,v 1.2 2009/03/12 06:03:18 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.22.1.ebuild,v 1.3 2009/04/05 20:00:13 maekke Exp $
EAPI="2"
@@ -148,7 +148,8 @@ src_configure() {
--with-ipsepcola
--with-libgd
--without-gdk-pixbuf
- --without-ming"
+ --without-ming
+ --without-lasi"
# new/experimental features, to be tested, disable for now
myconf="${myconf}
diff --git a/media-gfx/graphviz/graphviz-2.22.2-r1.ebuild b/media-gfx/graphviz/graphviz-2.22.2-r1.ebuild
new file mode 100644
index 000000000000..5a4fb650e974
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-2.22.2-r1.ebuild
@@ -0,0 +1,213 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.22.2-r1.ebuild,v 1.1 2009/04/05 20:00:13 maekke Exp $
+
+EAPI="2"
+
+inherit eutils autotools multilib python
+
+DESCRIPTION="Open Source Graph Visualization Software"
+HOMEPAGE="http://www.graphviz.org/"
+SRC_URI="http://www.graphviz.org/pub/graphviz/ARCHIVE/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="cairo doc examples gnome gtk java jpeg lasi nls perl png python ruby tcl"
+
+# Requires ksh
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/expat-2.0.0
+ >=dev-libs/glib-2.11.1
+ >=media-libs/fontconfig-2.3.95
+ >=media-libs/freetype-2.1.10
+ >=media-libs/gd-2.0.28[png?,jpeg?]
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.10
+ virtual/libiconv
+ cairo? (
+ x11-libs/libXaw
+ >=x11-libs/pango-1.12
+ >=x11-libs/cairo-1.1.10[svg]
+ )
+ gtk? (
+ >=x11-libs/gtk+-2
+ x11-libs/libXaw
+ >=x11-libs/pango-1.12
+ >=x11-libs/cairo-1.1.10
+ gnome? ( gnome-base/libgnomeui )
+ )
+ lasi? ( media-libs/lasi )
+ ruby? ( dev-lang/ruby )
+ tcl? ( >=dev-lang/tcl-8.3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.20
+ sys-devel/flex
+ java? ( dev-lang/swig )
+ nls? ( >=sys-devel/gettext-0.14.5 )
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )
+ tcl? ( || ( <dev-lang/swig-1.3.38[tcl]
+ >=dev-lang/swig-1.3.38 ) )"
+
+# Dependency description / Maintainer-Info:
+
+# Rendering is done via the following plugins (/plugins):
+# - core, dot_layout, neato_layout, gd , dot
+# the ones which are always compiled in, depend on zlib, gd
+# - gtk
+# Directly depends on gtk-2.
+# gtk-2 depends on pango, cairo and libX11 directly.
+# - gdk-pixbuf
+# Disabled, GTK-1 junk.
+# - ming
+# Disabled, depends on ming-3.0 which is still p.masked.
+# - cairo:
+# Needs pango for text layout, uses cairo methods to draw stuff
+# - xlib :
+# needs cairo+pango,
+# can make use of gnomeui and inotify support,
+# needs libXaw for UI
+
+# There can be swig-generated bindings for the following languages (/tclpkg/gv):
+# - c-sharp (disabled)
+# - scheme (enabled via guile) ... broken on ~x86
+# - io (disabled)
+# - java (enabled via java) *2
+# - lua (enabled via lua)
+# - ocaml (enabled via ocaml)
+# - perl (enabled via perl) *1
+# - php (enabled via php) *2
+# - python (enabled via python) *1
+# - ruby (enabled via ruby) *1
+# - tcl (enabled via tcl)
+# *1 = The ${P}-bindings.patch takes care that those bindings are installed to the right location
+# *2 = Those bindings don't build because the paths for the headers/libs aren't
+# detected correctly and/or the options passed to swig are wrong (-php instead of -php4/5)
+
+# There are several other tools in /tclpkg:
+# gdtclft, tcldot, tclhandle, tclpathplan, tclstubs ; enabled with: --with-tcl
+# tkspline, tkstubs ; enabled with: --with-tk
+
+# And the commands (/cmd):
+# - dot, dotty, gvpr, lefty, lneato, tools/* :)
+# Lefty needs Xaw and X to build
+
+src_prepare() {
+ # ToDo: Do the same thing for examples and/or
+ # write a patch for a configuration-option
+ # and send it to upstream
+ if ! use doc ; then
+ find . -iname Makefile.am \
+ | xargs sed -i -e '/html_DATA/d' -e '/pdf_DATA/d' || die
+ fi
+
+ # This is an old version of libtool
+ rm -rf libltdl
+ sed -i -e '/libltdl/d' configure.ac || die
+
+ # Update this file from our local libtool which is much newer than the
+ # bundled one. This allows MAKEOPTS=-j2 to work on FreeBSD.
+ if has_version ">=sys-devel/libtool-2" ; then
+ cp /usr/share/libtool/config/install-sh config || die
+ else
+ cp /usr/share/libtool/install-sh config || die
+ fi
+
+ # no nls, no gettext, no iconv macro, so disable it
+ use nls || { sed -i -e '/^AM_ICONV/d' configure.ac || die; }
+
+ # Nuke the dead symlinks for the bindings
+ sed -i -e '/$(pkgluadir)/d' tclpkg/gv/Makefile.am || die
+
+ # replace the whitespace with tabs
+ sed -i -e 's: :\t:g' doc/info/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # Core functionality:
+ # All of X, cairo-output, gtk need the pango+cairo functionality
+ if use gtk || use cairo ; then
+ myconf="${myconf} --with-x"
+ else
+ myconf="${myconf} --without-x"
+ fi
+ myconf="${myconf}
+ $(use_with cairo pangocairo)
+ $(use_with gtk)
+ $(use_with lasi)
+ --with-digcola
+ --with-fontconfig
+ --with-freetype2
+ --with-ipsepcola
+ --with-libgd
+ --without-gdk-pixbuf
+ --without-ming"
+
+ # new/experimental features, to be tested, disable for now
+ myconf="${myconf}
+ --without-digcola
+ --without-ipsepcola
+ --without-sfdp
+ --without-smyrna"
+
+ use gtk && myconf="${myconf} $(use_with gnome gnomeui)"
+
+ # Bindings:
+ myconf="${myconf}
+ --disable-guile
+ --disable-io
+ $(use_enable java)
+ --disable-lua
+ --disable-ocaml
+ $(use_enable perl)
+ --disable-php
+ $(use_enable python)
+ --disable-r
+ $(use_enable ruby)
+ --disable-sharp
+ $(use_enable tcl)"
+
+ econf \
+ --enable-ltdl \
+ ${myconf}
+}
+
+src_install() {
+ sed -i -e "s:htmldir:htmlinfodir:g" doc/info/Makefile || die
+
+ emake DESTDIR="${D}" \
+ txtdir=/usr/share/doc/${PF} \
+ htmldir=/usr/share/doc/${PF}/html \
+ htmlinfodir=/usr/share/doc/${PF}/html/info \
+ pdfdir=/usr/share/doc/${PF}/pdf \
+ pkgconfigdir=/usr/$(get_libdir)/pkgconfig \
+ install || die "emake install failed"
+
+ use examples || rm -rf "${D}/usr/share/graphviz/demo"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ # This actually works if --enable-ltdl is passed
+ # to configure
+ dot -c
+ if use python ; then
+ python_mod_optimize
+ fi
+}
+
+pkg_postrm() {
+ if use python ; then
+ python_mod_cleanup
+ fi
+}
diff --git a/media-gfx/graphviz/graphviz-2.22.2.ebuild b/media-gfx/graphviz/graphviz-2.22.2.ebuild
index 5ac0cebba6d9..79b05b196b5b 100644
--- a/media-gfx/graphviz/graphviz-2.22.2.ebuild
+++ b/media-gfx/graphviz/graphviz-2.22.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.22.2.ebuild,v 1.1 2009/03/19 18:18:29 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.22.2.ebuild,v 1.2 2009/04/05 20:00:13 maekke Exp $
EAPI="2"
@@ -148,7 +148,8 @@ src_configure() {
--with-ipsepcola
--with-libgd
--without-gdk-pixbuf
- --without-ming"
+ --without-ming
+ --without-lasi"
# new/experimental features, to be tested, disable for now
myconf="${myconf}
diff --git a/media-gfx/graphviz/metadata.xml b/media-gfx/graphviz/metadata.xml
index 0e9f1fea54e2..bbf96303e444 100644
--- a/media-gfx/graphviz/metadata.xml
+++ b/media-gfx/graphviz/metadata.xml
@@ -32,6 +32,9 @@ a database of telephone calls or e-mail messages
<flag name='cgraph'>
Enables cgraph (PostScript plotting library in C) library
</flag>
+ <flag name='lasi'>
+ Enables PostScript output via <pkg>media-libs/lasi</pkg> library
+ </flag>
<flag name='pango'>
Enables the rendering of the graphs using pango &amp; cairo (with antialiasing support)
</flag>