summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/licq/ChangeLog6
-rw-r--r--net-im/licq/files/digest-licq-1.2.6-r11
-rw-r--r--net-im/licq/licq-1.2.6-r1.ebuild146
3 files changed, 152 insertions, 1 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 36f6c3013319..1e2fb1631813 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-im/licq
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.22 2003/04/22 22:36:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.23 2003/05/04 18:30:38 lordvan Exp $
+*licq-1.2.6-r1 (04 May 2003)
+ 04 May 2003; Thomas Raschbacher <lordvan@gentoo.org licq-1.2.6-r1.ebuild:
+ fixes from brad@gentoo.org (bug #18205)
+
*licq-1.2.6 (22 Apr 2003)
22 Apr 2003; Daniel Robbins <drobbins@gentoo.org> licq-1.2.6.ebuild: A
diff --git a/net-im/licq/files/digest-licq-1.2.6-r1 b/net-im/licq/files/digest-licq-1.2.6-r1
new file mode 100644
index 000000000000..8d03f75b6eb7
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.2.6-r1
@@ -0,0 +1 @@
+MD5 7e84a1dde8b21eb2bb057d3755353500 licq-1.2.6.tar.bz2 3282918
diff --git a/net-im/licq/licq-1.2.6-r1.ebuild b/net-im/licq/licq-1.2.6-r1.ebuild
new file mode 100644
index 000000000000..21742d40b579
--- /dev/null
+++ b/net-im/licq/licq-1.2.6-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.6-r1.ebuild,v 1.1 2003/05/04 18:30:38 lordvan Exp $
+
+inherit kde-base
+need-kde 3.0
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org/"
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86"
+IUSE="ssl socks5 qt kde ncurses"
+
+# we can't have conditional dependencies so "use kde && inherit kde-base"
+# won't work -- messes up dep caching.
+
+# need-kde and their eclass friends inject things into DEPEND. But we only
+# want them enabled if the kde USE flag is set. We get around this in the
+# following dep lines:
+RDEPEND="kde? ( ${DEPEND} )"
+DEPEND="kde? ( ${DEPEND} )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-3.0.0 )
+ ncurses? ( sys-libs/ncurses )"
+
+src_unpack() {
+ unpack ${A}
+
+ if [ "`use kde`" ]
+ then
+ # fix for #12436
+ ebegin "Setting kde plugin as default..."
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = kde-gui:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ else
+ if [ -z "`use qt`" ]
+ then
+ ebegin "Setting console plugin as default..."
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = console:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ fi
+ fi
+}
+
+src_compile() {
+ local first_conf
+ use ssl || myconf="${myconf} --disable-openssl"
+ use socks5 && myconf="${myconf} --enable-socks5"
+
+ econf ${myconf} || die
+ emake || die
+
+ # Create the various plug-ins
+
+ # First, the Qt plug-in
+ if [ "`use qt`" ]
+ then
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
+ use kde && kde_src_compile myconf
+ use kde && myconf="${myconf} --with-kde"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd ${S}/plugins/qt-gui
+ einfo "Compiling Qt GUI plug-in"
+ econf ${myconf} || die
+ emake || die
+ fi
+
+ # Now the console plug-in
+ if [ "`use ncurses `" ]
+ then
+ cd ${S}/plugins/console
+ einfo "Compiling the Console plug-in"
+ econf || die
+ emake || die
+ fi
+
+ # The Auto-Responder plug-in
+ cd ${S}/plugins/auto-reply
+ einfo "Compiling the Auto-Reply plug-in"
+ econf || die
+ emake || die
+
+ # The Remote Management Service
+ cd ${S}/plugins/rms
+ einfo "Compiling Remote Management Services plug-in"
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog INSTALL README*
+
+ # Install the plug-ins
+ if [ "`use qt`" ]
+ then
+ cd ${S}/plugins/qt-gui
+ make DESTDIR=${D} install || die
+ docinto plugins/qt-gui
+ dodoc README*
+
+ # fix bug #12436, see my comment there
+## if [ "`use kde`" ]; then
+## cd $D/usr/lib/licq
+## ln -s licq_kde-gui.la licq_qt-gui.la
+## ln -s licq_kde-gui.so licq_qt-gui.so
+## fi
+ fi
+
+ if [ "`use ncurses`" ]
+ then
+ cd ${S}/plugins/console
+ make DESTDIR=${D} install || die
+ docinto plugins/console
+ dodoc README
+ fi
+
+
+ cd ${S}/plugins/auto-reply
+ make DESTDIR=${D} install || die
+ docinto plugins/auto-reply
+ dodoc README licq_autoreply.conf
+
+ cd ${S}/plugins/rms
+ make DESTDIR=${D} install || die
+ docinto plugins/rms
+ dodoc README licq_rms.conf
+}