summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyquery/ChangeLog7
-rw-r--r--dev-python/pyquery/pyquery-1.2.8.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/pyquery/ChangeLog b/dev-python/pyquery/ChangeLog
index 293867c63097..89f1d38ae226 100644
--- a/dev-python/pyquery/ChangeLog
+++ b/dev-python/pyquery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyquery
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyquery/ChangeLog,v 1.42 2014/01/18 15:59:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyquery/ChangeLog,v 1.43 2014/04/20 04:33:27 idella4 Exp $
+
+*pyquery-1.2.8 (20 Apr 2014)
+
+ 20 Apr 2014; Ian Delaney <idella4@gentoo.org> +pyquery-1.2.8.ebuild:
+ bump; drop py26 py3.2 support, upgrade deps, test phase, closes Bug #507548
18 Jan 2014; Markus Meier <maekke@gentoo.org> pyquery-1.2.4.ebuild:
arm stable, bug #450174
diff --git a/dev-python/pyquery/pyquery-1.2.8.ebuild b/dev-python/pyquery/pyquery-1.2.8.ebuild
new file mode 100644
index 000000000000..ec7a5330b96f
--- /dev/null
+++ b/dev-python/pyquery/pyquery-1.2.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyquery/pyquery-1.2.8.ebuild,v 1.1 2014/04/20 04:33:27 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A jQuery-like library for python"
+HOMEPAGE="https://github.com/gawel/pyquery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="beautifulsoup3 test"
+
+RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( beautifulsoup3 )"
+
+python_prepare_all() {
+ # rm known failing tests and tests dependent on restkit
+ # https://github.com/gawel/pyquery/pull/63/files
+ sed -e "s/test_proxy/_&/" \
+ -e "s/test_replaceWith/_&/" \
+ -i tests/test_pyquery.py || die
+ rm docs/ajax.rst || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # The suite, it appears, requires this hard setting of PYTHONPATH!
+ PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
+}