summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/iproute2/ChangeLog6
-rw-r--r--sys-apps/iproute2/iproute2-2.6.10.20050112-r1.ebuild9
-rw-r--r--sys-apps/iproute2/iproute2-2.6.10.20050124.ebuild9
3 files changed, 15 insertions, 9 deletions
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index 31b1048af400..c7f3649b3e57 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/iproute2
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.28 2005/02/10 02:48:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.29 2005/02/12 03:42:56 vapier Exp $
+
+ 11 Feb 2005; Mike Frysinger <vapier@gentoo.org>
+ iproute2-2.6.10.20050112-r1.ebuild, iproute2-2.6.10.20050124.ebuild:
+ Do not build the arpd binary if USE=-berkdb #81660 by Roy Marples.
*iproute2-2.6.10.20050124 (09 Feb 2005)
diff --git a/sys-apps/iproute2/iproute2-2.6.10.20050112-r1.ebuild b/sys-apps/iproute2/iproute2-2.6.10.20050112-r1.ebuild
index 2daf0db0316e..c08d54fd9a68 100644
--- a/sys-apps/iproute2/iproute2-2.6.10.20050112-r1.ebuild
+++ b/sys-apps/iproute2/iproute2-2.6.10.20050112-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.10.20050112-r1.ebuild,v 1.7 2005/02/09 14:52:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.10.20050112-r1.ebuild,v 1.8 2005/02/12 03:42:56 vapier Exp $
inherit eutils toolchain-funcs
@@ -14,10 +14,10 @@ SRC_URI="http://developer.osdl.org/dev/iproute2/download/${PN}-${MY_PV}-${SNAP}.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
-IUSE="atm minimal"
+IUSE="atm berkdb minimal"
RDEPEND="virtual/libc
- !minimal? ( sys-libs/db )
+ !minimal? ( berkdb? ( sys-libs/db ) )
atm? ( net-dialup/linux-atm )"
DEPEND="${RDEPEND}
>=virtual/os-headers-2.4.21
@@ -33,7 +33,8 @@ src_unpack() {
epatch \
${FILESDIR}/2.6.9.20041106-esfq.patch \
${FILESDIR}/2.6.9.20041019-wrr.patch
-
+ # don't build arpd if USE=-berkdb #81660
+ use berkdb || sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
# Multilib fixes
sed -i "s:/usr/lib/tc:/usr/$(get_libdir)/tc:g" ${S}/tc/Makefile ${S}/tc/tc.c ${S}/tc/q_netem.c
}
diff --git a/sys-apps/iproute2/iproute2-2.6.10.20050124.ebuild b/sys-apps/iproute2/iproute2-2.6.10.20050124.ebuild
index 474ff3072de5..1265e485607e 100644
--- a/sys-apps/iproute2/iproute2-2.6.10.20050124.ebuild
+++ b/sys-apps/iproute2/iproute2-2.6.10.20050124.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.10.20050124.ebuild,v 1.1 2005/02/10 02:48:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.6.10.20050124.ebuild,v 1.2 2005/02/12 03:42:56 vapier Exp $
inherit eutils toolchain-funcs
@@ -14,10 +14,10 @@ SRC_URI="http://developer.osdl.org/dev/iproute2/download/${PN}-${MY_PV}-${SNAP}.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="atm minimal"
+IUSE="atm berkdb minimal"
RDEPEND="virtual/libc
- !minimal? ( sys-libs/db )
+ !minimal? ( berkdb? ( sys-libs/db ) )
atm? ( net-dialup/linux-atm )"
DEPEND="${RDEPEND}
>=virtual/os-headers-2.4.21
@@ -33,7 +33,8 @@ src_unpack() {
epatch \
${FILESDIR}/2.6.9.20041106-esfq.patch \
${FILESDIR}/2.6.9.20041019-wrr.patch
-
+ # don't build arpd if USE=-berkdb #81660
+ use berkdb || sed -i '/^TARGETS=/s: arpd : :' misc/Makefile
# Multilib fixes
sed -i "s:/usr/lib/tc:/usr/$(get_libdir)/tc:g" \
tc/Makefile tc/tc.c tc/q_netem.c