summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/libselinux/ChangeLog7
-rw-r--r--sys-libs/libselinux/libselinux-2.1.9-r1.ebuild85
-rw-r--r--sys-libs/libselinux/libselinux-2.1.9-r2.ebuild97
-rw-r--r--sys-libs/libselinux/libselinux-2.1.9-r3.ebuild92
-rw-r--r--sys-libs/libselinux/libselinux-2.1.9.ebuild84
5 files changed, 6 insertions, 359 deletions
diff --git a/sys-libs/libselinux/ChangeLog b/sys-libs/libselinux/ChangeLog
index d287a51c40ef..723fea8bad51 100644
--- a/sys-libs/libselinux/ChangeLog
+++ b/sys-libs/libselinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libselinux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.98 2013/06/23 08:30:57 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/ChangeLog,v 1.99 2013/07/07 17:58:21 swift Exp $
+
+ 07 Jul 2013; Sven Vermeulen <swift@gentoo.org> -libselinux-2.1.9.ebuild,
+ -libselinux-2.1.9-r1.ebuild, -libselinux-2.1.9-r2.ebuild,
+ -libselinux-2.1.9-r3.ebuild:
+ Summer cleaning
*libselinux-2.1.13-r3 (23 Jun 2013)
diff --git a/sys-libs/libselinux/libselinux-2.1.9-r1.ebuild b/sys-libs/libselinux/libselinux-2.1.9-r1.ebuild
deleted file mode 100644
index 3cf17bfdf44f..000000000000
--- a/sys-libs/libselinux/libselinux-2.1.9-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.9-r1.ebuild,v 1.4 2012/08/06 07:46:08 patrick Exp $
-
-EAPI="4"
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython *-pypy-* 2.5 2.6 3.*"
-
-inherit multilib python toolchain-funcs eutils
-
-SEPOL_VER="2.1.4"
-
-DESCRIPTION="SELinux userland library"
-HOMEPAGE="http://userspace.selinuxproject.org"
-SRC_URI="http://userspace.selinuxproject.org/releases/20120216/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="python ruby"
-
-RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
- ruby? ( dev-lang/ruby )"
-DEPEND="${RDEPEND}
- ruby? ( dev-lang/swig )
- python? ( dev-lang/swig )"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # fix up paths for multilib
- sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
- || die "Fix for multilib LIBDIR failed."
- sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
- || die "Fix for multilib SHLIBDIR failed."
- epatch "${FILESDIR}/${P}-mountsys.patch"
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" LDFLAGS="-fPIC ${LDFLAGS}" all || die
-
- if use python; then
- python_copy_sources src
- building() {
- emake CC="$(tc-getCC)" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC ${LDFLAGS}" pywrap
- }
- python_execute_function -s --source-dir src building
- fi
-
- if use ruby; then
- emake CC="$(tc-getCC)" rubywrap || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- if use python; then
- installation() {
- emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
- }
- python_execute_function -s --source-dir src installation
- fi
-
- if use ruby; then
- emake DESTDIR="${D}" install-rubywrap || die
- fi
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize selinux
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup selinux
- fi
-}
diff --git a/sys-libs/libselinux/libselinux-2.1.9-r2.ebuild b/sys-libs/libselinux/libselinux-2.1.9-r2.ebuild
deleted file mode 100644
index 72b9438f4897..000000000000
--- a/sys-libs/libselinux/libselinux-2.1.9-r2.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.9-r2.ebuild,v 1.3 2012/10/06 16:36:49 swift Exp $
-
-EAPI="4"
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 *-jython *-pypy-*"
-USE_RUBY="ruby18"
-RUBY_OPTIONAL="yes"
-
-inherit multilib python toolchain-funcs eutils ruby-ng
-
-SEPOL_VER="2.1.4"
-
-DESCRIPTION="SELinux userland library"
-HOMEPAGE="http://userspace.selinuxproject.org"
-SRC_URI="http://userspace.selinuxproject.org/releases/20120216/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="python ruby"
-
-RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
- ruby? ( $(ruby_implementations_depend) )"
-DEPEND="${RDEPEND}
- ruby? ( dev-lang/swig )
- python? ( dev-lang/swig )"
-
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-
- if use ruby; then
- ruby-ng_pkg_setup
- fi
-}
-
-src_unpack() {
- default
-}
-
-src_prepare() {
- # fix up paths for multilib
- sed -i \
- -e "/^LIBDIR/s/lib/$(get_libdir)/" \
- -e "/^SHLIBDIR/s/lib/$(get_libdir)/" \
- src/Makefile utils/Makefile || die
- epatch "${FILESDIR}/${P}-mountsys.patch"
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" LDFLAGS="-fPIC ${LDFLAGS}" all || die
-
- if use python; then
- python_copy_sources src
- building() {
- emake CC="$(tc-getCC)" PYINC="-I$(python_get_includedir)" PYTHONLIBDIR="$(python_get_library -l)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC ${LDFLAGS}" pywrap
- }
- python_execute_function -s --source-dir src building
- fi
-
- if use ruby; then
- emake CC="$(tc-getCC)" rubywrap || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- if use python; then
- installation() {
- emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
- }
- python_execute_function -s --source-dir src installation
- fi
-
- if use ruby; then
- emake DESTDIR="${D}" install-rubywrap || die
- fi
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize selinux
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup selinux
- fi
-}
diff --git a/sys-libs/libselinux/libselinux-2.1.9-r3.ebuild b/sys-libs/libselinux/libselinux-2.1.9-r3.ebuild
deleted file mode 100644
index b95cffa02b7d..000000000000
--- a/sys-libs/libselinux/libselinux-2.1.9-r3.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.9-r3.ebuild,v 1.2 2012/11/17 16:53:48 swift Exp $
-
-EAPI="4"
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 *-jython *-pypy-*"
-
-inherit multilib python toolchain-funcs eutils
-
-SEPOL_VER="2.1.4"
-
-DESCRIPTION="SELinux userland library"
-HOMEPAGE="http://userspace.selinuxproject.org"
-SRC_URI="http://userspace.selinuxproject.org/releases/20120216/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="python ruby"
-
-RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
- ruby? ( dev-lang/ruby )"
-DEPEND="${RDEPEND}
- ruby? ( dev-lang/swig )
- python? ( dev-lang/swig )"
-
-S="${WORKDIR}/${P}"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_unpack() {
- default
-}
-
-src_prepare() {
- # fix up paths for multilib
- sed -i \
- -e "/^LIBDIR/s/lib/$(get_libdir)/" \
- -e "/^SHLIBDIR/s/lib/$(get_libdir)/" \
- src/Makefile utils/Makefile || die
- epatch "${FILESDIR}/${P}-mountsys.patch"
- epatch "${FILESDIR}/${P}-support_ruby19.patch"
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" LDFLAGS="-fPIC ${LDFLAGS}" all || die
-
- if use python; then
- python_copy_sources src
- building() {
- emake CC="$(tc-getCC)" PYINC="-I$(python_get_includedir)" PYTHONLIBDIR="$(python_get_library -l)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC ${LDFLAGS}" pywrap
- }
- python_execute_function -s --source-dir src building
- fi
-
- if use ruby; then
- emake CC="$(tc-getCC)" rubywrap || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- if use python; then
- installation() {
- emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
- }
- python_execute_function -s --source-dir src installation
- fi
-
- if use ruby; then
- emake DESTDIR="${D}" install-rubywrap || die
- fi
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize selinux
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup selinux
- fi
-}
diff --git a/sys-libs/libselinux/libselinux-2.1.9.ebuild b/sys-libs/libselinux/libselinux-2.1.9.ebuild
deleted file mode 100644
index f400ceac3c12..000000000000
--- a/sys-libs/libselinux/libselinux-2.1.9.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libselinux/libselinux-2.1.9.ebuild,v 1.3 2012/06/26 05:03:37 floppym Exp $
-
-EAPI="2"
-PYTHON_DEPEND="python? *"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
-
-inherit multilib python toolchain-funcs
-
-SEPOL_VER="2.1.4"
-
-DESCRIPTION="SELinux userland library"
-HOMEPAGE="http://userspace.selinuxproject.org"
-SRC_URI="http://userspace.selinuxproject.org/releases/20120216/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="python ruby"
-
-RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}
- ruby? ( dev-lang/ruby )"
-DEPEND="${RDEPEND}
- ruby? ( dev-lang/swig )
- python? ( dev-lang/swig )"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # fix up paths for multilib
- sed -i -e "/^LIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
- || die "Fix for multilib LIBDIR failed."
- sed -i -e "/^SHLIBDIR/s/lib/$(get_libdir)/" "${S}/src/Makefile" \
- || die "Fix for multilib SHLIBDIR failed."
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" LDFLAGS="-fPIC ${LDFLAGS}" all || die
-
- if use python; then
- python_copy_sources src
- building() {
- emake CC="$(tc-getCC)" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" LDFLAGS="-fPIC ${LDFLAGS}" pywrap
- }
- python_execute_function -s --source-dir src building
- fi
-
- if use ruby; then
- emake CC="$(tc-getCC)" rubywrap || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- if use python; then
- installation() {
- emake DESTDIR="${D}" PYLIBVER="python$(python_get_version)" PYPREFIX="python-$(python_get_version)" install-pywrap
- }
- python_execute_function -s --source-dir src installation
- fi
-
- if use ruby; then
- emake DESTDIR="${D}" install-rubywrap || die
- fi
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize selinux
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup selinux
- fi
-}