summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/bzr/ChangeLog5
-rw-r--r--dev-vcs/bzr/bzr-2.4.2.ebuild45
2 files changed, 8 insertions, 42 deletions
diff --git a/dev-vcs/bzr/ChangeLog b/dev-vcs/bzr/ChangeLog
index 529d40f2ff6c..2c43430c7209 100644
--- a/dev-vcs/bzr/ChangeLog
+++ b/dev-vcs/bzr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/bzr
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.44 2011/12/26 22:41:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.45 2011/12/28 14:29:30 fauli Exp $
+
+ 28 Dec 2011; Christian Faulhammer <fauli@gentoo.org> bzr-2.4.2.ebuild:
+ drop Emacs support as Emacs 23 and above ship it directly, see bug 396103
26 Dec 2011; Mike Gilbert <floppym@gentoo.org> bzr-2.4.2.ebuild:
Add || die.
diff --git a/dev-vcs/bzr/bzr-2.4.2.ebuild b/dev-vcs/bzr/bzr-2.4.2.ebuild
index 967677a98667..13a18c59ed29 100644
--- a/dev-vcs/bzr/bzr-2.4.2.ebuild
+++ b/dev-vcs/bzr/bzr-2.4.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.4.2.ebuild,v 1.3 2011/12/26 22:41:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.4.2.ebuild,v 1.4 2011/12/28 14:29:30 fauli Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.[45] 3.*"
-inherit bash-completion-r1 distutils elisp-common eutils versionator
+inherit bash-completion-r1 distutils eutils versionator
MY_P=${PN}-${PV}
SERIES=$(get_version_component_range 1-2)
@@ -20,14 +20,13 @@ SRC_URI="http://launchpad.net/bzr/${SERIES}/${PV}/+download/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="curl doc emacs +sftp test"
+IUSE="curl doc +sftp test"
RDEPEND="|| ( dev-lang/python:2.7[xml] dev-lang/python:2.6[xml] dev-python/celementtree )
curl? ( dev-python/pycurl )
sftp? ( dev-python/paramiko )"
-DEPEND="emacs? ( virtual/emacs )
- test? (
+DEPEND="test? (
${RDEPEND}
|| ( dev-python/pyftpdlib dev-python/medusa )
dev-python/subunit
@@ -40,7 +39,6 @@ PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
DOCS="doc/*.txt"
PYTHON_MODNAME="bzrlib"
-SITEFILE="71bzr-gentoo.el"
src_prepare() {
distutils_src_prepare
@@ -49,14 +47,6 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-2.4.2-no-pyrex-citon.patch"
}
-src_compile() {
- distutils_src_compile
-
- if use emacs; then
- elisp-compile contrib/emacs/bzr-mode.el || die
- fi
-}
-
src_test() {
# Some tests expect the usual pyc compiling behaviour.
python_enable_pyc
@@ -94,32 +84,5 @@ src_install() {
done
fi
- if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el* || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
-
- # don't add automatically to the load-path, so the sitefile
- # can do a conditional loading
- touch "${ED}${SITELISP}/${PN}/.nosearch"
- fi
-
dobashcomp contrib/bash/bzr || die
}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- if use emacs; then
- elisp-site-regen
- elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
- elog "is already included. This ebuild does not automatically activate bzr support"
- elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
- elog "file by adding"
- elog " (load \"bzr-mode\")"
- fi
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- use emacs && elisp-site-regen
-}