summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libnxml/ChangeLog9
-rw-r--r--net-libs/libnxml/libnxml-0.18.2.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/net-libs/libnxml/ChangeLog b/net-libs/libnxml/ChangeLog
index d9c27c24d053..c86f2c37a4a0 100644
--- a/net-libs/libnxml/ChangeLog
+++ b/net-libs/libnxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libnxml
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/ChangeLog,v 1.12 2008/10/03 12:34:49 bluebird Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/ChangeLog,v 1.13 2009/03/29 15:30:10 patrick Exp $
+
+*libnxml-0.18.2 (29 Mar 2009)
+
+ 29 Mar 2009; Patrick Lauer <patrick@gentoo.org> +libnxml-0.18.2.ebuild:
+ Bump to 0.18.2, fixes #214764
03 Oct 2008; Friedrich Oslage <bluebird@gentoo.org> libnxml-0.18.0.ebuild:
Add ~sparc keyword, bug #238946
diff --git a/net-libs/libnxml/libnxml-0.18.2.ebuild b/net-libs/libnxml/libnxml-0.18.2.ebuild
new file mode 100644
index 000000000000..43dc95f17625
--- /dev/null
+++ b/net-libs/libnxml/libnxml-0.18.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/libnxml-0.18.2.ebuild,v 1.1 2009/03/29 15:30:10 patrick Exp $
+
+DESCRIPTION="A C-library for parsing and writing XML 1.0/1.1 files or streams"
+HOMEPAGE="http://www2.autistici.org/bakunin/codes.php"
+SRC_URI="http://www2.autistici.org/bakunin/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ ebegin "Creating documentation"
+ doxygen doxy.conf
+ eend 0
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use doc; then
+ dohtml doc/html/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/test
+ doins test/*.c
+ fi
+}