summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog11
-rw-r--r--app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.7-glibc-2.10.patch41
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild61
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild5
4 files changed, 114 insertions, 4 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index 109d4743289b..8023a28c13fb 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/speech-dispatcher
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.41 2009/04/01 17:18:16 williamh Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.42 2009/09/04 08:55:08 ssuominen Exp $
+
+*speech-dispatcher-0.6.7-r1 (04 Sep 2009)
+
+ 04 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +speech-dispatcher-0.6.7-r1.ebuild,
+ +files/speech-dispatcher-0.6.7-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #281130 by Christoph Brill.
01 Apr 2009; William Hubbs <williamh@gentoo.org>
speech-dispatcher-0.6.7.ebuild:
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.7-glibc-2.10.patch b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.7-glibc-2.10.patch
new file mode 100644
index 000000000000..3f3473452d73
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.7-glibc-2.10.patch
@@ -0,0 +1,41 @@
+From f0c490dc160f04cb9f258e0639944cffc1df9a40 Mon Sep 17 00:00:00 2001
+From: root <root@christoph.(none)>
+Date: Tue, 11 Aug 2009 20:39:24 +0200
+Subject: [PATCH] Fix build with recent gcc
+
+---
+ src/modules/module_main.c | 3 ---
+ src/modules/module_utils.h | 3 ---
+ 2 files changed, 0 insertions(+), 6 deletions(-)
+
+diff --git a/src/modules/module_main.c b/src/modules/module_main.c
+index 2732cff..5bb5769 100644
+--- a/src/modules/module_main.c
++++ b/src/modules/module_main.c
+@@ -21,9 +21,6 @@
+ * $Id: speech-dispatcher-0.6.7-glibc-2.10.patch,v 1.1 2009/09/04 08:55:08 ssuominen Exp $
+ */
+
+-/* So that gcc doesn't comply */
+-int getline(char**, size_t*, FILE*);
+-
+ #define PROCESS_CMD(command, function) \
+ if (!strcmp(cmd_buf, #command"\n")){ \
+ char *msg; \
+diff --git a/src/modules/module_utils.h b/src/modules/module_utils.h
+index e33865a..70e6241 100644
+--- a/src/modules/module_utils.h
++++ b/src/modules/module_utils.h
+@@ -420,9 +420,6 @@ void module_report_event_pause(void);
+
+
+
+-/* So that gcc doesn't complain */
+-int getline(char**, size_t*, FILE*);
+-
+ pthread_mutex_t module_stdout_mutex;
+
+ int module_utils_init(void);
+--
+1.6.4
+
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild
new file mode 100644
index 000000000000..600d9e2baba3
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild,v 1.1 2009/09/04 08:55:08 ssuominen Exp $
+
+inherit eutils
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="alsa flite nas pulseaudio python"
+
+RDEPEND="dev-libs/dotconf
+ >=dev-libs/glib-2
+ alsa? ( media-libs/alsa-lib )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? ( dev-lang/python )
+ app-accessibility/espeak"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ sed -i -e 's/\(SUBDIRS.*\)python/\1/' src/Makefile.in || die
+}
+
+src_compile() {
+ econf \
+ $(use_with alsa) \
+ $(use_with flite) \
+ $(use_with pulseaudio pulse) \
+ $(use_with nas) || die "configure failed"
+ make all || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use python; then
+ cd "${S}"/src/python
+ ./setup.py install --root="${D}" --no-compile
+ cd "${S}"
+ fi
+
+ insinto /usr/include
+ doins "${S}"/src/c/api/libspeechd.h
+
+ dodoc AUTHORS ChangeLog NEWS TODO
+ newinitd "${FILESDIR}"/speech-dispatcher speech-dispatcher
+}
+
+pkg_postinst() {
+ elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
+}
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
index 4632d47e19e2..6f286325a12a 100644
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild,v 1.2 2009/04/01 17:18:16 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild,v 1.3 2009/09/04 08:55:08 ssuominen Exp $
inherit eutils
@@ -26,7 +26,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- sed -i -e 's/\(SUBDIRS.*\)python/\1/' "${S}"/src/Makefile.in
+ cd "${S}"
+ sed -i -e 's/\(SUBDIRS.*\)python/\1/' src/Makefile.in || die
}
src_compile() {