summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/sord/ChangeLog7
-rw-r--r--dev-libs/sord/sord-0.5.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-libs/sord/ChangeLog b/dev-libs/sord/ChangeLog
index 2210f3f05694..80905dc6e8a6 100644
--- a/dev-libs/sord/ChangeLog
+++ b/dev-libs/sord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/sord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/sord/ChangeLog,v 1.2 2011/05/27 05:48:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/sord/ChangeLog,v 1.3 2011/10/11 20:35:13 aballier Exp $
+
+*sord-0.5.0 (11 Oct 2011)
+
+ 11 Oct 2011; Alexis Ballier <aballier@gentoo.org> +sord-0.5.0.ebuild:
+ version bump
27 May 2011; Alexis Ballier <aballier@gentoo.org> sord-0.4.2.ebuild:
export CC variables and depend on pkgconfig
diff --git a/dev-libs/sord/sord-0.5.0.ebuild b/dev-libs/sord/sord-0.5.0.ebuild
new file mode 100644
index 000000000000..b7618b984178
--- /dev/null
+++ b/dev-libs/sord/sord-0.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/sord/sord-0.5.0.ebuild,v 1.1 2011/10/11 20:35:13 aballier Exp $
+
+EAPI=3
+
+inherit base multilib toolchain-funcs
+
+DESCRIPTION="Library for storing RDF data in memory"
+HOMEPAGE="http://drobilla.net/software/sord/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/serd-0.5.0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/ldconfig.patch" )
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure \
+ --prefix=/usr \
+ --libdir="/usr/$(get_libdir)" \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static") \
+ || die
+}
+
+src_compile() {
+ ./waf || die
+}
+
+src_test() {
+ ./waf test || die
+}
+
+src_install() {
+ ./waf install --destdir="${D}" || die
+ dodoc AUTHORS README ChangeLog || die
+}