summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/sdlsasteroids/ChangeLog8
-rw-r--r--games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch11
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild16
3 files changed, 25 insertions, 10 deletions
diff --git a/games-arcade/sdlsasteroids/ChangeLog b/games-arcade/sdlsasteroids/ChangeLog
index ba6cd9c26756..2f854c9452d3 100644
--- a/games-arcade/sdlsasteroids/ChangeLog
+++ b/games-arcade/sdlsasteroids/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/sdlsasteroids
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.7 2006/06/29 15:22:02 wolf31o2 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.8 2008/04/30 22:14:04 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/sdlsasteroids-3.0.1-gcc43.patch, sdlsasteroids-3.0.1.ebuild:
+ Fix building with gcc-4.3
29 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
sdlsasteroids-3.0.1.ebuild:
diff --git a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch
new file mode 100644
index 000000000000..5ee05328e897
--- /dev/null
+++ b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch
@@ -0,0 +1,11 @@
+--- src/sbitmap.h
++++ src/sbitmap.h
+@@ -36,7 +36,7 @@
+ void LoadImage(char* path);
+ void LoadSurface(SDL_Surface* surface);
+
+- void put(float x, float y, float rotate = 1.0f, float rotate = 1.0f, float layer = 0.0f);
++ void put(float x, float y, float sf = 1.0f, float rotate = 1.0f, float layer = 0.0f);
+ void putA(float x, float y, float layer = 0.0f, float alpha = 1.0f);
+
+ inline float width() const
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
index 96c7682b5267..ce0e6226c22f 100644
--- a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
+++ b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild,v 1.3 2006/06/29 15:22:02 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild,v 1.4 2008/04/30 22:14:04 nyhm Exp $
-inherit games
+inherit eutils games
DESCRIPTION="Rework of Sasteroids using SDL"
HOMEPAGE="http://sdlsas.sourceforge.net/"
@@ -13,9 +13,8 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-DEPEND="virtual/libc
- virtual/opengl
- >=media-libs/sdl-mixer-1.2.0
+DEPEND="virtual/opengl
+ media-libs/sdl-mixer
media-libs/libsdl
media-libs/sdl-image
media-libs/sdl-ttf"
@@ -25,6 +24,7 @@ S=${WORKDIR}/SDLSasteroids-${PV}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
#-e '34 d' \
sed -i \
-e 's/make /$(MAKE) /' \
@@ -41,11 +41,11 @@ src_compile() {
src_install() {
dodir /usr/share/man/man6/
- make \
+ emake \
GAMEDIR="${D}/${GAMES_DATADIR}/${PN}" \
BINDIR="${D}/${GAMES_BINDIR}" \
MANDIR="${D}/usr/share/man/" \
- install || die "make install failed"
+ install || die "emake install failed"
dodoc ChangeLog README README.xast TODO description
prepgamesdirs
}