summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/microcode-ctl/ChangeLog11
-rw-r--r--sys-apps/microcode-ctl/Manifest2
-rw-r--r--sys-apps/microcode-ctl/files/digest-microcode-ctl-1.06-r12
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.06-r1.ebuild47
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild7
5 files changed, 63 insertions, 6 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
index a4805dac4499..a69a16e30136 100644
--- a/sys-apps/microcode-ctl/ChangeLog
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/microcode-ctl
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.3 2004/03/01 19:59:51 aliz Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.4 2004/04/09 15:46:20 seemant Exp $
+
+*microcode-ctl-1.06-r1 (09 Apr 2004)
+
+ 09 Apr 2004; Seemant Kulleen <seemant@gentoo.org>
+ microcode-ctl-1.06-r1.ebuild, microcode-ctl-1.06.ebuild:
+ patch to initscript to work with dual booting. Patch provided by: Paul Belt
+ <gaarde@yahoo.com> in bug #33309 by Priit Laes <amd@tt.ee>
*microcode-ctl-1.06 (30 Apr 2002)
diff --git a/sys-apps/microcode-ctl/Manifest b/sys-apps/microcode-ctl/Manifest
index 77edbe3aff0c..384694c0ab2b 100644
--- a/sys-apps/microcode-ctl/Manifest
+++ b/sys-apps/microcode-ctl/Manifest
@@ -1,4 +1,6 @@
MD5 24cc8366657833b1a41615dbba2ad9be microcode-ctl-1.06.ebuild 1369
+MD5 3e8ab73fa93a6d4df38a56c04267da14 microcode-ctl-1.06-r1.ebuild 1318
MD5 30ff78b16e9718770032dc5ab177a6d6 ChangeLog 852
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 4264b9b56f2c050a179656e4de363623 files/digest-microcode-ctl-1.06 148
+MD5 d7008d6229625e357c4168a2b7e63bb1 files/digest-microcode-ctl-1.06-r1 151
diff --git a/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.06-r1 b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.06-r1
new file mode 100644
index 000000000000..af7c8ae735ec
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.06-r1
@@ -0,0 +1,2 @@
+MD5 4008903ba66e88e4eccca4256363cf30 microcode_ctl-1.06.tar.gz 126450
+MD5 94b386498b20d7b5a6dc80cf5b88d2ac microcode-ctl-1.06-r1-gentoo.tar.bz2 106114
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.06-r1.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.06-r1.ebuild
new file mode 100644
index 000000000000..b1924a550f08
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.06-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.06-r1.ebuild,v 1.1 2004/04/09 15:46:20 seemant Exp $
+
+MY_P=${PN/-/_}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Intel IA32 microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz
+ mirror://gentoo/${PF}-gentoo.tar.bz2
+ http://dev.gentoo.org/~seemant/distfiles/${PF}-gentoo.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64 -ppc -sparc -hppa -mips -alpha"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ make all || die "compile problem"
+}
+
+src_install() {
+ into /usr/
+ dosbin microcode_ctl
+ doman microcode_ctl.8
+ dodoc Changelog README
+ insinto /etc/
+ doins ${WORKDIR}/${PV}/microcode.dat
+ exeinto /etc/init.d/
+ doexe ${WORKDIR}/${PV}/microcode_ctl
+}
+
+pkg_postinst() {
+ einfo "Your kernel must include both devfs and microcode update support."
+ echo
+ einfo "To update the microcode now, run"
+ einfo ""
+ einfo "\tmicrocode_ctl -u"
+ einfo ""
+ einfo "The update will not survive a reboot. To have it do that run"
+ einfo ""
+ einfo "\trc-update add microcode_ctl default"
+ einfo ""
+ einfo "NOTE: For 2.6x series kernels, use the '-d' flag to specify a"
+ einfo " different microcode device: /dev/misc/microcode"
+}
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild
index c5367974c40c..223caade6895 100644
--- a/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild,v 1.3 2003/11/12 23:38:32 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.06.ebuild,v 1.4 2004/04/09 15:46:20 seemant Exp $
MY_P=${PN/-/_}-${PV}
S=${WORKDIR}/${MY_P}
DESCRIPTION="Intel IA32 microcode update utility"
HOMEPAGE="http://www.urbanmyth.org/microcode"
SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz
- mirror://gentoo/${P}-gentoo.tar.bz2
- http://cvs.gentoo.org/~seemant/${P}-gentoo.tar.bz2"
+ mirror://gentoo/${P}-gentoo.tar.bz2"
SLOT="0"
LICENSE="GPL-2"