summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/transcend/ChangeLog10
-rw-r--r--games-action/transcend/Manifest2
-rw-r--r--games-action/transcend/files/digest-transcend-0.21
-rw-r--r--games-action/transcend/metadata.xml5
-rw-r--r--games-action/transcend/transcend-0.2.ebuild59
5 files changed, 77 insertions, 0 deletions
diff --git a/games-action/transcend/ChangeLog b/games-action/transcend/ChangeLog
new file mode 100644
index 000000000000..3f95b8fe07e0
--- /dev/null
+++ b/games-action/transcend/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/transcend
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/ChangeLog,v 1.1 2005/02/08 19:00:57 mr_bones_ Exp $
+
+*transcend-0.2 (08 Feb 2005)
+
+ 08 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +transcend-0.2.ebuild:
+ initial commit (bug #65472)
+
diff --git a/games-action/transcend/Manifest b/games-action/transcend/Manifest
new file mode 100644
index 000000000000..6a356660e587
--- /dev/null
+++ b/games-action/transcend/Manifest
@@ -0,0 +1,2 @@
+MD5 38ac49008ad43331f9373d3792c8f545 transcend-0.2.ebuild 893
+MD5 bc06eaad665cd403a40c948ab56bb7c1 files/digest-transcend-0.2 83
diff --git a/games-action/transcend/files/digest-transcend-0.2 b/games-action/transcend/files/digest-transcend-0.2
new file mode 100644
index 000000000000..0d6340957731
--- /dev/null
+++ b/games-action/transcend/files/digest-transcend-0.2
@@ -0,0 +1 @@
+MD5 09f6b2ae9ab51ec4d173080fe5adb085 Transcend_0.2-IGF-2_UnixSource.tar.gz 1168043
diff --git a/games-action/transcend/metadata.xml b/games-action/transcend/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/transcend/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/transcend/transcend-0.2.ebuild b/games-action/transcend/transcend-0.2.ebuild
new file mode 100644
index 000000000000..2e5e60370c6c
--- /dev/null
+++ b/games-action/transcend/transcend-0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/transcend-0.2.ebuild,v 1.1 2005/02/08 19:00:57 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="retro-style, abstract, 2D shooter"
+HOMEPAGE="http://transcend.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/Transcend_${PV}-IGF-2_UnixSource.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/x11
+ virtual/opengl
+ virtual/glu
+ virtual/glut"
+
+S=${WORKDIR}/Transcend_${PV}-IGF-2_UnixSource/Transcend
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ chmod a+x portaudio/configure
+ rm -f game/Makefile
+ cat \
+ Makefile.GnuLinuxX86 \
+ Makefile.common \
+ Makefile.minorGems \
+ game/Makefile.all \
+ Makefile.minorGems_targets \
+ > game/Makefile
+ sed -i \
+ -e "s:\"levels\":\"${GAMES_DATADIR}/${PN}/levels\":" \
+ game/LevelDirectoryManager.cpp \
+ game/game.cpp \
+ || die "sed failed"
+}
+
+src_compile() {
+ cd portaudio
+ egamesconf || die
+ emake
+ cd ../game
+ emake || die
+ cd ..
+ cp game/Transcend ${PN} || die "cp failed"
+}
+
+src_install() {
+ newgamesbin game/Transcend ${PN} || die "newgamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r levels/ "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc doc/how_to_*.txt
+ prepgamesdirs
+}