summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/vimspell/ChangeLog10
-rw-r--r--app-vim/vimspell/Manifest4
-rw-r--r--app-vim/vimspell/files/digest-vimspell-1.681
-rw-r--r--app-vim/vimspell/metadata.xml9
-rw-r--r--app-vim/vimspell/vimspell-1.68.ebuild57
5 files changed, 80 insertions, 1 deletions
diff --git a/app-vim/vimspell/ChangeLog b/app-vim/vimspell/ChangeLog
new file mode 100644
index 000000000000..f59261a0cc4f
--- /dev/null
+++ b/app-vim/vimspell/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/vimspell
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimspell/ChangeLog,v 1.1 2003/11/19 19:35:33 ciaranm Exp $
+
+*vimspell-1.68 (19 Nov 2003)
+
+ 19 Nov 2003; Ciaran McCreesh <ciaranm@gentoo.org> metadata.xml,
+ vimspell-1.68.ebuild:
+ new ebuild
+
diff --git a/app-vim/vimspell/Manifest b/app-vim/vimspell/Manifest
index ac93adaab0f8..1e97a207919a 100644
--- a/app-vim/vimspell/Manifest
+++ b/app-vim/vimspell/Manifest
@@ -1,2 +1,4 @@
-MD5 1fa222c0a1743c18241be196ad2552e1 vimspell-1.68.ebuild 2182
+MD5 c46988920a91b396c62abb24653383eb vimspell-1.68.ebuild 2283
+MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
+MD5 2a94774f509da3fd7af765f7f586741f ChangeLog 349
MD5 584de3c97924b0422303af4e46df9a0d files/digest-vimspell-1.68 65
diff --git a/app-vim/vimspell/files/digest-vimspell-1.68 b/app-vim/vimspell/files/digest-vimspell-1.68
new file mode 100644
index 000000000000..8b7dcdd6933a
--- /dev/null
+++ b/app-vim/vimspell/files/digest-vimspell-1.68
@@ -0,0 +1 @@
+MD5 27233e4e31a141da74892d7cfed23e61 vimspell-1.68.tar.bz2 16562
diff --git a/app-vim/vimspell/metadata.xml b/app-vim/vimspell/metadata.xml
new file mode 100644
index 000000000000..3a147a175714
--- /dev/null
+++ b/app-vim/vimspell/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+<maintainer>
+ <email>ciaranm@gentoo.org</email>
+ <name>Ciaran McCreesh</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-vim/vimspell/vimspell-1.68.ebuild b/app-vim/vimspell/vimspell-1.68.ebuild
new file mode 100644
index 000000000000..97d76c398c78
--- /dev/null
+++ b/app-vim/vimspell/vimspell-1.68.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimspell/vimspell-1.68.ebuild,v 1.1 2003/11/19 19:35:33 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: on-the-fly spell checking with aspell"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=465"
+LICENSE="GPL-1 | GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+# In theory, this plugin supports either aspell or ispell. However,
+# virtual/spell has been removed by seemant in favour of just using
+# app-text/aspell:
+# 20:06 <@seemant> ciaranm: I think I might have removed it, come to
+# think of it, because I was on a kick to get everything converted
+# to aspell instead of ispell
+# 20:06 <@seemant> for the simple reason that ispell blows dogs
+# So we'll just force people to use aspell...
+RDEPEND="$RDEPEND app-text/aspell"
+
+function src_unpack() {
+ unpack ${A}
+ cd ${S}/plugin
+
+ # This plugin needs to be told which spell program to use. The default
+ # is hard-coded as 'ispell' in the plugin file. We can fix that with a
+ # bit of sed magic.
+ OLD_DEFAULT='s:SpellGetOption("spell_executable","ispell")'
+ NEW_DEFAULT='s:SpellGetOption("spell_executable","aspell")'
+ sed -e "s/$OLD_DEFAULT/$NEW_DEFAULT/g" \
+ -i vimspell.vim || die "default setting fix failed"
+
+ # This plugin also tries to install its own documentation automatically
+ # upon load. This breaks emerge unmerge, so we'll install the docs
+ # manually.
+ mkdir ${S}/doc || die
+ cd ${S}/doc
+ cp ${S}/plugin/vimspell.vim vimspell.txt
+
+ sed -e "1,/^=== \+START_DOC/d" \
+ -e "/^=== \+END_DOC/,\$d" \
+ -e "s/{{{[1-9]/ /g" \
+ -e "s/#version#/v${PV}/g" \
+ -i vimspell.txt || die "docs failed"
+ echo -ne "\n vim:tw=78:ts=8:ft=help:norl:\n" >> vimspell.txt
+
+ # Unfortunately, there's a rather large logic error in the documentation
+ # installation code. If vim can't write to /usr/share/vim/vimfiles/doc/
+ # then the plugin will try to install a copy of the docs locally, even if
+ # the global directory has an up-to-date copy. To get around this we'll
+ # make the SpellInstallDocumentation function do nothing.
+ cd ${S}/plugin
+ sed -e "/^function! s:SpellInstallDocumentation/a\ return 0" \
+ -i vimspell.vim || die "install fix failed"
+}
+