summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/gcc/ChangeLog11
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r10.ebuild3
-rw-r--r--sys-devel/gcc/gcc-3.2.2.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.6-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-3.4.6-r2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.0.4.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.1.2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.2.4-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.3-r2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.4.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.5.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.3.6-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.4.2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.4.3-r3.ebuild8
-rw-r--r--sys-devel/gcc/gcc-4.4.4-r2.ebuild8
-rw-r--r--sys-devel/gcc/gcc-4.4.5.ebuild8
-rw-r--r--sys-devel/gcc/gcc-4.4.6-r1.ebuild8
-rw-r--r--sys-devel/gcc/gcc-4.5.1-r1.ebuild8
-rw-r--r--sys-devel/gcc/gcc-4.5.2.ebuild8
-rw-r--r--sys-devel/gcc/gcc-4.5.3-r1.ebuild8
-rw-r--r--sys-devel/gcc/gcc-4.6.0.ebuild4
-rw-r--r--sys-devel/gcc/gcc-4.6.1-r1.ebuild4
22 files changed, 55 insertions, 87 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 34c278c73924..6816451adbe3 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.826 2011/09/25 01:52:54 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.827 2011/09/26 17:38:49 vapier Exp $
+
+ 26 Sep 2011; Mike Frysinger <vapier@gentoo.org> gcc-2.95.3-r10.ebuild,
+ gcc-3.2.2.ebuild, gcc-3.3.6-r1.ebuild, gcc-3.4.6-r2.ebuild, gcc-4.0.4.ebuild,
+ gcc-4.1.2.ebuild, gcc-4.2.4-r1.ebuild, gcc-4.3.3-r2.ebuild, gcc-4.3.4.ebuild,
+ gcc-4.3.5.ebuild, gcc-4.3.6-r1.ebuild, gcc-4.4.2.ebuild, gcc-4.4.3-r3.ebuild,
+ gcc-4.4.4-r2.ebuild, gcc-4.4.5.ebuild, gcc-4.4.6-r1.ebuild,
+ gcc-4.5.1-r1.ebuild, gcc-4.5.2.ebuild, gcc-4.5.3-r1.ebuild, gcc-4.6.0.ebuild,
+ gcc-4.6.1-r1.ebuild:
+ Scrub now unused ETYPE logic.
25 Sep 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> gcc-4.5.3-r1.ebuild:
x86 stable wrt bug #357479
diff --git a/sys-devel/gcc/gcc-2.95.3-r10.ebuild b/sys-devel/gcc/gcc-2.95.3-r10.ebuild
index 93a7972c0879..1e946aaa853d 100644
--- a/sys-devel/gcc/gcc-2.95.3-r10.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r10.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r10.ebuild,v 1.5 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r10.ebuild,v 1.6 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.3"
SPLIT_SPECS="no"
-ETYPE="gcc-compiler"
inherit toolchain eutils flag-o-matic
diff --git a/sys-devel/gcc/gcc-3.2.2.ebuild b/sys-devel/gcc/gcc-3.2.2.ebuild
index 3e2462639ce7..4ffb800b83d4 100644
--- a/sys-devel/gcc/gcc-3.2.2.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.31 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.32 2011/09/26 17:38:49 vapier Exp $
# This version is really meant JUST for the ps2
@@ -11,8 +11,6 @@ PIE_VER=""
PP_VER=""
HTB_VER=""
-ETYPE="gcc-compiler"
-
SPLIT_SPECS=${SPLIT_SPECS-true}
inherit toolchain eutils
diff --git a/sys-devel/gcc/gcc-3.3.6-r1.ebuild b/sys-devel/gcc/gcc-3.3.6-r1.ebuild
index 953dc933c1ea..33058df2fe77 100644
--- a/sys-devel/gcc/gcc-3.3.6-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6-r1.ebuild,v 1.18 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6-r1.ebuild,v 1.19 2011/09/26 17:38:49 vapier Exp $
MAN_VER=""
PATCH_VER="1.7"
@@ -9,8 +9,6 @@ PIE_VER="8.7.8"
PP_VER="1.0"
HTB_VER="1.00-r2"
-ETYPE="gcc-compiler"
-
# arch/libc configurations known to be stable with {PIE,SSP}-by-default
SSP_STABLE="x86 sparc amd64"
SSP_UCLIBC_STABLE="arm mips ppc x86"
@@ -73,7 +71,7 @@ DEPEND="${RDEPEND}
PDEPEND=">=sys-devel/gcc-config-1.4"
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
if [[ -n ${UCLIBC_VER} ]] && [[ ${CTARGET} == *-uclibc* ]] ; then
mv "${S}"/gcc-3.3.2/libstdc++-v3/config/os/uclibc "${S}"/libstdc++-v3/config/os/ || die
diff --git a/sys-devel/gcc/gcc-3.4.6-r2.ebuild b/sys-devel/gcc/gcc-3.4.6-r2.ebuild
index 7a76fa3225ec..7498d616ca5f 100644
--- a/sys-devel/gcc/gcc-3.4.6-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.4.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.26 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.27 2011/09/26 17:38:49 vapier Exp $
MAN_VER=""
PATCH_VER="1.6"
@@ -16,8 +16,6 @@ D_VER="0.24"
GCC_LIBSSP_SUPPORT="true"
-ETYPE="gcc-compiler"
-
# arch/libc configurations known to be stable with {PIE,SSP}-by-default
SSP_STABLE="x86 sparc amd64 ppc ppc64 ia64"
SSP_UCLIBC_STABLE="arm mips ppc x86"
@@ -84,7 +82,7 @@ DEPEND="${RDEPEND}
PDEPEND=">=sys-devel/gcc-config-1.4"
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
# misc patches that havent made it into a patch tarball yet
[[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
diff --git a/sys-devel/gcc/gcc-4.0.4.ebuild b/sys-devel/gcc/gcc-4.0.4.ebuild
index 7f55998290c8..450d83a5853d 100644
--- a/sys-devel/gcc/gcc-4.0.4.ebuild
+++ b/sys-devel/gcc/gcc-4.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.4.ebuild,v 1.9 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.4.ebuild,v 1.10 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
@@ -8,8 +8,6 @@ PIE_VER="8.7.8"
PP_VER=""
HTB_VER=""
-ETYPE="gcc-compiler"
-
# bug #126609
GENTOO_PATCH_EXCLUDE="33_all_gcc4-pr16104.patch"
@@ -59,7 +57,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.1.2.ebuild b/sys-devel/gcc/gcc-4.1.2.ebuild
index cb783e94d398..6cae7fcf0b36 100644
--- a/sys-devel/gcc/gcc-4.1.2.ebuild
+++ b/sys-devel/gcc/gcc-4.1.2.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.2.ebuild,v 1.28 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.2.ebuild,v 1.29 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.0"
D_VER="0.24"
-ETYPE="gcc-compiler"
-
# whether we should split out specs files for multiple {PIE,SSP}-by-default
# and vanilla configurations.
SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
@@ -57,7 +55,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.2.4-r1.ebuild b/sys-devel/gcc/gcc-4.2.4-r1.ebuild
index 08aedafe83ee..f7630c827984 100644
--- a/sys-devel/gcc/gcc-4.2.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.2.4-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.4-r1.ebuild,v 1.8 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.4-r1.ebuild,v 1.9 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# whether we should split out specs files for multiple {PIE,SSP}-by-default
# and vanilla configurations.
SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
@@ -58,7 +56,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.3-r2.ebuild b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
index 6b9c173cee71..98ba83adccd5 100644
--- a/sys-devel/gcc/gcc-4.3.3-r2.ebuild
+++ b/sys-devel/gcc/gcc-4.3.3-r2.ebuild
@@ -1,14 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r2.ebuild,v 1.11 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.3-r2.ebuild,v 1.12 2011/09/26 17:38:49 vapier Exp $
GENTOO_PATCH_EXCLUDE="69_all_gcc43-pr39013.patch" #262567
PATCH_VER="1.2"
UCLIBC_VER="1.1"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="10.1.5"
SPECS_VER="0.9.4"
@@ -70,7 +68,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.4.ebuild b/sys-devel/gcc/gcc-4.3.4.ebuild
index cb69bf807e6b..1cdcbd18454f 100644
--- a/sys-devel/gcc/gcc-4.3.4.ebuild
+++ b/sys-devel/gcc/gcc-4.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.4.ebuild,v 1.17 2011/07/01 06:02:29 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.4.ebuild,v 1.18 2011/09/26 17:38:49 vapier Exp $
GENTOO_PATCH_EXCLUDE="69_all_gcc43-pr39013.patch \
02_all_gcc-4.3-alpha-PR42113.patch" #262567 #309279
@@ -8,8 +8,6 @@ GENTOO_PATCH_EXCLUDE="69_all_gcc43-pr39013.patch \
PATCH_VER="1.3"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="10.1.5"
SPECS_VER="0.9.4"
@@ -71,7 +69,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.5.ebuild b/sys-devel/gcc/gcc-4.3.5.ebuild
index 9b4853b184d5..5e3addaf555c 100644
--- a/sys-devel/gcc/gcc-4.3.5.ebuild
+++ b/sys-devel/gcc/gcc-4.3.5.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.5.ebuild,v 1.6 2011/07/01 07:27:56 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.5.ebuild,v 1.7 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="10.1.5"
SPECS_VER="0.9.4"
@@ -68,7 +66,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.3.6-r1.ebuild b/sys-devel/gcc/gcc-4.3.6-r1.ebuild
index b54c59e4251f..94863d07bbc4 100644
--- a/sys-devel/gcc/gcc-4.3.6-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.3.6-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.6-r1.ebuild,v 1.1 2011/08/13 03:55:39 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.6-r1.ebuild,v 1.2 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="10.1.5"
SPECS_VER="0.9.4"
@@ -68,7 +66,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.4.2.ebuild b/sys-devel/gcc/gcc-4.4.2.ebuild
index 71dec80d72fd..c99ea33ebd5d 100644
--- a/sys-devel/gcc/gcc-4.4.2.ebuild
+++ b/sys-devel/gcc/gcc-4.4.2.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.2.ebuild,v 1.8 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.2.ebuild,v 1.9 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
#PIE_VER="10.1.5"
#SPECS_VER="0.9.4"
@@ -71,7 +69,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
diff --git a/sys-devel/gcc/gcc-4.4.3-r3.ebuild b/sys-devel/gcc/gcc-4.4.3-r3.ebuild
index 6956aacf5f28..ac45592c1975 100644
--- a/sys-devel/gcc/gcc-4.4.3-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.4.3-r3.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.3-r3.ebuild,v 1.10 2011/07/20 08:58:35 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.3-r3.ebuild,v 1.11 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.4"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="0.4.5"
SPECS_VER="0.2.0"
@@ -68,7 +66,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
@@ -80,7 +78,7 @@ src_unpack() {
}
pkg_setup() {
- gcc_pkg_setup
+ toolchain_pkg_setup
if use graphite ; then
ewarn "Graphite support is still experimental and unstable."
diff --git a/sys-devel/gcc/gcc-4.4.4-r2.ebuild b/sys-devel/gcc/gcc-4.4.4-r2.ebuild
index b83553afdbcf..a97d6f2962d6 100644
--- a/sys-devel/gcc/gcc-4.4.4-r2.ebuild
+++ b/sys-devel/gcc/gcc-4.4.4-r2.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.4-r2.ebuild,v 1.13 2011/03/11 07:06:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.4-r2.ebuild,v 1.14 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.4"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="0.4.5"
SPECS_VER="0.2.0"
@@ -70,7 +68,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
@@ -82,7 +80,7 @@ src_unpack() {
}
pkg_setup() {
- gcc_pkg_setup
+ toolchain_pkg_setup
if use graphite ; then
ewarn "Graphite support is still experimental and unstable."
diff --git a/sys-devel/gcc/gcc-4.4.5.ebuild b/sys-devel/gcc/gcc-4.4.5.ebuild
index dc175a761598..a6255577195b 100644
--- a/sys-devel/gcc/gcc-4.4.5.ebuild
+++ b/sys-devel/gcc/gcc-4.4.5.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.5.ebuild,v 1.11 2011/07/03 03:18:48 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.5.ebuild,v 1.12 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="0.4.5"
SPECS_VER="0.2.0"
@@ -70,7 +68,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
@@ -80,7 +78,7 @@ src_unpack() {
}
pkg_setup() {
- gcc_pkg_setup
+ toolchain_pkg_setup
if use graphite ; then
ewarn "Graphite support is still experimental and unstable."
diff --git a/sys-devel/gcc/gcc-4.4.6-r1.ebuild b/sys-devel/gcc/gcc-4.4.6-r1.ebuild
index b92b00eb8b11..3db838c50360 100644
--- a/sys-devel/gcc/gcc-4.4.6-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.4.6-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.6-r1.ebuild,v 1.1 2011/08/13 03:55:39 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.6-r1.ebuild,v 1.2 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="0.4.5"
SPECS_VER="0.2.0"
@@ -70,7 +68,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
@@ -80,7 +78,7 @@ src_unpack() {
}
pkg_setup() {
- gcc_pkg_setup
+ toolchain_pkg_setup
if use graphite ; then
ewarn "Graphite support is still experimental and unstable."
diff --git a/sys-devel/gcc/gcc-4.5.1-r1.ebuild b/sys-devel/gcc/gcc-4.5.1-r1.ebuild
index f89766ba2400..c9f8aea9406b 100644
--- a/sys-devel/gcc/gcc-4.5.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.5.1-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.1-r1.ebuild,v 1.5 2011/08/06 01:00:22 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.1-r1.ebuild,v 1.6 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.4"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="0.4.5"
SPECS_VER="0.2.0"
@@ -71,7 +69,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
@@ -83,7 +81,7 @@ src_unpack() {
}
pkg_setup() {
- gcc_pkg_setup
+ toolchain_pkg_setup
if use lto ; then
ewarn
diff --git a/sys-devel/gcc/gcc-4.5.2.ebuild b/sys-devel/gcc/gcc-4.5.2.ebuild
index 73ad7f9923d2..c6fd214cf6a9 100644
--- a/sys-devel/gcc/gcc-4.5.2.ebuild
+++ b/sys-devel/gcc/gcc-4.5.2.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.2.ebuild,v 1.5 2011/08/06 01:00:22 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.2.ebuild,v 1.6 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="0.4.5"
SPECS_VER="0.2.0"
@@ -71,7 +69,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
@@ -83,7 +81,7 @@ src_unpack() {
}
pkg_setup() {
- gcc_pkg_setup
+ toolchain_pkg_setup
if use lto ; then
ewarn
diff --git a/sys-devel/gcc/gcc-4.5.3-r1.ebuild b/sys-devel/gcc/gcc-4.5.3-r1.ebuild
index 34a6ba687c4c..e1d3f7178e50 100644
--- a/sys-devel/gcc/gcc-4.5.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.5.3-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.3-r1.ebuild,v 1.4 2011/09/25 01:52:54 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.3-r1.ebuild,v 1.5 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="0.4.5"
SPECS_VER="0.2.0"
@@ -71,7 +69,7 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
use vanilla && return 0
@@ -81,7 +79,7 @@ src_unpack() {
}
pkg_setup() {
- gcc_pkg_setup
+ toolchain_pkg_setup
if use lto ; then
ewarn
diff --git a/sys-devel/gcc/gcc-4.6.0.ebuild b/sys-devel/gcc/gcc-4.6.0.ebuild
index 243038b14098..ee7f74790927 100644
--- a/sys-devel/gcc/gcc-4.6.0.ebuild
+++ b/sys-devel/gcc/gcc-4.6.0.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.0.ebuild,v 1.4 2011/08/06 00:55:14 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.0.ebuild,v 1.5 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.2"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="0.4.5"
SPECS_VER="0.2.0"
diff --git a/sys-devel/gcc/gcc-4.6.1-r1.ebuild b/sys-devel/gcc/gcc-4.6.1-r1.ebuild
index 08e7feaa129a..80b8e99a8f68 100644
--- a/sys-devel/gcc/gcc-4.6.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.6.1-r1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.1-r1.ebuild,v 1.1 2011/08/13 03:55:39 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.1-r1.ebuild,v 1.2 2011/09/26 17:38:49 vapier Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
-ETYPE="gcc-compiler"
-
# Hardened gcc 4 stuff
PIE_VER="0.4.5"
SPECS_VER="0.2.0"