summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/cloop/Manifest2
-rw-r--r--sys-apps/cloop/cloop-2.00.ebuild72
-rw-r--r--sys-apps/cloop/files/digest-cloop-2.001
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-apps/cloop/Manifest b/sys-apps/cloop/Manifest
index 1ccd71bf8f43..af7a01f601eb 100644
--- a/sys-apps/cloop/Manifest
+++ b/sys-apps/cloop/Manifest
@@ -1,5 +1,5 @@
MD5 0aa22b40a06cb0a362cb73beb7326b8b cloop-0.68.ebuild 2060
-MD5 2616d01bc0fc8ecc55f6f8474d86bc0f cloop-2.00.ebuild 2038
+MD5 dfb42d89b2eb9366057275bb35202b96 cloop-2.00.ebuild 2037
MD5 3db0f939da34558d619d860bd53d6885 cloop-1.0.ebuild 1842
MD5 d1f639e42e93f782278ec9e7d4fe89fc ChangeLog 1071
MD5 13b52e04f9964bff66e8ce3f95695987 cloop-1.02.ebuild 1949
diff --git a/sys-apps/cloop/cloop-2.00.ebuild b/sys-apps/cloop/cloop-2.00.ebuild
new file mode 100644
index 000000000000..d1e38ad9b125
--- /dev/null
+++ b/sys-apps/cloop/cloop-2.00.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cloop/cloop-2.00.ebuild,v 1.1 2003/12/29 10:37:37 stuart Exp $
+
+inherit kernel-mod
+
+MY_PV="${PV}-1"
+MY_P="${PN}_${MY_PV}"
+DESCRIPTION="Compressed filesystem loopback kernel module"
+HOMEPAGE="http://www.knopper.net/knoppix/"
+SRC_URI="http://developer.linuxtag.net/knoppix/sources/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+S=${WORKDIR}/${PN}-${PV}
+
+badversion () {
+ eerror "This version of cloop will only compile against Linux 2.4.x"
+ eerror "Please change where /usr/src/linux points to, or export the KERNEL_DIR"
+ eerror "environment variable like this:"
+ eerror
+ eerror " KERNEL_DIR=\"<dir>\" emerge cloop"
+
+ die "cloop ${PV} only works with Linux 2.4"
+}
+
+badconfig () {
+ eerror "You have not enabled the zlib compression and/or decompression options"
+ eerror "in your Linux kernel."
+ eerror
+ eerror "You must configure both options to be compiled into your kernel; cloop"
+ eerror "will not compile if the zlib options are compiled as modules"
+ die
+}
+
+src_compile() {
+ kernel-mod_getversion
+ [ "$KV_MAJOR" = "2" ] && [ "$KV_MINOR" != "4" ] && badversion
+
+ . ${KERNEL_DIR}/.config || die "kernel has not been configured yet"
+ [ "$CONFIG_ZLIB_INFLATE" != "y" ] && badconfig
+ [ "$CONFIG_ZLIB_DEFLATE" != "y" ] && badconfig
+
+ kernel-mod_src_compile
+}
+
+src_install() {
+ insinto /lib/modules/$KV_VERSION_FULL/misc
+ doins cloop.o
+ dobin create_compressed_fs extract_compressed_fs
+ cp debian/create_compressed_fs.1 debian/extract_compressed_fs.1
+ doman debian/create_compressed_fs.1 debian/extract_compressed_fs.1
+ dodoc CHANGELOG README
+}
+
+pkg_postinst () {
+ einfo "Adding /dev/cloop devices"
+ if [ -e /dev/cloop ] ; then
+ rm -f /dev/cloop
+ fi
+ mknod /dev/cloop b 240 0 || die
+ if [ -e /dev/cloop1 ] ; then
+ rm -f /dev/cloop1
+ fi
+ mknod /dev/cloop1 b 240 1 || die
+}
diff --git a/sys-apps/cloop/files/digest-cloop-2.00 b/sys-apps/cloop/files/digest-cloop-2.00
new file mode 100644
index 000000000000..1e61447e13c1
--- /dev/null
+++ b/sys-apps/cloop/files/digest-cloop-2.00
@@ -0,0 +1 @@
+MD5 a18f5d97bae863b823c42cf6722ef769 cloop_2.00-1.tar.gz 21583