summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/alsa-lib/ChangeLog9
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.14_rc2-r1.ebuild84
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.14_rc2.ebuild71
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc23
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc2-r13
5 files changed, 169 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index c443eb576f10..886c04b61f07 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.218 2007/01/14 09:06:30 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.219 2007/01/16 22:56:46 flameeyes Exp $
+
+*alsa-lib-1.0.14_rc2-r1 (16 Jan 2007)
+*alsa-lib-1.0.14_rc2 (16 Jan 2007)
+
+ 16 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-lib-1.0.14_rc2.ebuild, +alsa-lib-1.0.14_rc2-r1.ebuild:
+ Version bump.
14 Jan 2007; Joseph Jezak <josejx@gentoo.org> alsa-lib-1.0.14_rc1.ebuild:
Marked ppc stable for bug #158678.
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.14_rc2-r1.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.14_rc2-r1.ebuild
new file mode 100644
index 000000000000..9f9ff1c7fd77
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.14_rc2-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.14_rc2-r1.ebuild,v 1.1 2007/01/16 22:56:46 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug alisp midi"
+
+RDEPEND="virtual/alsa
+ >=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file null empty share meter hooks lfloat ladspa dmix dshare dsnoop asym iec958
+softvol extplug ioplug"
+
+for plugin in ${IUSE_PCM_PLUGIN}; do
+ IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
+done
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ --disable-resmgr \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable midi instr) \
+ $(use_enable midi seq) $(use_enable midi aload) \
+ "--with-pcm-plugins=${ALSA_PCM_PLUGINS}" \
+ --disable-dependency-tracking \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try media-sound/alsa-driver before filing bugs about unstable"
+ elog "or missing output with in-kernel drivers. Misaligned versions of"
+ elog "alsa-lib and drivers used can cause problems."
+}
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.14_rc2.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.14_rc2.ebuild
new file mode 100644
index 000000000000..5cd632b2a9f0
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.14_rc2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.14_rc2.ebuild,v 1.1 2007/01/16 22:56:46 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug"
+
+RDEPEND="virtual/alsa
+ >=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_with debug) \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try media-sound/alsa-driver before filing bugs about unstable"
+ elog "or missing output with in-kernel drivers. Misaligned versions of"
+ elog "alsa-lib and drivers used can cause problems."
+}
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc2 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc2
new file mode 100644
index 000000000000..be8d19781cf1
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc2
@@ -0,0 +1,3 @@
+MD5 7ea3319690672d4bbd5f950947b705b7 alsa-lib-1.0.14rc2.tar.bz2 714700
+RMD160 639afd5affab58fb760aa4161a5714dba00e9460 alsa-lib-1.0.14rc2.tar.bz2 714700
+SHA256 9f32daa66ac6e0a549d4345f7b43588eee28b6abace5ad0aac271e4ddd06d349 alsa-lib-1.0.14rc2.tar.bz2 714700
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc2-r1 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc2-r1
new file mode 100644
index 000000000000..be8d19781cf1
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc2-r1
@@ -0,0 +1,3 @@
+MD5 7ea3319690672d4bbd5f950947b705b7 alsa-lib-1.0.14rc2.tar.bz2 714700
+RMD160 639afd5affab58fb760aa4161a5714dba00e9460 alsa-lib-1.0.14rc2.tar.bz2 714700
+SHA256 9f32daa66ac6e0a549d4345f7b43588eee28b6abace5ad0aac271e4ddd06d349 alsa-lib-1.0.14rc2.tar.bz2 714700