summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/scipy/ChangeLog7
-rw-r--r--sci-libs/scipy/files/scipy-0.9.0-superlu-4.3.patch20
-rw-r--r--sci-libs/scipy/metadata.xml13
-rw-r--r--sci-libs/scipy/scipy-0.10.1.ebuild128
-rw-r--r--sci-libs/scipy/scipy-0.11.0-r1.ebuild10
-rw-r--r--sci-libs/scipy/scipy-0.11.0.ebuild130
6 files changed, 19 insertions, 289 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 7e4f35f004e4..3d97477dbddd 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.85 2013/02/10 14:27:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.86 2013/02/21 00:37:29 bicatali Exp $
+
+ 21 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/scipy-0.9.0-superlu-4.3.patch, -scipy-0.10.1.ebuild,
+ -scipy-0.11.0.ebuild, metadata.xml, scipy-0.11.0-r1.ebuild:
+ Move to generic pkg-config, removed old
10 Feb 2013; Michał Górny <mgorny@gentoo.org> scipy-0.11.0-r1.ebuild:
Use distutils_install_for_testing().
diff --git a/sci-libs/scipy/files/scipy-0.9.0-superlu-4.3.patch b/sci-libs/scipy/files/scipy-0.9.0-superlu-4.3.patch
deleted file mode 100644
index c5b7176572e6..000000000000
--- a/sci-libs/scipy/files/scipy-0.9.0-superlu-4.3.patch
+++ /dev/null
@@ -1,20 +0,0 @@
- scipy/sparse/linalg/dsolve/_superluobject.c | 6 +++---
- 1 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/scipy/sparse/linalg/dsolve/_superluobject.c b/scipy/sparse/linalg/dsolve/_superluobject.c
-index e9ec0bd..2fde6cc 100644
---- a/scipy/sparse/linalg/dsolve/_superluobject.c
-+++ b/scipy/sparse/linalg/dsolve/_superluobject.c
-@@ -589,9 +589,9 @@ static int iterrefine_cvt(PyObject *input, IterRefine_t *value)
- {
- ENUM_CHECK_INIT;
- ENUM_CHECK(NOREFINE);
-- ENUM_CHECK(SINGLE);
-- ENUM_CHECK(DOUBLE);
-- ENUM_CHECK(EXTRA);
-+ ENUM_CHECK(SLU_SINGLE);
-+ ENUM_CHECK(SLU_DOUBLE);
-+ ENUM_CHECK(SLU_EXTRA);
- ENUM_CHECK_FINISH("invalid value for 'IterRefine' parameter");
- }
-
diff --git a/sci-libs/scipy/metadata.xml b/sci-libs/scipy/metadata.xml
index cae437e54ae0..50532c00c267 100644
--- a/sci-libs/scipy/metadata.xml
+++ b/sci-libs/scipy/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+<herd>sci</herd>
+<longdescription lang="en">
SciPy is an open source library of scientific tools for Python. SciPy
supplements the popular numpy module, gathering a variety of high level
science and engineering modules together as a single package.
@@ -10,7 +10,10 @@
special functions, signal and image processing, genetic algorithms, ODE
solvers, and others.
</longdescription>
- <use>
- <flag name="umfpack">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
- </use>
+<use>
+ <flag name="umfpack">Adds support for sparse solving with <pkg>sci-libs/umfpack</pkg></flag>
+</use>
+<upstream>
+ <remote-id type="pypi">scipy</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/sci-libs/scipy/scipy-0.10.1.ebuild b/sci-libs/scipy/scipy-0.10.1.ebuild
deleted file mode 100644
index 7c186691d743..000000000000
--- a/sci-libs/scipy/scipy-0.10.1.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.10.1.ebuild,v 1.6 2012/10/16 19:47:58 jlec Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="*::3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.3 *-jython *-pypy-*"
-
-inherit eutils fortran-2 distutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy"
-SRC_URI="
- mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${P}-html.zip
- http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${P}-ref.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc test umfpack"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- dev-python/numpy
- sci-libs/arpack
- virtual/cblas
- virtual/lapack
- umfpack? ( sci-libs/umfpack )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? ( dev-python/nose )
- umfpack? ( dev-lang/swig )"
-
-RDEPEND="${CDEPEND}
- dev-python/imaging"
-
-DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
-
-pkg_setup() {
- fortran-2_pkg_setup
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use umfpack && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
- python_pkg_setup
-}
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${P}-html.zip -d html || die
- fi
-}
-
-pc_incdir() {
- pkg-config --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g'
-}
-
-pc_libdir() {
- pkg-config --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g'
-}
-
-pc_libs() {
- pkg-config --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g'
-}
-
-src_prepare() {
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-}
-
-src_compile() {
- distutils_src_compile ${SCIPY_FCONFIG}
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} \
- || die "install test failed"
- pushd "${S}/test-${PYTHON_ABI}/"lib*/python > /dev/null
- PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full')" \
- 2>&1 | tee test.log
- grep -q ^ERROR test.log && die "test failed"
- popd > /dev/null
- rm -fr test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install ${SCIPY_FCONFIG}
- use doc && dohtml -r "${WORKDIR}"/html/* && dodoc "${DISTDIR}"/${P}*pdf
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy/scipy-0.11.0-r1.ebuild b/sci-libs/scipy/scipy-0.11.0-r1.ebuild
index 3417401b981f..c707ee438301 100644
--- a/sci-libs/scipy/scipy-0.11.0-r1.ebuild
+++ b/sci-libs/scipy/scipy-0.11.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.11.0-r1.ebuild,v 1.3 2013/02/10 14:27:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.11.0-r1.ebuild,v 1.4 2013/02/21 00:37:29 bicatali Exp $
EAPI=5
@@ -9,7 +9,7 @@ PYTHON_COMPAT=( python{2_5,2_6,2_7} )
inherit eutils fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy"
+HOMEPAGE="http://www.scipy.org/"
SRC_URI="
mirror://sourceforge/${PN}/${P}.tar.gz
doc? (
@@ -49,17 +49,17 @@ src_unpack() {
}
pc_incdir() {
- pkg-config --cflags-only-I $@ | \
+ $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
sed -e 's/^-I//' -e 's/[ ]*-I/:/g'
}
pc_libdir() {
- pkg-config --libs-only-L $@ | \
+ $(tc-getPKG_CONFIG) --libs-only-L $@ | \
sed -e 's/^-L//' -e 's/[ ]*-L/:/g'
}
pc_libs() {
- pkg-config --libs-only-l $@ | \
+ $(tc-getPKG_CONFIG) --libs-only-l $@ | \
sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
-e 's/^-l//' -e 's/[ ]*-l/,/g'
}
diff --git a/sci-libs/scipy/scipy-0.11.0.ebuild b/sci-libs/scipy/scipy-0.11.0.ebuild
deleted file mode 100644
index a2ec94159de2..000000000000
--- a/sci-libs/scipy/scipy-0.11.0.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.11.0.ebuild,v 1.2 2012/12/13 16:07:11 jlec Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="*::3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.3 *-jython *-pypy-*"
-
-inherit eutils fortran-2 distutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy"
-SRC_URI="
- mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${P}-html.zip
- http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${P}-ref.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc test umfpack"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- dev-python/numpy
- sci-libs/arpack
- virtual/cblas
- virtual/lapack
- umfpack? ( sci-libs/umfpack )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? ( dev-python/nose )
- umfpack? ( dev-lang/swig )"
-
-RDEPEND="${CDEPEND}
- dev-python/imaging"
-
-DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
-
-pkg_setup() {
- fortran-2_pkg_setup
- python_pkg_setup
-}
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${P}-html.zip -d html || die
- fi
-}
-
-pc_incdir() {
- pkg-config --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g'
-}
-
-pc_libdir() {
- pkg-config --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g'
-}
-
-pc_libs() {
- pkg-config --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g'
-}
-
-src_prepare() {
- local libdir="${EPREFIX}"/usr/$(get_libdir)
-
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use umfpack && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-}
-
-src_compile() {
- distutils_src_compile ${SCIPY_FCONFIG}
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} \
- || die "install test failed"
- pushd "${S}/test-${PYTHON_ABI}/"lib*/python > /dev/null
- PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full',verbose=10)" \
- 2>&1 | tee test.log
- grep -q ^ERROR test.log && die "test failed"
- popd > /dev/null
- rm -fr test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install ${SCIPY_FCONFIG}
- use doc && dohtml -r "${WORKDIR}"/html/* && dodoc "${DISTDIR}"/${P}*pdf
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}