summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/jdbc2-postgresql/ChangeLog11
-rw-r--r--dev-java/jdbc2-postgresql/jdbc2-postgresql-7.3-r1.ebuild22
-rw-r--r--dev-java/jdbc2-postgresql/jdbc2-postgresql-7.4-r1.ebuild21
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-java/jdbc2-postgresql/ChangeLog b/dev-java/jdbc2-postgresql/ChangeLog
index bf51e91b37f8..d688a024c8ae 100644
--- a/dev-java/jdbc2-postgresql/ChangeLog
+++ b/dev-java/jdbc2-postgresql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jdbc2-postgresql
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc2-postgresql/ChangeLog,v 1.15 2006/10/05 17:27:54 gustavoz Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc2-postgresql/ChangeLog,v 1.16 2008/02/08 02:51:11 betelgeuse Exp $
+
+*jdbc2-postgresql-7.4-r1 (08 Feb 2008)
+*jdbc2-postgresql-7.3-r1 (08 Feb 2008)
+
+ 08 Feb 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +jdbc2-postgresql-7.3-r1.ebuild, +jdbc2-postgresql-7.4-r1.ebuild:
+ Migrate to generation 2 eclasses.
05 Oct 2006; Gustavo Zacarias <gustavoz@gentoo.org>
jdbc2-postgresql-7.3.ebuild, jdbc2-postgresql-7.4.ebuild:
diff --git a/dev-java/jdbc2-postgresql/jdbc2-postgresql-7.3-r1.ebuild b/dev-java/jdbc2-postgresql/jdbc2-postgresql-7.3-r1.ebuild
new file mode 100644
index 000000000000..2a1c1fdfe29a
--- /dev/null
+++ b/dev-java/jdbc2-postgresql/jdbc2-postgresql-7.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc2-postgresql/jdbc2-postgresql-7.3-r1.ebuild,v 1.1 2008/02/08 02:51:11 betelgeuse Exp $
+
+inherit java-pkg-2
+
+At="pg73jdbc2.jar"
+S=${WORKDIR}
+DESCRIPTION="JDBC Driver for PostgreSQL"
+SRC_URI="http://jdbc.postgresql.org/download/${At}"
+HOMEPAGE="http://jdbc.postgresql.org/"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+LICENSE="POSTGRESQL"
+SLOT="5"
+DEPEND=""
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.2"
+
+src_install() {
+ java-pkg_dojar ${DISTDIR}/${At}
+}
diff --git a/dev-java/jdbc2-postgresql/jdbc2-postgresql-7.4-r1.ebuild b/dev-java/jdbc2-postgresql/jdbc2-postgresql-7.4-r1.ebuild
new file mode 100644
index 000000000000..07afc97bb61b
--- /dev/null
+++ b/dev-java/jdbc2-postgresql/jdbc2-postgresql-7.4-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc2-postgresql/jdbc2-postgresql-7.4-r1.ebuild,v 1.1 2008/02/08 02:51:11 betelgeuse Exp $
+
+inherit java-pkg-2
+
+At="pg74.215.jdbc2.jar"
+S=${WORKDIR}
+DESCRIPTION="JDBC Driver for PostgreSQL"
+SRC_URI="http://jdbc.postgresql.org/download/${At}"
+HOMEPAGE="http://jdbc.postgresql.org/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+LICENSE="POSTGRESQL"
+SLOT="6"
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.2"
+
+src_install() {
+ java-pkg_dojar ${DISTDIR}/${At}
+}