summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/elfsh/elfsh-0.51_beta3.ebuild16
-rw-r--r--dev-libs/elfutils/elfutils-0.89.ebuild18
-rw-r--r--dev-util/elfkickers/elfkickers-2.0a.ebuild12
3 files changed, 17 insertions, 29 deletions
diff --git a/dev-libs/elfsh/elfsh-0.51_beta3.ebuild b/dev-libs/elfsh/elfsh-0.51_beta3.ebuild
index 5a3ac43008cb..b3ce607d8561 100644
--- a/dev-libs/elfsh/elfsh-0.51_beta3.ebuild
+++ b/dev-libs/elfsh/elfsh-0.51_beta3.ebuild
@@ -1,26 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfsh/elfsh-0.51_beta3.ebuild,v 1.1 2003/08/21 14:42:43 solar Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfsh/elfsh-0.51_beta3.ebuild,v 1.2 2003/11/11 13:02:05 vapier Exp $
MY_PV=${PV/_beta/b}
S=${WORKDIR}/${PN}-${MY_PV}
-DESCRIPTION="ELFsh is an interactive and scriptable ELF machine to play with executable files, shared libraries and relocatable ELF32 objects"
+DESCRIPTION="interactive and scriptable ELF machine to play with executable files, shared libraries and relocatable ELF32 objects"
HOMEPAGE="http://devhell.org/projects/elfsh"
SRC_URI="http://elfsh.segfault.net/files/elfsh-${MY_PV}-portable.tgz
http://devhell.org/projects/elfsh/files/elfsh-${MY_PV}-portable.tgz"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
DEPEND="virtual/glibc
>=dev-libs/expat-1.95
- >=sys-devel/gettext-0.11
-"
-
-RDEPEND="${DEPEND}"
+ >=sys-devel/gettext-0.11"
src_unpack() {
unpack ${A}
@@ -31,13 +27,11 @@ src_unpack() {
}
src_compile() {
- cd ${S}
# emacs does not have to be a requirement.
emake ETAGS=echo || die "emake failed"
}
src_install() {
- cd ${S}
dodir /usr/share/elfsh
einstall DESTDIR=${D} || die "einstall failed"
}
diff --git a/dev-libs/elfutils/elfutils-0.89.ebuild b/dev-libs/elfutils/elfutils-0.89.ebuild
index 279da21c666d..4dd0d4dbc5ef 100644
--- a/dev-libs/elfutils/elfutils-0.89.ebuild
+++ b/dev-libs/elfutils/elfutils-0.89.ebuild
@@ -1,20 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.89.ebuild,v 1.2 2003/10/29 20:21:07 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.89.ebuild,v 1.3 2003/11/11 12:57:27 vapier Exp $
inherit eutils
-IUSE="nls"
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Libraries and utilities to handle compiled objects.
-This should be a drop in replacement for libelf."
-SRC_URI="mirror://gentoo/${P}.tar.gz"
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
HOMEPAGE="http://www.redhat.com/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="OpenSoftware"
SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~mips"
+IUSE="nls"
DEPEND=">=sys-libs/glibc-2.3.2
>=sys-devel/binutils-2.14.90.0.6
@@ -34,10 +31,11 @@ src_unpack() {
}
src_compile() {
- econf --program-prefix="eu-" \
+ econf \
+ --program-prefix="eu-" \
--enable-shared \
- `use_enable nls` || die "./configure failed"
-
+ `use_enable nls` \
+ || die "./configure failed"
emake || die
}
diff --git a/dev-util/elfkickers/elfkickers-2.0a.ebuild b/dev-util/elfkickers/elfkickers-2.0a.ebuild
index db82ab4fbe82..29eb1390d9de 100644
--- a/dev-util/elfkickers/elfkickers-2.0a.ebuild
+++ b/dev-util/elfkickers/elfkickers-2.0a.ebuild
@@ -1,24 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/elfkickers/elfkickers-2.0a.ebuild,v 1.4 2003/09/29 21:56:04 solar Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/dev-util/elfkickers/elfkickers-2.0a.ebuild,v 1.5 2003/11/11 12:59:40 vapier Exp $
MY_PN=${PN/elf/ELF}
S=${WORKDIR}/${MY_PN}
-DESCRIPTION="ELFkickers is a collection of programs to manipulate ELF files: sstrip, rebind, elfls, elftoc, ebfc"
+DESCRIPTION="collection of programs to manipulate ELF files: sstrip, rebind, elfls, elftoc, ebfc"
HOMEPAGE="http://www.muppetlabs.com/~breadbox/software/elfkickers.html"
SRC_URI="http://www.muppetlabs.com/~breadbox/pub/software/${MY_PN}-${PV}.tar.gz"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 sparc"
DEPEND="virtual/glibc
dev-lang/nasm"
-RDEPEND="${DEPEND}"
-
src_unpack() {
unpack ${A}
# custom made patch to keep the compiler warnings down
@@ -26,7 +23,6 @@ src_unpack() {
}
src_compile() {
- cd ${S}
emake -C ebfc
emake -C elfls
emake -C elftoc