summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/gnunet/ChangeLog7
-rw-r--r--net-p2p/gnunet/files/0.7.3-configure.patch18
-rw-r--r--net-p2p/gnunet/files/0.7.3-libtool.patch15
-rw-r--r--net-p2p/gnunet/gnunet-0.7.3-r1.ebuild5
4 files changed, 43 insertions, 2 deletions
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
index 2086b0514210..d4dbdbc75b0a 100644
--- a/net-p2p/gnunet/ChangeLog
+++ b/net-p2p/gnunet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/gnunet
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.63 2008/02/25 14:11:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.64 2008/06/30 16:09:45 armin76 Exp $
+
+ 30 Jun 2008; Raúl Porcel <armin76@gentoo.org>
+ +files/0.7.3-configure.patch, +files/0.7.3-libtool.patch,
+ gnunet-0.7.3-r1.ebuild:
+ Add patch to fix bugs #226195 and #220765
25 Feb 2008; Raúl Porcel <armin76@gentoo.org> -gnunet-0.7.2c-r1.ebuild,
gnunet-0.7.3-r1.ebuild:
diff --git a/net-p2p/gnunet/files/0.7.3-configure.patch b/net-p2p/gnunet/files/0.7.3-configure.patch
new file mode 100644
index 000000000000..5bb36443b15e
--- /dev/null
+++ b/net-p2p/gnunet/files/0.7.3-configure.patch
@@ -0,0 +1,18 @@
+svn diff -r7052:7110 https://gnunet.org/svn/GNUnet/configure.ac
+r7110 | amatus | 2008-06-09 18:34:31 +0200 (Mo, 09 Jun 2008) | 2 lines
+Added AC_PROG_CXX to make configure work in archlinux.
+
+See also https://bugs.gentoo.org/show_bug.cgi?id=226195
+
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 7052)
++++ configure.ac (revision 7110)
+@@ -31,6 +31,7 @@
+ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_CPP
++AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
diff --git a/net-p2p/gnunet/files/0.7.3-libtool.patch b/net-p2p/gnunet/files/0.7.3-libtool.patch
new file mode 100644
index 000000000000..078fc9072a90
--- /dev/null
+++ b/net-p2p/gnunet/files/0.7.3-libtool.patch
@@ -0,0 +1,15 @@
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 6742)
++++ configure.ac (revision 6836)
+@@ -39,9 +39,9 @@
+ AC_LIBTOOL_WIN32_DLL
+ AC_LIBLTDL_INSTALLABLE
+ AC_PROG_LIBTOOL
+-AC_CONFIG_SUBDIRS(libltdl)
+ AC_CANONICAL_HOST
+ AC_LIB_LTDL
++m4_ifdef([_AC_SEEN_TAG(libltdl)], [], [AC_CONFIG_SUBDIRS(libltdl)])
+ AC_SUBST(LTDLINCL)
+ AC_SUBST(LIBLTDL)
+ AC_SUBST(MKDIR_P)
diff --git a/net-p2p/gnunet/gnunet-0.7.3-r1.ebuild b/net-p2p/gnunet/gnunet-0.7.3-r1.ebuild
index 0fcfeb173dc7..24ad72c7a46b 100644
--- a/net-p2p/gnunet/gnunet-0.7.3-r1.ebuild
+++ b/net-p2p/gnunet/gnunet-0.7.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.7.3-r1.ebuild,v 1.3 2008/02/25 14:11:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.7.3-r1.ebuild,v 1.4 2008/06/30 16:09:45 armin76 Exp $
inherit eutils autotools
@@ -60,6 +60,9 @@ src_unpack() {
sed -i "s:AC_DEFINE_UNQUOTED..HAVE_GTK.*:true:" configure.ac
fi
+ epatch "${FILESDIR}"/${PV}-libtool.patch
+ epatch "${FILESDIR}"/${PV}-configure.patch
+
AT_M4DIR="${S}/m4" eautoreconf
}