summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/cyrus-imap-admin/ChangeLog8
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/net-mail/cyrus-imap-admin/ChangeLog b/net-mail/cyrus-imap-admin/ChangeLog
index d6dcf3f0f622..6c1dbd67c337 100644
--- a/net-mail/cyrus-imap-admin/ChangeLog
+++ b/net-mail/cyrus-imap-admin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/cyrus-imap-admin
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.69 2008/01/18 21:22:13 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.70 2008/06/04 19:06:51 dertobi123 Exp $
+
+*cyrus-imap-admin-2.3.12_p2 (04 Jun 2008)
+
+ 04 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +cyrus-imap-admin-2.3.12_p2.ebuild:
+ Version bump
18 Jan 2008; Tobias Scherbaum <dertobi123@gentoo.org>
-files/cyrus-imap-admin-2.2.12-gcc4.patch,
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild
new file mode 100644
index 000000000000..4d1baad83cbd
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild,v 1.1 2008/06/04 19:06:51 dertobi123 Exp $
+
+inherit autotools perl-app eutils
+
+MY_PV=${PV/_/}
+
+PIC_PATCH_VER="2.2"
+DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~hppa ~ppc64"
+IUSE="ssl kerberos"
+
+RDEPEND=">=sys-libs/db-3.2
+ >=dev-lang/perl-5.6.1
+ >=dev-libs/cyrus-sasl-2.1.13
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="$RDEPEND
+ sys-devel/libtool
+ >=sys-devel/autoconf-2.58
+ sys-devel/automake
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ # Versioned symbols.
+ epatch "${FILESDIR}/${PN}-${PIC_PATCH_VER}-fPIC.patch"
+
+ # Recreate configure.
+ WANT_AUTOCONF="2.5"
+ eautoreconf
+
+ # When linking with rpm, you need to link with more libraries.
+ sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"
+
+}
+
+src_compile() {
+
+ local myconf
+ myconf="${myconf} `use_with ssl openssl`"
+ myconf="${myconf} `use_with kerberos gssapi`"
+
+ econf \
+ --disable-server \
+ --enable-murder \
+ --enable-listext \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-auth=unix \
+ --with-perl=/usr/bin/perl \
+ --enable-cyradm \
+ ${myconf} || die "econf failed"
+
+ emake -C "${S}/lib" all || die "compile problem"
+ emake -C "${S}/perl" all || die "compile problem"
+}
+
+src_install () {
+ make -C "${S}/perl" DESTDIR="${D}" install || die "install problem"
+ fixlocalpod # bug #98122
+}