summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xcape/ChangeLog11
-rw-r--r--x11-misc/xcape/metadata.xml18
-rw-r--r--x11-misc/xcape/xcape-1.0.ebuild28
3 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/xcape/ChangeLog b/x11-misc/xcape/ChangeLog
new file mode 100644
index 000000000000..243818fe7159
--- /dev/null
+++ b/x11-misc/xcape/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/xcape
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcape/ChangeLog,v 1.1 2013/03/10 08:50:29 pinkbyte Exp $
+
+*xcape-1.0 (10 Mar 2013)
+
+ 10 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> +xcape-1.0.ebuild,
+ +metadata.xml:
+ Initial commit, wrt bug #455992. Ebuild by aditsu <aditsu AT yahoo.com>, he
+ will maintain this package through proxy maintainers
+
diff --git a/x11-misc/xcape/metadata.xml b/x11-misc/xcape/metadata.xml
new file mode 100644
index 000000000000..43e57ddbd5aa
--- /dev/null
+++ b/x11-misc/xcape/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>aditsu@yahoo.com</email>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">alols/xcape</remote-id>
+ <bugs-to>https://github.com/alols/xcape/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xcape/xcape-1.0.ebuild b/x11-misc/xcape/xcape-1.0.ebuild
new file mode 100644
index 000000000000..ce3d20f9a753
--- /dev/null
+++ b/x11-misc/xcape/xcape-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcape/xcape-1.0.ebuild,v 1.1 2013/03/10 08:50:29 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
+HOMEPAGE="https://github.com/alols/xcape"
+SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}