summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tcltk/expect/ChangeLog8
-rw-r--r--dev-tcltk/expect/expect-5.43.0-r1.ebuild122
-rw-r--r--dev-tcltk/expect/expect-5.43.0.ebuild53
3 files changed, 152 insertions, 31 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index c4c280aecbd3..0d08cd64ac21 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.68 2010/04/13 07:51:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.69 2010/04/16 12:07:25 jlec Exp $
+
+*expect-5.43.0-r1 (16 Apr 2010)
+
+ 16 Apr 2010; Justin Lecher <jlec@gentoo.org> expect-5.43.0.ebuild,
+ +expect-5.43.0-r1.ebuild:
+ reverting back and moving prefix import into -r1
*expect-5.44.1.15 (12 Apr 2010)
diff --git a/dev-tcltk/expect/expect-5.43.0-r1.ebuild b/dev-tcltk/expect/expect-5.43.0-r1.ebuild
new file mode 100644
index 000000000000..5f1498a7e765
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.43.0-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0-r1.ebuild,v 1.1 2010/04/16 12:07:25 jlec Exp $
+
+EAPI="3"
+
+WANT_AUTOCONF="2.1"
+inherit autotools eutils multilib versionator
+
+DESCRIPTION="tool for automating interactive applications"
+HOMEPAGE="http://expect.nist.gov/"
+SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="X doc"
+
+# We need dejagnu for src_test, but dejagnu needs expect
+# to compile/run, so we cant add dejagnu to DEPEND :/
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
+RDEPEND="${DEPEND}"
+
+NON_MICRO_V=${PN}-$(get_version_component_range 1-2)
+S=${WORKDIR}/${NON_MICRO_V}
+
+src_prepare() {
+ # fix install_name on darwin
+ [[ ${CHOST} == *-darwin* ]] && \
+ epatch "${FILESDIR}"/${P}-darwin.patch
+epatch "${FILESDIR}"/"${P}"-multilib.patch
+
+ #fix the rpath being set to /var/tmp/portage/...
+ epatch "${FILESDIR}"/expect-5.39.0-libdir.patch
+
+ #Removes references to functions that Tcl 8.5 no longer exposes.
+ epatch "${FILESDIR}"/"${P}"-avoid-tcl-internals-1.patch
+
+ sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expect.man
+ sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expectk.man
+ #stops any example scripts being installed by default
+ sed -i \
+ -e '/^install:/s/install-libraries //' \
+ -e 's/^SCRIPTS_MANPAGES = /_&/' \
+ Makefile.in
+ #fixes "TCL_REG_BOSONLY undeclared" error due to a change in tcl8.5
+ sed -i -e 's/^#include "tcl.h"/#include "tclInt.h"/' \
+ exp_inter.c exp_command.c
+ #fix missing define of HAVE_UNISTD_H in Dbg.c
+ sed -i -e 's/^\(#include <stdio\.h>\)/\1\n#include "expect_cf.h"/' \
+ Dbg.c
+
+ # fix implicit missing declarations (bug 204878)
+ epatch "${FILESDIR}"/"${P}"-missing-includes.patch
+
+# epatch "${FILESDIR}"/"${P}"-ldflags.patch
+
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+ local tcl_version
+ tcl_version="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
+ TCL_HDIR="${EPREFIX}/usr/$(get_libdir)/tcl${tcl_version}/include"
+
+ #configure needs to find the file tclConfig.sh is
+ myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${TCL_HDIR}"
+
+ if use X ; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir)"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf --enable-shared
+}
+
+src_compile() {
+ emake TCLHDIRDASHI="-I${TCL_HDIR}/generic -I${TCL_HDIR}/unix" \
+ || die "emake failed"
+}
+
+src_test() {
+ # we need dejagnu to do tests ... but dejagnu needs
+ # expect ... so don't do tests unless we have dejagnu
+ type -p runtest || return 0
+ make check || die "make check failed"
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)
+ make install INSTALL_ROOT="${D}" || die "make install failed"
+
+ dodoc ChangeLog FAQ HISTORY NEWS README || die
+
+ local lib_basename="lib${NON_MICRO_V/-/}"
+ rm "${ED}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${lib_basename}.a"
+
+ # bug #182278 - /usr/lib/expect.so symlink
+ ln -s "${lib_basename}.so" "${ED}/usr/$(get_libdir)/lib${PN}.so"
+
+ #install examples if 'doc' is set
+ if use doc ; then
+ docinto examples
+ local scripts=$(make -qp | \
+ sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
+ insinto /usr/share/doc/${PF}/examples
+ doins ${scripts} || die
+ local scripts_manpages=$(make -qp | \
+ sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
+ for m in ${scripts_manpages}; do
+ dodoc example/${m}.man
+ done
+ dodoc example/README
+ fi
+}
diff --git a/dev-tcltk/expect/expect-5.43.0.ebuild b/dev-tcltk/expect/expect-5.43.0.ebuild
index e43bfbdf52d9..f565abf39e8c 100644
--- a/dev-tcltk/expect/expect-5.43.0.ebuild
+++ b/dev-tcltk/expect/expect-5.43.0.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.22 2010/04/13 14:57:33 jlec Exp $
-
-EAPI="3"
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.23 2010/04/16 12:07:25 jlec Exp $
WANT_AUTOCONF="2.1"
-inherit autotools eutils multilib versionator
+inherit autotools eutils versionator
DESCRIPTION="tool for automating interactive applications"
HOMEPAGE="http://expect.nist.gov/"
@@ -13,7 +11,7 @@ SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="X doc"
# We need dejagnu for src_test, but dejagnu needs expect
@@ -25,11 +23,10 @@ RDEPEND="${DEPEND}"
NON_MICRO_V=${PN}-$(get_version_component_range 1-2)
S=${WORKDIR}/${NON_MICRO_V}
-src_prepare() {
- # fix install_name on darwin
- [[ ${CHOST} == *-darwin* ]] && \
- epatch "${FILESDIR}"/${P}-darwin.patch
-epatch "${FILESDIR}"/"${P}"-multilib.patch
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/"${P}"-multilib.patch
#fix the rpath being set to /var/tmp/portage/...
epatch "${FILESDIR}"/expect-5.39.0-libdir.patch
@@ -37,8 +34,8 @@ epatch "${FILESDIR}"/"${P}"-multilib.patch
#Removes references to functions that Tcl 8.5 no longer exposes.
epatch "${FILESDIR}"/"${P}"-avoid-tcl-internals-1.patch
- sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expect.man
- sed -i "s#/usr/local/bin#${EPREFIX}/usr/bin#" expectk.man
+ sed -i 's#/usr/local/bin#/usr/bin#' expect.man
+ sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
#stops any example scripts being installed by default
sed -i \
-e '/^install:/s/install-libraries //' \
@@ -54,35 +51,31 @@ epatch "${FILESDIR}"/"${P}"-multilib.patch
# fix implicit missing declarations (bug 204878)
epatch "${FILESDIR}"/"${P}"-missing-includes.patch
-# epatch "${FILESDIR}"/"${P}"-ldflags.patch
-
eautoconf
}
-src_configure() {
+src_compile() {
local myconf
local tcl_version
- tcl_version="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
- TCL_HDIR="${EPREFIX}/usr/$(get_libdir)/tcl${tcl_version}/include"
+ local tcl_hdir
+ tcl_version=$(echo 'puts [set tcl_version]' | tclsh)
+ tcl_hdir="/usr/$(get_libdir)/tcl${tcl_version}/include"
#configure needs to find the file tclConfig.sh is
- myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${TCL_HDIR}"
+ myconf="--with-tcl=/usr/$(get_libdir) --with-tclinclude=$tcl_hdir"
if use X ; then
#--with-x is enabled by default
#configure needs to find the file tkConfig.sh and tk.h
#tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir)"
+ myconf="$myconf --with-tk=/usr/$(get_libdir)"
else
#configure knows that tk depends on X so just disable X
myconf="$myconf --without-x"
fi
- econf $myconf --enable-shared
-}
-
-src_compile() {
- emake TCLHDIRDASHI="-I${TCL_HDIR}/generic -I${TCL_HDIR}/unix" \
+ econf $myconf --enable-shared || die "econf failed"
+ emake TCLHDIRDASHI="-I${tcl_hdir}/generic -I${tcl_hdir}/unix" \
|| die "emake failed"
}
@@ -97,21 +90,21 @@ src_install() {
dodir /usr/$(get_libdir)
make install INSTALL_ROOT="${D}" || die "make install failed"
- dodoc ChangeLog FAQ HISTORY NEWS README || die
+ dodoc ChangeLog FAQ HISTORY NEWS README
local lib_basename="lib${NON_MICRO_V/-/}"
- rm "${ED}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${lib_basename}.a"
+ rm "${D}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${lib_basename}.a"
# bug #182278 - /usr/lib/expect.so symlink
- ln -s "${lib_basename}.so" "${ED}/usr/$(get_libdir)/lib${PN}.so"
+ ln -s "${lib_basename}.so" "${D}/usr/$(get_libdir)/lib${PN}.so"
#install examples if 'doc' is set
if use doc ; then
docinto examples
local scripts=$(make -qp | \
sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
- insinto /usr/share/doc/${PF}/examples
- doins ${scripts} || die
+ exeinto /usr/share/doc/${PF}/examples
+ doexe ${scripts}
local scripts_manpages=$(make -qp | \
sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
for m in ${scripts_manpages}; do