summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/xcopilot/ChangeLog9
-rw-r--r--app-emulation/xcopilot/Manifest4
-rw-r--r--app-emulation/xcopilot/files/digest-xcopilot-0.6.61
-rw-r--r--app-emulation/xcopilot/metadata.xml8
-rw-r--r--app-emulation/xcopilot/xcopilot-0.6.6.ebuild33
5 files changed, 54 insertions, 1 deletions
diff --git a/app-emulation/xcopilot/ChangeLog b/app-emulation/xcopilot/ChangeLog
new file mode 100644
index 000000000000..2331ecbfa2ab
--- /dev/null
+++ b/app-emulation/xcopilot/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/xcopilot
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xcopilot/ChangeLog,v 1.1 2004/01/27 01:40:13 zul Exp $
+
+*xcopilot-0.6.6 (26 Jan 2004)
+
+ 26 Jan 2004; <zul@gentoo.org> xcopilot-0.6.6.ebuild:
+ Initial version written by me.
+
diff --git a/app-emulation/xcopilot/Manifest b/app-emulation/xcopilot/Manifest
index 76215691c4c0..fa509b80703a 100644
--- a/app-emulation/xcopilot/Manifest
+++ b/app-emulation/xcopilot/Manifest
@@ -1,2 +1,4 @@
-MD5 a523ababb9d0483edd208d507b3cbb0e xcopilot-0.6.6.ebuild 638
+MD5 effeeb7dfc61bb8c0088e1c5fb03b0bc xcopilot-0.6.6.ebuild 741
+MD5 17c068c7ec33d3f4e0aaeddd76ff9773 ChangeLog 343
+MD5 7e285f080272b311b0eb8b0028928e07 metadata.xml 219
MD5 c29c08134028b23d656076378349c7ae files/digest-xcopilot-0.6.6 70
diff --git a/app-emulation/xcopilot/files/digest-xcopilot-0.6.6 b/app-emulation/xcopilot/files/digest-xcopilot-0.6.6
new file mode 100644
index 000000000000..4a97f7019a1c
--- /dev/null
+++ b/app-emulation/xcopilot/files/digest-xcopilot-0.6.6
@@ -0,0 +1 @@
+MD5 2fc27f20e4434581af7a7d5cd6fd6c8e xcopilot-0.6.6-uc0.tar.gz 365229
diff --git a/app-emulation/xcopilot/metadata.xml b/app-emulation/xcopilot/metadata.xml
new file mode 100644
index 000000000000..d66bb0cd26df
--- /dev/null
+++ b/app-emulation/xcopilot/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>zul@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emulation/xcopilot/xcopilot-0.6.6.ebuild b/app-emulation/xcopilot/xcopilot-0.6.6.ebuild
new file mode 100644
index 000000000000..4b458af4b434
--- /dev/null
+++ b/app-emulation/xcopilot/xcopilot-0.6.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xcopilot/xcopilot-0.6.6.ebuild,v 1.1 2004/01/27 01:40:13 zul Exp $
+
+MY_P="xcopilot-0.6.6-uc0"
+
+DESCRIPTION="A pilot emulator."
+SRC_URI="http://www.uclinux.org/pub/uClinux/utilities/${MY_P}.tar.gz"
+HOMEPAGE="http://www.uclinux.org"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="virtual/glibc
+ virtual/x11
+ app-arch/dpkg"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --disable-autorun || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS README NEWS README.uClinux
+
+ einfo "See ${D}/usr/share/${P}/README.uClinux for more info"
+}