summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/seamonkey-bin/ChangeLog9
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild13
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-2.6.ebuild (renamed from www-client/seamonkey-bin/seamonkey-bin-2.4.1.ebuild)49
3 files changed, 39 insertions, 32 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 9a614fca3cda..06b16fa647c1 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.109 2011/12/05 22:01:56 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.110 2011/12/20 08:31:09 polynomial-c Exp $
+
+*seamonkey-bin-2.6 (20 Dec 2011)
+
+ 20 Dec 2011; Lars Wendler <polynomial-c@gentoo.org>
+ -seamonkey-bin-2.4.1.ebuild, seamonkey-bin-2.5.ebuild,
+ +seamonkey-bin-2.6.ebuild:
+ Version bump. Removed old.
05 Dec 2011; Lars Wendler <polynomial-c@gentoo.org> seamonkey-bin-2.5.ebuild:
Ebuild improvements.
diff --git a/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild b/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild
index 6f1823913beb..4881e1282b24 100644
--- a/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild
+++ b/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild,v 1.3 2011/12/05 22:01:56 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-2.5.ebuild,v 1.4 2011/12/20 08:31:09 polynomial-c Exp $
EAPI="4"
@@ -11,12 +11,13 @@ ja lt nb-NO nl pl pt-PT ru sk sv-SE tr zh-CN)
MY_PV="${PV/_alpha/a}"
MY_P="${PN}-${MY_PV}"
+MY_PN="${PN/-bin}"
DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
-HTTP_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${MY_PV}/"
+FTP_URI="ftp://ftp.mozilla.org/pub/mozilla.org/${MY_PN}/releases/"
SRC_URI="
- amd64? ( ${HTTP_URI}/contrib/seamonkey-${MY_PV}.en-US.linux-x86_64.tar.bz2 -> ${PN}_x86_64-${PV}.tar.bz2 )
- x86? ( ${HTTP_URI}/linux-i686/en-US/seamonkey-${MY_PV}.tar.bz2 -> ${PN}_i686-${PV}.tar.bz2 )"
+ amd64? ( ${FTP_URI}/${MY_PV}/contrib/seamonkey-${MY_PV}.en-US.linux-x86_64.tar.bz2 -> ${PN}_x86_64-${PV}.tar.bz2 )
+ x86? ( ${FTP_URI}/${MY_PV}/linux-i686/en-US/seamonkey-${MY_PV}.tar.bz2 -> ${PN}_i686-${PV}.tar.bz2 )"
HOMEPAGE="http://www.seamonkey-project.org/"
RESTRICT="strip"
QA_EXECSTACK="opt/seamonkey/*"
@@ -42,7 +43,7 @@ for X in "${LANGS[@]}" ; do
if [[ ${X} != en ]] && [[ ${X} != en-US ]]; then
SRC_URI="${SRC_URI}
linguas_${X/-/_}? (
- ${HTTP_URI}/langpack/seamonkey-${MY_PV}.${X}.langpack.xpi -> ${P/-bin/}-${X}.xpi )"
+ ${FTP_URI}/${MY_PV}/langpack/seamonkey-${MY_PV}.${X}.langpack.xpi -> ${P/-bin/}-${X}.xpi )"
fi
IUSE="${IUSE} linguas_${X/-/_}"
# Install all the specific locale xpis if there's no generic locale xpi
@@ -50,7 +51,7 @@ for X in "${LANGS[@]}" ; do
if ! has ${X%%-*} "${LANGS[@]}"; then
SRC_URI="${SRC_URI}
linguas_${X%%-*}? (
- ${HTTP_URI}/langpack/seamonkey-${MY_PV}.${X}.langpack.xpi -> ${P/-bin/}-${X}.xpi )"
+ ${FTP_URI}/${MY_PV}/langpack/seamonkey-${MY_PV}.${X}.langpack.xpi -> ${P/-bin/}-${X}.xpi )"
IUSE="${IUSE} linguas_${X%%-*}"
fi
done
diff --git a/www-client/seamonkey-bin/seamonkey-bin-2.4.1.ebuild b/www-client/seamonkey-bin/seamonkey-bin-2.6.ebuild
index ed7b00c9e07e..21644603da32 100644
--- a/www-client/seamonkey-bin/seamonkey-bin-2.4.1.ebuild
+++ b/www-client/seamonkey-bin/seamonkey-bin-2.6.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-2.4.1.ebuild,v 1.1 2011/11/16 08:51:20 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-2.6.ebuild,v 1.1 2011/12/20 08:31:09 polynomial-c Exp $
EAPI="4"
-inherit eutils mozilla-launcher multilib mozextension pax-utils
+inherit eutils mozilla-launcher multilib mozextension pax-utils nsplugins fdo-mime gnome2-utils
LANGS=(be ca cs de en-GB en-US es-AR es-ES fi fr gl hu it
ja lt nb-NO nl pl pt-PT ru sk sv-SE tr zh-CN)
MY_PV="${PV/_alpha/a}"
MY_P="${PN}-${MY_PV}"
+MY_PN="${PN/-bin}"
DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
-HTTP_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${MY_PV}/"
-SRC_URI="${HTTP_URI}/linux-i686/en-US/seamonkey-${MY_PV}.tar.bz2"
+FTP_URI="ftp://ftp.mozilla.org/pub/mozilla.org/${MY_PN}/releases/"
+SRC_URI="
+ amd64? ( ${FTP_URI}/${MY_PV}/contrib/seamonkey-${MY_PV}.en-US.linux-x86_64.tar.bz2 -> ${PN}_x86_64-${PV}.tar.bz2 )
+ x86? ( ${FTP_URI}/${MY_PV}/linux-i686/en-US/seamonkey-${MY_PV}.tar.bz2 -> ${PN}_i686-${PV}.tar.bz2 )"
HOMEPAGE="http://www.seamonkey-project.org/"
RESTRICT="strip"
QA_EXECSTACK="opt/seamonkey/*"
@@ -26,18 +29,11 @@ IUSE="startup-notification"
DEPEND="app-arch/unzip"
RDEPEND="dev-libs/dbus-glib
+ >=media-libs/alsa-lib-1.0.16
+ >=x11-libs/gtk+-2.10:2
x11-libs/libXrender
x11-libs/libXt
x11-libs/libXmu
- x86? (
- >=x11-libs/gtk+-2.2:2
- >=media-libs/alsa-lib-1.0.16
- )
- amd64? (
- >=app-emulation/emul-linux-x86-baselibs-20081109
- >=app-emulation/emul-linux-x86-gtklibs-20081109
- >=app-emulation/emul-linux-x86-soundlibs-20081109
- )
!<www-client/seamonkey-bin-2"
S="${WORKDIR}/seamonkey"
@@ -47,7 +43,7 @@ for X in "${LANGS[@]}" ; do
if [[ ${X} != en ]] && [[ ${X} != en-US ]]; then
SRC_URI="${SRC_URI}
linguas_${X/-/_}? (
- ${HTTP_URI}/langpack/seamonkey-${MY_PV}.${X}.langpack.xpi -> ${P/-bin/}-${X}.xpi )"
+ ${FTP_URI}/${MY_PV}/langpack/seamonkey-${MY_PV}.${X}.langpack.xpi -> ${P/-bin/}-${X}.xpi )"
fi
IUSE="${IUSE} linguas_${X/-/_}"
# Install all the specific locale xpis if there's no generic locale xpi
@@ -55,7 +51,7 @@ for X in "${LANGS[@]}" ; do
if ! has ${X%%-*} "${LANGS[@]}"; then
SRC_URI="${SRC_URI}
linguas_${X%%-*}? (
- ${HTTP_URI}/langpack/seamonkey-${MY_PV}.${X}.langpack.xpi -> ${P/-bin/}-${X}.xpi )"
+ ${FTP_URI}/${MY_PV}/langpack/seamonkey-${MY_PV}.${X}.langpack.xpi -> ${P/-bin/}-${X}.xpi )"
IUSE="${IUSE} linguas_${X%%-*}"
fi
done
@@ -87,13 +83,6 @@ linguas() {
done
}
-pkg_setup() {
- # This is a binary x86 package => ABI=x86
- # Please keep this in future versions
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
- has_multilib_profile && ABI="x86"
-}
-
src_unpack() {
unpack ${A}
@@ -148,13 +137,23 @@ EOF
insinto /etc/revdep-rebuild
doins "${FILESDIR}"/10${PN} || die
- ln -sfn "/usr/$(get_libdir)/nsbrowser/plugins" \
- "${D}${MOZILLA_FIVE_HOME}/plugins" || die
+ # Handle plugins dir through nsplugins.eclass
+ share_plugins_dir
# Required in order to use plugins and even run seamonkey on hardened.
pax-mark m "${ED}"/${MOZILLA_FIVE_HOME}/{seamonkey,seamonkey-bin,plugin-container}
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
- use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
+ # Update mimedb for the new .desktop file
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
}